Linking contacts does not work

Bug #847078 reported by Joshua Lückers on 2011-09-11
342
This bug affects 85 people
Affects Status Importance Assigned to Milestone
folks
Fix Released
Medium
folks (Debian)
Fix Released
Unknown
folks (Ubuntu)
Medium
Unassigned

Bug Description

I tried to link a contact (gTalk and MSN) but it does not seem to work.
This worked fine under Ubuntu 11.04.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: empathy 3.1.91-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Sun Sep 11 16:55:51 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110904)
SourcePackage: empathy
UpgradeStatus: No upgrade log present (probably fresh install)

Joshua Lückers (joshualuckers) wrote :
Changed in empathy (Ubuntu):
status: New → Confirmed

I'm getting the same issue, where the contact I want to link has GTalk and Yahoo! accounts.

Ben Clapp (ibenrunnin) wrote :

I'm having this problem, didn't have it previously in ubuntu 11.04

Same problem but I can't link two MSN contacts, and not only two contacts with differents protocols.
Same problem with gnome-contacts so maybe it's a lib used by these two softwares that is buggy...

Thomas Broda (spam-magnet) wrote :

Same here...can't link two contacts (Jabber)

Using empathy and empathy-common 3.2.0-0ubuntu1

C de-Avillez (hggdh2) on 2011-10-08
tags: added: regression-release

Same problem here trying to link a Facebook and a Gtalk account

Changed in empathy (Debian):
status: Unknown → New
Changed in folks:
importance: Unknown → Medium
status: Unknown → New
affects: empathy (Ubuntu) → folks (Ubuntu)
affects: empathy (Debian) → folks (Debian)
Laurent Bigonville (bigon) wrote :

Could you try to reproduce this bug with empathy started like this

FOLKS_DEBUG=folks empathy &> folks.log

and then attach the folks.log to this bug report.

thanks

Changed in folks (Debian):
status: New → Confirmed
Changed in folks:
status: New → Incomplete
Changed in folks (Ubuntu):
status: Confirmed → Incomplete
Felix Haller (felixhaller) wrote :

these are the last lines of folks.log created with the method above.

===================================================================================
(empathy:2809): folks-DEBUG: individual-aggregator.vala:1261: Replacing Individuals due to linking:
(empathy:2809): folks-DEBUG: individual.vala:892: Creating new Individual with 1 Personas: 0xe3bbd0
(empathy:2809): folks-DEBUG: individual.vala:1186: Buddies

(empathy:2809): empathy-WARNING **: Failed to link personas: Can't link personas with no primary store.
===================================================================================

i don't want to post the whole file because there are some private informations in there.

hope it helps.

greets felix

I've attached the output of FOLKS_DEBUG=folks empathy on the upstream bug. You can see it here: http://bugzilla-attachments.gnome.org/attachment.cgi?id=199752

Changed in folks (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in folks:
status: Incomplete → Fix Released
timothymowens (timothymowens) wrote :

I was already running the latest revision of Empathy and I also had this issue. I fixed this on my Oneiric 11.10 install by running: sudo apt-get install libfolks*

Granted, I many not need these other packages, but it works, so I'm happy.

Jeff Van Epps (lordbah) wrote :

Installing just libfolks-eds25 did the job for me, as a workaround until the empathy patch makes its way here.

Changed in folks (Debian):
status: Confirmed → Fix Released
Brandon Mayes (bdmayes) wrote :

I had the same problem attempting to link a Google/MSN contact. I can confirm that installing libfolks-eds25 corrected the problem. Thanks Jeff!

Nathan Clemons (stormerider) wrote :

Happens to me as well... here's my folks.log file.

Nick (soapduk) wrote :

Installing libfolks-eds25 seems to have fixed the problem for me too, so far.

Changed in folks (Debian):
status: Fix Released → Confirmed
Raik (jinto) wrote :

I installed empathy on alpha2 of kubuntu 12.04 and was not able to link contacts. When i started empathy on the console i've got the follown error:

folks-WARNING **: Failed to find primary PersonaStore with type ID 'eds' and ID 'system'.
Individuals will not be linked properly and creating new links between Personas will not work.
The configured primary PersonaStore's backend may not be installed. If you are unsure, check with your distribution.

When i figured out, that this eds thing uses some evolution addressbook to save meta contacts, i uninstalled libfolks-eds25 and hoped that empathy would use some other store to save meta contacts but that didn't work.
My next try was to install evolution and libfolks-eds25, starte evolution, abort the initial configuration dialog and uninstall evolution. That fixed the problem for me.

The problem would be solved, if libfolks whould create the evolution things that it needs to store meta contacts it self if they doesn't exist.

Brian Curtis (bcurtiswx) wrote :

This doesn't seem to be an issue with empathy in Precise. Could anyone with this issue in a non-alpha/beta Precise install please let us know steps to reproduce this bug?

Changed in folks (Ubuntu):
status: Triaged → Incomplete
Brian Curtis (bcurtiswx) wrote :

Sorry, this bug has been fixed upstream and Precise holds a version where this fix has been applied. Anyone still having this issue please open a new bug report.

Changed in folks (Ubuntu):
status: Incomplete → Fix Released
Changed in folks (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.