Ubuntu

fluxbox right click menu doesnt work in gutsy

Reported by Kreuger Burns on 2007-09-28
22
Affects Status Importance Assigned to Milestone
blackbox (Ubuntu)
Undecided
Unassigned
fluxbox (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: fluxbox

Since upgrading to Gutsy from Feisty yesterday, I have no right click menu (to access everything) on the desktop using Fluxbox. I can only access it using the hotkey that produces RootMenu.

Steffen780 (steffenfelso) wrote :

I've had this problem with fluxbox on Gentoo, turns out the fix was to simply edit ~/.fluxbox/keys like this:
OnDesktop Mouse1 :hideMenus
OnDesktop Mouse2 :workspaceMenu
OnDesktop Mouse3 :rootMenu
OnDesktop Mouse4 :nextWorkspace
OnDesktop Mouse5 :prevWorkspace

(well, only the Mouse3 line is for the menu, the other stuff is what the guy on Gentoo had and it looks useful).
Try this see if it fixes it for you.

Kreuger Burns (car-crazy33) wrote :

Awesome thank you, that fixed that. But now when I click off the menu it won't go away. I have to choose a program for it to disappear. It seemed this was a problem with the upgrade. I'm getting more updates now hopefully it'll fix it completely.

Kreuger Burns (car-crazy33) wrote :

oh I guess I'd probably just need that hide menus one wouldn't I? haha

libertyernie (libertyernie) wrote :

This fix didn't work for me.
I am using fluxbox 1.0~rc3-4 on gutsy.

It doesn't work for me either. I didn't edit my ~/.fluxbox/keys, and "OnDesktop Mouse3 :rootMenu" has always been there.

Sorry, I figure it out: the file "menu" was missing from my .fluxbox directory. I just copied the generic one from /etc and now it works. If anyone confirms it, I think this bug could be closed.

libertyernie (libertyernie) wrote :

Here are the contents of my default ~/.fluxbox/menu:

[begin] (fluxbox)
[include] (/etc/X11/fluxbox/fluxbox-menu)
[end]

But the new "menu" package no longer has a /etc/X11/fluxbox/fluxbox-menu file.
I really don't know where it's been moved to, though.

Kreuger Burns (car-crazy33) wrote :

Mine was still there David.

@maybeway36 (and @Kreuger Burns):

yes, it can't find the file "/etc/X11/fluxbox/fluxbox-menu", so it doesn't display anything while right clicking! :)
Try to run update-menus, the manually rename the crated file (don't remember the name) to "~/.fluxbox/menu". It should work.

libertyernie (libertyernie) wrote :

That worked perfectly. Thanks!
P.S. The generated file to rename is ~/.fluxbox/fluxbox-menu

Kreuger Burns (car-crazy33) wrote :

So then wouldn't I just have to change it to point to my menu file in I believe the init.

I suppose you could run update-menus as root and it might go to
/etc/X11/fluxbox where it's actually supposed to be.

On 10/11/07, Kreuger Burns <email address hidden> wrote:
> So then wouldn't I just have to change it to point to my menu file in I
> believe the init.
>
> --
> fluxbox right click menu doesnt work in gutsy
> https://bugs.launchpad.net/bugs/146414
> You received this bug notification because you are a direct subscriber
> of the bug.
>

This is from another fluxbox bug report (https://bugs.launchpad.net/ubuntu/+source/fluxbox/+bug/154523).

just do:
sudo update-menus

this solved my right-key problem under Gutsy Gibbon install of fluxbox.

ubuntu_demon (ubuntu-demon) wrote :

I can confirm this bug (both on my laptop and on an older desktop)

Changed in fluxbox:
status: New → Confirmed
flix2704 (flix2704) wrote :

i can confirm this bug on gutsy gibbon

runnining update-menu
and copying fluxbox-menu to menu in ~/.fluxbox was solving the problem
(cp ~/.fluxbox/fluxbox-menu ~/.fluxbox/menu)

(thanks Davide R!)

i can confirm this bug on gutsy gibbon, too.

Tested in 2007-01-10. Problem solved using only
$sudo update-menus

Daniel T Chen (crimsun) on 2008-11-23
Changed in blackbox:
status: New → Fix Released
Paul Tagliamonte  (paultag) wrote :

Hello,

Is this problem still present in Fluxbox 1.1.1 ?

Changed in fluxbox (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers