wrong soundfont path

Bug #1832417 reported by stsp on 2019-06-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fluidsynth (Debian)
Fix Released
Unknown
fluidsynth (Ubuntu)
Undecided
Unassigned

Bug Description

libfliudsynth provides an API to locate the default
soundfonts. Its like below:

ret = fluid_settings_dupstr(settings, "synth.default-soundfont", &sfont);
if (ret == 0 || access(sfont, R_OK) != 0) {
    ret = fluid_synth_sfload(synth, sfont, TRUE);
}

Under ubuntu it returns
/usr/share/soundfonts/default.sf2
but its unclear what package provides this,
if any. At least not fluid-soundfont-gm.

This font path can be specified during fluidsynth
build. The valid one under ubuntu seems to be
/usr/share/sounds/sf2/FluidR3_GM.sf2
But as this font may not be installed, I would
suggest fluidsynth to check against the pre-defined
list of pathes, and return error if nothing is found.

This bug is a duplicate of Debian #929182. Since this package is inherited unpatched from Debian, please comment on the bug at this link: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929182

Changed in fluidsynth (Ubuntu):
status: New → Confirmed
Changed in fluidsynth (Debian):
status: Unknown → Confirmed
Changed in fluidsynth (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.