flickrfs.py crashed with FuseError in main()

Bug #138392 reported by Helder Ribeiro on 2007-09-09
32
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flickrfs (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: flickrfs

I ran it without parameters (the instructions on the webpage said the first run would fire up the configuration process) and it crashed after getting the flickr authorization.

Authorization complete.
fuse: missing mountpoint
Sets are being populated in the background.
Traceback (most recent call last):
  File "/usr/bin/flickrfs", line 1096, in <module>
    server.main()
  File "/usr/lib/python2.5/site-packages/fuse.py", line 713, in main
    main(**d)
fuse.FuseError: filesystem initialization failed

ProblemType: Crash
Architecture: i386
Date: Sun Sep 9 06:48:58 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/share/pycentral/flickrfs/site-packages/flickrfs/flickrfs.py
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: video
Package: flickrfs 1.3.9.1-5ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/flickrfs
ProcCwd: /home/helder/code/git
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/var/lib/gems/1.8/bin:/var/lib/gems/1.8/bin
 LANG=pt_BR.UTF-8
 LANGUAGE=pt_BR:pt:en
PythonArgs: ['/usr/bin/flickrfs']
SourcePackage: flickrfs
Title: flickrfs.py crashed with FuseError in main()
Uname: Linux sputnik 2.6.22-11-generic #1 SMP Fri Sep 7 05:07:05 GMT 2007 i686 GNU/Linux

Helder Ribeiro (obvio171) wrote :

The same happened here.

Ubuntu Gusty Gibon (7.10) Beta 1
Linux note 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux
ii flickrfs 1.3.9.1-5ubuntu1 virtual filesystem for flickr online photosh

The error:

joaoolavo@note:~$ flickrfs
Authorizing with flickr...
Authorization complete.
fuse: missing mountpoint
Sets are being populated in the background.
Traceback (most recent call last):
  File "/usr/bin/flickrfs", line 1096, in <module>
    server.main()
  File "/usr/lib/python2.5/site-packages/fuse.py", line 713, in main
    main(**d)
fuse.FuseError: filesystem initialization failed

Ricardo Pérez López (ricardo) wrote :

I have the same problem. Confirmed.

Changed in flickrfs:
status: New → Confirmed

I have the same problem on gutsy final.

Aaron Sells (aaron-sells) wrote :

I was getting this error but worked around it by executing flickrfs as super user. However, my sets do not populate in the mount location which is a problem.

Linux Euphorica 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU

sellsa@Euphorica:~$ sudo su
[sudo] password for sellsa:
root@Euphorica:/home/sellsa# fusermount -u /home/sellsa/flickr
umount: /home/sellsa/flickr: device is busy
umount: /home/sellsa/flickr: device is busy
root@Euphorica:/home/sellsa# fusermount -u /home/sellsa/flickr
root@Euphorica:/home/sellsa# flickrfs /home/sellsa/flickr/
Authorizing with flickr...
Authorization complete.
root@Euphorica:/home/sellsa# cd flickr/
root@Euphorica:/home/sellsa/flickr# ls -al
total 4
drwxr-xr-x 3 root root 0 2007-10-22 13:42 .
drwxr-xr-x 72 sellsa sellsa 4096 2007-10-22 13:06 ..
drwxr-xr-x 4 root root 0 2007-10-22 13:42 tags
root@Euphorica:/home/sellsa/flickr#

wuziq (spamziq) wrote :

I don't believe that you need to be a superuser, but you do need to specify the mountpoint. I am, however, getting the same problem where the sets do not populate.

wuziq@wuziq:~$ flickrfs flickrfsmount
Authorizing with flickr...
Authorization complete.
wuziq@wuziq:~$

We should be seeing "Sets are being populated in the background."

karlrt (karlrt) wrote :

for me exactly the same happens.

First i forgot to specify a mountpoint, but after

# mkdir /media/flickr/
$ flickrfs /media/flickr/

the exact same error still occurs, the only way wich helped me out was the superuser:

# flickrfs /media/flickr/

but i dont want to run flickrfs as superuser, i want to be able as normal user to copy my photos

febs (spelta) wrote :

The workaround is:

$ sudo chmod 755 /bin/fusermount
$ sudo chmod u+s /bin/fusermount
$ sudo chmod 666 /dev/fuse

Then it will work fine.

If those lines are the same lines included in the setup instructions
on the flickrfs website, then I've already done that :)

On Thu, Feb 28, 2008 at 2:23 PM, febs <email address hidden> wrote:
> The workaround is:
>
> $ sudo chmod 755 /bin/fusermount
> $ sudo chmod u+s /bin/fusermount
> $ sudo chmod 666 /dev/fuse
>
> Then it will work fine.
>
>
>
> --
> flickrfs.py crashed with FuseError in main()
> https://bugs.launchpad.net/bugs/138392
> You received this bug notification because you are a direct subscriber
> of the bug.
>

febs (spelta) wrote :

> If those lines are the same lines included in the setup instructions
> on the flickrfs website, then I've already done that :)

not exactly. Those lines shows the wrong path fpr the fusermount
application.

On Thu, Feb 28, 2008 at 2:23 PM, febs <email address hidden> wrote:
> > The workaround is:
> >
> > $ sudo chmod 755 /bin/fusermount
> > $ sudo chmod u+s /bin/fusermount
> > $ sudo chmod 666 /dev/fuse
> >
> > Then it will work fine.
> >
> >
> >
> > --
> > flickrfs.py crashed with FuseError in main()
> > https://bugs.launchpad.net/bugs/138392
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
> --
> flickrfs.py crashed with FuseError in main()
> https://bugs.launchpad.net/bugs/138392
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Fabio

exactt (giesbert) wrote :

IMO the best solution is to add the user to the "fuse" group(requires relogin to become effective). what do you think?

Daniel Hahler (blueyed) on 2008-03-22
Changed in flickrfs:
importance: Undecided → Medium
Timo Jyrinki (timo-jyrinki) wrote :

Just tested flickrfs on Ubuntu 15.04's newest version and it worked fine for me.

Changed in flickrfs (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers