Consuming more data than the given size in KDE Neon's discover

Bug #1885362 reported by dipesh kumar
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flatpak (Ubuntu)
Undecided
Unassigned

Bug Description

My point is that in KDE Neon's discover the app name 'Telgram Desktop' was shown as the download size of 332MB. But when I started downloading, it actually consumes 700+ MB to download completely.
I had connected my wifi to my mobile hotspot. And I was out of data and I had to purchase another pack to get the download completed.
I think it's a bug in Discover.

Revision history for this message
Andrew Hayzen (ahayzen) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

This bug potentially sounds like it is an issue with the discover calculations rather than flatpak, but let's check the sizes first.

Assuming that you have effectively just installed org.telegram.desktop org.kde.Platform//5.14 this would be 348.2MB of download, as shown below. (note there are some extra extensions such as org.freedesktop.Platform.GL.default//19.08, org.freedesktop.Platform.VAAPI.Intel//19.08 etc that could have also been installed - but these would only add another 93.8MB). However if such extensions are being installed, maybe discover isn't taking these into account?

Could you check which flatpak's you have installed ? And if possible the history of when they were installed? eg with $ flatpak list and $ flatpak history

It could also be possible that while you were installing the flatpak's another service performed network downloads such as unattended-upgrades or snap refreshes etc.

Therefore until there is more info as to which flatpak packages were installed, I am going to mark this bug as incomplete.

$ flatpak remote-info flathub org.telegram.desktop

Telegram Desktop - Telegram Desktop messenger

        ID: org.telegram.desktop
       Ref: app/org.telegram.desktop/x86_64/stable
      Arch: x86_64
    Branch: stable
   Version: 2.1.13
   License: GPL-3.0
Collection: org.flathub.Stable
  Download: 23.7 MB
 Installed: 49.4 MB
   Runtime: org.kde.Platform/x86_64/5.14

       Sdk: org.kde.Sdk/x86_64/5.14
    Commit: 134bf1b199a333c599e6d65b59568e4d1761c508f591adfa6dd9d18a0b620413
    Parent: 0f2b9e677e59d83228fee400209534437a4a10883dda8214fbf3126eeb011a0d
   Subject: Update to 2.1.13 (1a9a9b86)
      Date: 2020-06-24 10:26:24 +0000

$ flatpak remote-info flathub org.kde.Platform//5.14

KDE Application Platform - Shared libraries used by KDE applications

        ID: org.kde.Platform
       Ref: runtime/org.kde.Platform/x86_64/5.14
      Arch: x86_64
    Branch: 5.14
   License: GPL-2.0+
Collection: org.flathub.Stable
  Download: 324.5 MB
 Installed: 925.8 MB

    Commit: b2c33a73a8090ae9ab4a9802f9a26c6016b96f4e593ba577cb58483c85fa1345
    Parent: 710b312bd61bc199b086b0a82ea483b39f4aeeec4920bc1d8b655efa3f81c752
   Subject: build of org.kde.Sdk, Thu May 28 12:48:22 UTC 2020 (a0d676f934717ac697de659dcf92b838014dfe25)
      Date: 2020-05-28 20:11:47 +0000

Changed in flatpak (Ubuntu):
status: New → Incomplete
Revision history for this message
dipesh kumar (dipesh9218) wrote :

Actually I have checked this and nothing was being downloaded in the background. Because when I tried to download anything from browser let's say a movie of 1GB, it just took 1GB in downloading and nothing more than it.
But it is consuming more data only in the case of 'Discover'.

After $ flatpak list, it shows that I downloaded 2.1.3 (stable) version of 'Telegram Desktop'.

Revision history for this message
Andrew Hayzen (ahayzen) wrote :

OK, I have tried uninstalling all flatpak's in a virtual machine and then installing telegram and it's dependencies.

You can see the console output here https://pastebin.ubuntu.com/p/MGKhsQfnYN/ I would have expected it to use around 440MB download from the estimates given, but the network interface is reporting around 540MB used.

This is not as a dramatic increase such as yours, and I wonder if it is related to the way ostree fetches many files or something.

I would recommend opening a bug upstream here https://github.com/flatpak/flatpak/issues/ as this bug could be in flatpak or ostree or maybe somewhere else, then once there is feedback from upstream we can action this bug. (also feel free to link/copy info from my pastebin and this bug in the upstream bug).

Revision history for this message
dipesh kumar (dipesh9218) wrote :

Okay Thank You.

Andrew Hayzen (ahayzen)
Changed in flatpak (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers