[SRU] [bionic] new upstream microrelease flatpak 1.0.9

Bug #1844666 reported by Andrew Hayzen on 2019-09-19
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
flatpak (Ubuntu)
Undecided
Andrew Hayzen
Bionic
Undecided
Unassigned

Bug Description

This is a request to SRU the latest microrelease of the flatpak 1.0 series into bionic.

[Impact]

New upstream microrelease of flatpak, which brings backported fixes and improvements - the main being allowing use of extra_data in runtimes (which is required by the openh264 extension).

Bionic is currently at 1.0.8, whereas 1.0.9 is available upstream.

[Test Case]

The main fix in this release is allowing for use of extra_data in runtimes, I have tested this works with a test repository, see the test plan below for testing flatpak itself.

[Regression Potential]

Flatpak has a test suite, which is run on build across all architectures and passes.

There is also a manual test plan https://wiki.ubuntu.com/Process/Merges/TestPlan/flatpak. I have confirmed that 1.0.9 passes with this test plan on bionic.

Flatpak has autopkgtests enabled http://autopkgtest.ubuntu.com/packages/f/flatpak which is passing on bionic.

Regression potential is low, and upstream is very responsive to any issues raised.

Andrew Hayzen (ahayzen) on 2019-09-19
Changed in flatpak (Ubuntu):
assignee: nobody → Andrew Hayzen (ahayzen)
status: New → In Progress
Andrew Hayzen (ahayzen) on 2019-09-24
description: updated
Andrew Hayzen (ahayzen) on 2019-09-24
summary: - [bionic] new upstream microrelease flatpak 1.0.9
+ [SRU] [bionic] new upstream microrelease flatpak 1.0.9
Amr Ibrahim (amribrahim1987) wrote :

Yes, in Bionic at 1.0.8, I get this warning when I try to update openh264:

Installing: org.freedesktop.Platform.openh264/x86_64/19.08 from flathub
Warning: installing org.freedesktop.Platform.openh264/x86_64/19.08 failed: runtime/org.freedesktop.Platform.openh264/x86_64/19.08 requests a newer version of flatpak (1.4.2)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in flatpak (Ubuntu Bionic):
status: New → Confirmed
Niklas Sombert (ytvwld) wrote :

For me this message mentions multiple supported versions: flatpak (1.4.2;1.2.5;1.0.9;)
So updating from 1.0.8 to 1.0.9 would be enough to be able to update org.freedesktop.Platform.openh264.

sanette (sanette-linux) wrote :

same here, using Kde Neon user edition (based on Ubuntu 18.04)

Warning: Failed to install org.freedesktop.Platform.openh264/x86_64/19.08: runtime/org.freedesktop.Platform.openh264/x86_64/19.08 needs a later flatpak version (1.4.2;1.2.5;1.0.9;)

Changed in flatpak (Ubuntu):
status: In Progress → Invalid

Hello Andrew, or anyone else affected,

Accepted flatpak into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/flatpak/1.0.9-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in flatpak (Ubuntu Bionic):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-bionic
Andrew Hayzen (ahayzen) wrote :

Awesome, thanks !

I have run the test plan on a Bionic VM, which passed all tests successfully - I have noted the version of flatpak used below. Autopkgtest's are also passing. Therefore I am marking this as verification-done-bionic.

$ apt policy flatpak
flatpak:
  Installed: 1.0.9-0ubuntu0.1
  Candidate: 1.0.9-0ubuntu0.1
  Version table:
 *** 1.0.9-0ubuntu0.1 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic-proposed/universe amd64 Packages
        100 /var/lib/dpkg/status
     1.0.8-0ubuntu0.18.04.1 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
     0.11.3-3 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flatpak - 1.0.9-0ubuntu0.1

---------------
flatpak (1.0.9-0ubuntu0.1) bionic; urgency=medium

  * Update to 1.0.9 (LP: #1844666)
  * New upstream release
    - Allow use of extra_data for runtimes, this is required for the
      openh264 extension.

 -- Andrew Hayzen <email address hidden> Sat, 21 Sep 2019 21:30:00 +0000

Changed in flatpak (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for flatpak has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers