Flatpaks using org.kde.Platform take minutes to launch on Kubuntu 19.04

Bug #1829269 reported by Eric Adams on 2019-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flatpak (Ubuntu)
Undecided
Unassigned
xdg-desktop-portal-kde (Ubuntu)
Undecided
Unassigned

Bug Description

Apparently, based on my experience, any flatpak that uses org.kde.Platform takes between 1 and 4 minute to launch. For example, this is the case with Telegram Desktop and Kdenlive. However this same behavior is not seen with GNOME-based flatpaks such as GIMP. Also, I have only encountered this behavior on Kubuntu 19.04. Ubuntu, Xubuntu, Ubuntu MATE do not exhibit this behavior so I assume there is something specific to Kubuntu 19.04 at fault.

Flatpak is installed as described on the Flathub quick start guide. If I launch from the terminal with something like `flatpak run -v org.telegram.desktop' it gets to "running bwrap" and just sits for 1-3 minutes. It does eventually launch and then runs as normal.

Eric Adams (esa1975) wrote :

Setting to Ubuntu (actually Kubuntu 19.04...not sure how that works) and Package flatpak.

affects: launchpad → flatpak (Ubuntu)
summary: - kubuntu flatpak
+ Flatpaks using org.kde.Platform take minutes to launch on Kubuntu 19.04
Andrew Hayzen (ahayzen) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

This does seem odd, on my Ubuntu system Telegram launches immediately.

Could you paste (or pastebin) the output of the following commands?

$ apt policy bubblewrap flatpak
$ flatpak run -vv org.telegram.desktop

And also in the last command indicate exactly where it gets stuck ?

Eric Adams (esa1975) wrote :

Hello. Sure thing. See below.

Output of apt policy:

apt policy bubblewrap flatpak
bubblewrap:
  Installed: 0.3.1-4
  Candidate: 0.3.1-4
  Version table:
 *** 0.3.1-4 500
        500 http://us.archive.ubuntu.com/ubuntu disco/main amd64 Packages
        100 /var/lib/dpkg/status
flatpak:
  Installed: 1.2.4-1
  Candidate: 1.2.4-1
  Version table:
 *** 1.2.4-1 500
        500 http://us.archive.ubuntu.com/ubuntu disco/universe amd64 Packages
        100 /var/lib/dpkg/status

Output of flatpak run -vv is attached as a text file to avoid a wall of text.

It gets stuck on "Running 'bwrap --args 36 telegram-desktop'".

I also happened to notice some messages in the journald log related to this stating "Marshalling failed: Variant containing QVariant::Invalid passed in arguments". I pasted a sample of that log at the bottom of the attached text file.

Let me know if there's anything else I can provide. Thanks!

Andrew Hayzen (ahayzen) wrote :

Thanks ! To me this looks like flatpak is launching the app correctly and the app is instead hanging inside Qt when trying to communicate using xdg-desktop-portal-kde with the host for settings. I'll have a chat with upstream, but this might be a xdg-desktop-portal-kde issue.

Andrew Hayzen (ahayzen) wrote :

OK speaking with upstream we think this is likely a xdg-desktop-portal-kde bug, so I am marking this as affect that project and marking as invalid for flatpak.

I'm also trying to work out how to report a bug against https://phabricator.kde.org/source/xdg-desktop-portal-kde/ if I can figure it out I'll link it back here :-)

Changed in flatpak (Ubuntu):
status: New → Invalid
Andrew Hayzen (ahayzen) wrote :

Managed to report a bug here https://bugs.kde.org/show_bug.cgi?id=407572

@Eric, it would probably be useful if you could also report the version of xdg-desktop-portal and xdg-desktop-portal-kde you are running. Could you paste the output of the following command ?

$ apt policy xdg-desktop-portal xdg-desktop-portal-kde

Peter Eszlari (eszlari) wrote :
Eric Adams (esa1975) wrote :

I can confirm that this is working as expected in the daily iso I've just tested (Plasma 5.15.90).

Changed in xdg-desktop-portal-kde (Ubuntu):
status: New → Fix Committed
Andrew Hayzen (ahayzen) wrote :

Can someone add Disco (19.04) as an affected series to xdg-desktop-portal-kde, mark that as triaged (as we know the commit [0] to fix this). And then mark xdg-desktop-portal-kde (Ubuntu) as Fix Released?

(I don't have the permissions to do this)

0 - https://cgit.kde.org/xdg-desktop-portal-kde.git/commit/?id=045302b5292cb62da5843906825c04898d6656d7

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.