Firefox hangs when closing a page with flash running

Bug #98688 reported by Mika Fischer on 2007-03-29
44
This bug affects 2 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Freddy Martinez

Bug Description

Binary package hint: flashplugin-nonfree

When i watch a video on youtube or listen to some radio station on last.fm and I close the tab or the browser window while the video/radio is still playing, Firefox hangs pretty much every time. If the video is finished or paused closing the tab/window mostly works.

Let me know if I can help to debug this.

What version of Flash Player do you have? I can not reproduce this on my Fx 2.0 Feisty system with Flash 9.

Changed in flashplugin-nonfree:
assignee: nobody → freddymartinez9
status: Unconfirmed → Needs Info
Mika Fischer (zoop) wrote :

I'm using the latest version of the flashplugin-nonfree package:

mika@mika-pc:~$ dpkg -s flashplugin-nonfree | grep ^Vers
Version: 9.0.31.0.2ubuntu1

I found out that the problem does not happen with every flash video player. I could reproduce the problem pretty reliably with the "small" Youtube player. Two out of three times the following makes Firefox hang:

1) Start Firefox
2) Open a second Tab
3) Go to www.youtube.com
4) In the right sidebar is an embedded video. Click on the big Play button.
5) Wait until the video is playing
6) Close the tab

Again, this does not work every time but about 2/3 of the time this will hang my browser so that I have to kill it.

A backtrace tells me that it's hanging in pthread_join called from within libflashplayer.so, so there is probably not much anyone can do about it...

bark (kento) wrote :

I can confirm this problem. Almost every time I close a page with a flash video or hit the "back" button in firefox, the browser crashes and becomes unresponsive. I installed the flash 9 plugin trough the web-installer in firefox.

"about:plugins" shows:

   File name: libflashplayer.so
    Shockwave Flash 9.0 r31

John Leach (johnleach) wrote :

Same here with flashplugin-nonfree 9.0.31.0.2ubuntu1 on Feisty. Firefox hangs with various flash-based movie players when I close windows or tabs. Only way to get out is to pkill -9 firefox-bin and restart. I'm on Feisty on i386 Intel with an ati gcard (free software drivers) and Intel HDA sound card.

Changed in flashplugin-nonfree:
status: Needs Info → Confirmed

Same problem here with a 32-bit Firefox install on 64-bit Feisty.

Enrico Pangan (eipangan) wrote :

Same problem here. I am using Ubuntu 7.04, Firefox 2.0.0.3, Flash 9.0 r31 on a Sony Vaio. Seems to be a problem with Firefox because it doesn't happen when using the same Flash plug-in on Opera.

Runar Ingebrigtsen (ringe) wrote :

Confirmed. I also have this problem after upgrading to feisty.

Enrico Pangan (eipangan) wrote :

I've had this problem even with Edgy although it must be because I already downloaded the latest flash library (9.0) even when the one that came with Edgy was version 7.0

John Leach (johnleach) wrote :

I've not been able to reproduce this with the Opera browser on the same machine (same Flash binary as I understand).

Fabio Parri (parrif-ibb) wrote :

I confirm I have the same problem: Ubuntu 7.04 and Firefox 2.0.0.3, x86 version and intel graphic card

bark (kento) wrote :

Are there any updates on this problem?`This bug is really annoying. It's impossible to watch vidoes on Youtube.

martin_prior (martinwprior) wrote :

I first experienced this problem when I upgraded to Feisty. In my case the system becomes totally unresponsive and requires a hard re-set.

I was not using youtube, but just surfing sites. When I disable Flashplayer the system does not have a problem. To be fair to Feisty, I have tried Dreamlinux and Elive, all of the Debian Linux. They all give the same problem. So for now Flash is disabled.

Martin Prior

Enrico Pangan (eipangan) wrote :

I think a temporary solution can be found in this bug page...
https://bugs.launchpad.net/bugs/104470

1. Run firefox and watch a flash movie (e.g. youtube)
2. Open a new firefox window and browse as usual

DanielRoesler (diafygi) wrote :

I am having this problem too. Has anyone found a HOWTO fix yet? Mine bug happens when I go back or Home or to a bookmark or close the window (haven't tried anything with tabs yet) in which I've been watching a flash video (youtube, veoh, etc.). I've found that when the window goes to grayscale (black and white), you can still click on the "X" at the top right to close the window. It asks you to "Force Quit," and I do. Then, when I open firefox again, it asks me if I want to restore the session. I restore the session and it takes be back to the page I was at. If I go back quickly enough (the video hasn't played much), firefox won't crash.

OS: Ubuntu Feisty
FF: 2.0.0.3
plugin: libflashplayer.so, Shockwave Flash 9.0 r31 (I installed it by clicking the plugin icon when I first went to a flash site).
Also running: Flashblock (but this bug was happening before I installed flashblock)

John Leach (johnleach) wrote :

The latest security updates on Feisty brought Firefox 2.0.0.4, which appears to have fixed this problem for me. Can somebody else confirm this as it's sometimes difficult to reproduce, so I can't be sure it's fixed (and I'm bored of browsing youtube).

Although the frequency of freeze-ups after pressing back during a
youtube clip has reduced, ---either from the firefox update [2.0.0.4] or
some other ubuntu update I am not aware of--- I still experience them on
occasion.

DG.

On Tue, 2007-06-05 at 13:39 +0000, John Leach wrote:
> The latest security updates on Feisty brought Firefox 2.0.0.4, which
> appears to have fixed this problem for me. Can somebody else confirm
> this as it's sometimes difficult to reproduce, so I can't be sure it's
> fixed (and I'm bored of browsing youtube).
>

I think I'm seeing a variant of the same problem on two machines, but I have one machine where it is running okay. Is there some way to compare the relevant configuration information between the machines to see what's going on there?

Nick B. (futurepilot) wrote :

I can confirm this bug. It seems to be the worst on YouTube, but can be triggered by any Flash content when clicking the Back button, closing the tab, or otherwise leaving the page with Flash content. This is very annoying.

Confirmed on Dapper 6.06 with the latest Mozilla build of Firefox (2.0.0.4) and Flash plugin and on Feisty with the latest Ubuntu build of Firefox (2.0.0.4) and the latest Flash plugin

Experiencing same behaviour here: closing tab, or pressing back button hangs firefox on feisty.

firefox 2.0.0.4+1-0ubuntu1
flashplugin-nonfree 9.0.31.0.2ubuntu1

Ilija Gospodinov (ilijagosp) wrote :

I can confirm this bug too, and it started happening a few days ago out of nowhere. Firefox was working good with Flash 9.0 r31 since I installed Feisty a month ago. Right now Firefox 2.0.0.4 hangs whenever I open a URL with flash content, with processor usage 90+ %. I tried deleting the Firefox profile folder, and installed Flash through the web dialogue when opening a flash site, and through the .tgz package on the Adobe web site. Same result. Firefox is becomming very unusable this way, I am begging for a solution to this problem. Stay well.

Nick B. (futurepilot) wrote :

This seems to be a bug in the Flash plugin and not Firefox. I've tried many other browsers and they all react in the same way. I've tried Swiftfox, Opera, Epiphany. All freeze when closing a page with Flash content.

AK (kumar20-gmail) wrote :

it hangs quite often when I hit the back button while playing youtube video.

MarcoBazzani (visik7) wrote :

same problem here guys very annoing
also with epiphany

Filip Pawlak (filippawlak) wrote :

This seems to solve the problem...

Nick B. (futurepilot) wrote :

Filip Pawlak, what does this script do and where should I put it?
Thanks.

DanielRoesler (diafygi) wrote :

These workarounds do NOT work for me:
-right click on the video and change the setting "Local Storage" to unlimited
-adding "export XLIB_SKIP_ARGB_VISUALS=1" to the end of /usr/bin/firefox

How do I implement the bash script posted by Filip Pawlak? I tried it just in a random folder and also in /usr/bin, but it returns an error in both cases.

If I wait until the end of a youtube video, so that the links to other videos appear, it seems to reduce the frequency of the crashes.

Thank god for firefox restore! You can use the "Flashblock" firefox add-on so that when you restore the page after a crash, the flash doesn't start running again.

Yellow (send-spam-hotmail) wrote :

Once more confirmed. 32-bit Feisty with FF 2.0.0.6. Still the same problem that makes using YouTube impossible. If I click a link or click Back, it mostly - not always - hangs. Just like diafygi I noticed that it happens less when I wait until the clip has finished playing.

AaronMT (aaron-train) wrote :

Confirming that this occurs on my install of Feisty Ubuntu 7.04, 2.6.20-16-generic
with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20061201 Firefox/2.0.0.6 (Ubuntu-feisty)

Using Shockwave Flash 9.0 r48

1. Browser tends to crash upon moving around on YouTube for me.
2. I will finish watching a movie, hit back or click a link and the browser will lock up.

bluemarvel (itsjp2-0) wrote :

Firefox/2.0.0.6 (Ubuntu-feisty)
    File name: libflashplayer.so
    Shockwave Flash 9.0 r48

I'm having the same issue on an HP Pavilion dv9000 (actually dv9030us) running the 32-bit version of Feisty. No eye candy active. Primarily happens on YouTube and MySpace vid pages when I hit back or try to close the tab. It looks like it's freezing while it's trying to download ad information from a site such as doubleclick.

bluemarvel (itsjp2-0) wrote :

Upgraded to gutsy kernel per foxdemon suggestion, I was able to replicate the problem when YouTube tries to redirect to ash-v165.ash.youtube.com when I hit the "back" button in Firefox and the flash video was playing at the time.

larppa (larppaxyz) wrote :

I can confirm this problem with gutsy kernel (2.6.22-8-generic). Very annoying bug and afaik only appears with intel-hda audio driver.

goto (gotolaunchpad) wrote :

had the same problem with debian. my solution:

uninstall any current flash package (flashplugin-nonfree or flashplayer-mozilla)

get latest version (with MPEG4-AVC support) from adobe-labs:
http://labs.adobe.com/downloads/flashplayer9.html

i got the rpm and converted to deb (sudo alien flashplayer9_install_i386_082207.rpm)
installed it with "dpkg -i flash-plugin_9.0.60.184-1_i386.deb"

no more hanging problems so far... :)

greetz

goto (gotolaunchpad) wrote :

forgot to mention:
"sudo /usr/lib/flash-plugin/setup"

after installing the debian/ubuntu-package.
greetz

Hannes_S (6struss) wrote :

I had the same Problems with FF 2.0.0.6 on Feisty, but installing the beta from http://labs.adobe.com/downloads/flashplayer9.html seems to have fixed it.

rhinokitty (rhinokitty) wrote :

Can someone post a .deb?

Simon IJskes (sim-nyx) wrote :

i've installed the 'Shockwave Flash 9.0 r60' beta and it still hangs when tab closed/back pressed/other link selected during movie playing.

Still an issue with Gutsy. FFv2.0.0.6

I have the following:
- Firefox 2.0.0.6
- Shockwave Flash 9.0 r48
- Ubuntu 7.04

and my firefox used to crash after watching 2/3 videos in youtube......

So I did the following:
Uninstall (with synaptic) -----> mozilla-mplayer
Install (with synaptic) --------> totem-mozilla

Now firefox works perfectly.......
Can anybody confirm this "weird" theory?

Simon IJskes (sim-nyx) wrote :

> So I did the following:
> Uninstall (with synaptic) -----> mozilla-mplayer
> Install (with synaptic) --------> totem-mozilla
>
> Now firefox works perfectly.......
> Can anybody confirm this "weird" theory?

No, I followed recipe, but still unstable.

i can copy that

$ firefox -v
Mozilla Firefox 2.0.0.7, Copyright (c) 1998 - 2007 mozilla.org

Latest Flashplayer from Adobe website.

Crashes about 2/3 (its more about 5/6) all the time, if i close a tab including a playing or played flash video.

The hints here in the comments were all useless for me :(

foxdemon (fox324+launchpad) wrote :

From https://wiki.kubuntu.org/GutsyGibbon/RC/Kubuntu (maybe it also applies to firefox):

"Konqueror and Flash

Konqueror and Flash (Adobe, flashplugin-nonfree) are working once again. Ubuntu developers have patched up gtk which was causing the freeze and CPU temperature increases.
For freedom lovers everywhere we have available Gnash, a 100% Free version of flash. Install the klash package for a Konqueror plugin."

systemjack (systemjack) wrote :

I get this too with Firefox 2.0.0.7 and Flash 9.0 r48. In my experience I can avoid it if I always make sure to click in the page outside the video frame to return focus to Firefox before clicking the close button on the tab. Scrolling around the page first or similar seems to have the same effect. It's mostly if I open a page fresh, let it play through all the way or partially without interacting with the page in any other way before trying to close. I also use Flashblock 1.5.4.1 so I'm always clicking on the flash player and giving it focus in order to watch the vid which which may explain the high rate of failure for me.

freeflyer57 (freeflyer57) wrote :

 Bugmenot's solution worked perfectly for my system. Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)

Quote:
                 had the same problem with debian. my solution:
                 uninstall any current flash package (flashplugin-nonfree or flashplayer-mozilla)
                 get latest version (with MPEG4-AVC support) from adobe-labs:
                 http://labs.adobe.com/downloads/flashplayer9.html

                 i got the rpm and converted to deb (sudo alien flashplayer9_install_i386_082207.rpm)
                 installed it with "dpkg -i flash-plugin_9.0.60.184-1_i386.deb"
                 sudo /usr/lib/flash-plugin/setup

If you are a little confused follow this:

   goto http://labs.adobe.com/downloads/flashplayer9.html

   right-click Download Plugin for Linux x86 (RPM, 2.88 MB) and save as to Desktop

   close browser
      _________________________________________________________________________
     | IN TERMINAL |
     | |
     | sudo apt-get install alien |
     | |
     | sudo alien /home/yourname/Desktop/flashplayer9_install_i386_100107.rpm |
     | |
     | sudo dpkg -i flash-plugin_9.0.64.0-1_i386.deb |
     | |
     | sudo /usr/lib/flash-plugin/setup |
      -------------------------------------------------------------------------------------------------------
   open browser and enjoy!

 ____
/ ___| _ __ ___ _ __ ___ ___ _ __
\___ \| ' _ \ / _ \ ' _ \ / __ / _ \ ' __|
 ___) | |_) | __/ | | | (_ | __/ |
|____/| .__/ \___ |_| |_|\___\___|_|
         |_|

freeflyer57 (freeflyer57) wrote :

Nevermind the lines in the terminal commands. After I posted, the ascii messed up. Sorry about that.

I'll try bugmenot's tip soon but I'd like to share that this bug affects not only Firefox, but also Opera, Flock, Epiphany, and Konqueror. What I usually do to prevent my browser from hanging is to stop whatever video's playing, switch to another tab, and middle-click the tab with the flash video. This usually prevents whatever browser I'm using from hanging, however, it's not a 100% prevention tip. I'll also try systemjack's tip later, if that works, then I there's no reason for me to install the beta package from Adobe.

The bug is still there. I use Ubuntu 7.04, Firefox 2.0.0.8 and had used the default Flash plugin (the one that is installed when you click on the missing plugin installation button). The bug was there. Then I have updated to Shockwave Flash 9.0 r64 as bugmenot advised, but it hasn't solved the problem.

DanielRoesler (diafygi) wrote :

I am using Gutsy and this bug is still there. I tried SpencerVaughn's method. It reduced the crash frequency from around 1/3 to around 1/20. A small step forward I guess. Has anyone tried the new package available at adobe.com (9.0.115.0)? They released it in tar.gz, rpm, and YUM?! Where's the deb?? I'm going to try it (using the rpm and alien) tonight and report back. Here's the url:
http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash&P2_Platform=Linux

Also, why isn't this bug combined with 104470 (https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/104470)? It seems like they're the same problem. Also, they should update it to includ Gutsy as well.

Grrr! for close-source stuff!

Vorik (launchpad-gerapeldoorn) wrote :

I am also bothered by this bug using gutsy.

DanielRoesler (diafygi) wrote :

So far so good. I downloaded the latest .rpm of flash-player from Adobe's website. I converted it to .deb using alien and installed it by double clicking on it. I haven't had it crash once since. We'll see if it can hold up for a week.

Here are my specific steps:
1. install "alien" (via Synaptic Package Manager) if you haven't already
2. download "flash-plugin-9.0.115.0-release.i386.rpm" from <http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash&P2_Platform=Linux>
3. open a terminal and navigate to the place where you downloaded the .rpm file (i.e. type "cd /home/username/Desktop")
4. use alien to convert the .rpm file to a .deb file (i.e. type "sudo alien flash-plugin-9.0.115.0-release.i386.rpm")
5. after alien is done, close the terminal and show the desktop (or wherever you downloaded the .rpm file)
6. double click on the .deb that you just created (it's in the same place as the .rpm file) and click install
7. after it's done installing, navigate to /usr/lib/flash-plugin using your folder browser (it's called nautilus)
8. right click on "setup" and click Open With Other Application
9. click the "Use a custom command" to show the text box
10. type "sudo" and click Open (type in your password if it asks you)
11. it should run on it's own and be over within a second or two (maybe even faster)
12. You're Done!

Here are the same steps if you want to do it all by command line:
1. cd /home/YourUserName/Desktop
2. sudo apt-get install alien
3. wget http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-9.0.115.0-release.i386.rpm
4. sudo alien flash-plugin-9.0.115.0-release.i386.rpm
5. sudo dpkg -i flash-plugin_9.0.115.0-1_i386.deb
6. sudo /usr/lib/flash-plugin/setup

You can check that the setup script worked by opening firefox and typing "about:plugins" into the address bar at the top and hitting Enter. On the list below Shockwave Flash it will say "Shockwave Flash 9.0 r115."

You can do these same things for another version of the flash .rpm file if you want. I haven't had it crash yet, so I would recommend the latest one (9.0.115.0). I really don't understand why Adobe releases RPM and YUM but not DEB. Anyway, please let me know if I've missed anything or something doesn't work. I'd also like it if I could get some confirmations about this newest release not crashing.

The installation of the new deb file will upgrade any previous version of flash-plugin installed. If you want to uninstall, you can alway go to Synaptic Package Manager and remove it.

P.S. Yes, I know that the terminal method is shorter, but some of us humans out there will go to great lengths to avoid any command line. I only wish alien had a gui. Also, I've attached the deb file alien created for me :)

DanielRoesler (diafygi) wrote :

Doh! I spoke too soon. Version 9.0.115.0 has just crashed firefox. It took three days, but I was going Back on a collegehumor video and firefox froze. Thank god for firefox's Restore feature and Flash Block's plugin. I would say the ratio has decreased to around 1/70 now.

View my previous comment and instructions as only a way to reduce the frequency of the crashes. Is there anyone more technically minded than me worrying about this bug? I view it as a critical problem since not many regular people will make the jump from Windows to Ubuntu if youtube doesn't work. I realize that this is proprietary software we're dealing with, but there has to be something we can do.

Apparently this is an architecture-specific bug, so here is a review on my type of computer: http://www.notebookreview.com/default.asp?newsID=3298&review=Sager+NP6260

I'd be happy to follow any troubleshooting suggestions from those unable to reproduce it. You have a volunteer from an affected computer. I've tried everything in this thread and in bug #(104470) except changing the kernel. But possessing no advanced computer skills, I feel unqualified to diagnose this problem.

Joshua Swink (yathster) wrote :

Thanks for working on this Daniel. This is an important problem and it'll be a big relief when it's finally solved.

LimCore (limcore) wrote :

Hello,

can this debug info be of any help?

rafal@rafal-desktop:~/dap/install_flash_player_9_linux$ firefox
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.

(npviewer.bin:10921): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtengine.so: wrong ELF class: ELFCLASS64

(npviewer.bin:10921): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtengine.so: wrong ELF class: ELFCLASS64
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.

(npviewer.bin:10943): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtengine.so: wrong ELF class: ELFCLASS64

(npviewer.bin:10943): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtengine.so: wrong ELF class: ELFCLASS64
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.

(npviewer.bin:11002): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtengine.so: wrong ELF class: ELFCLASS64

(npviewer.bin:11002): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtengine.so: wrong ELF class: ELFCLASS64
*** NSPlugin Wrapper *** ERROR: NPP_Destroy() wait for reply: Message timeout
*** NSPlugin Wrapper *** ERROR: NPClass::Invalidate() invoke: Message timeout

rafal@rafal-desktop:~/dap/install_flash_player_9_linux$ sha1sum libflashplayer.so
c5e6cd91d70229c25f369678200c25a79d3a1d42 libflashplayer.so

I installed that by downloading adobe.com's flash tar.gz, unpacking it here, running on it the wrapper, and then running firefox in this dir

Buddhika (blaknath) wrote :

Hay,

I'm facing the same issue but in my case it's worse. FF hangs in the first time of loading a flash clip. This is a real headache.

My specs are,
Linux 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux

If there's any thing I can help to fix this bug will glad to provide it.

Buddhika

Buddhika (blaknath) wrote :

OK, I think my issues was corrected after some steps. Seems like the reason for my FF problem is caused by a clash between Flash-non free plug-in and Gnash player. After unstalling both from synaptic and installing only flash plugin solved my FF issue.

Cheers,
Buddhika

Julien (psylo1979) wrote :

I can confirm this bug with a fresh new Gutsy install with firefox 2.0.0.11 and Shockwave Flash 9.0 r115
firefox will freeze randomly when accessig a site with flash animation (example: youtube).
I had exactly the same bug using feisty.

Manuel Parra (manuparra) wrote :

I confirm this problem. I can watch one or two Flash videos, but when I click for other link that have flash videos, Firefox hangs

I use gusty!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers