Some flash widgets are not obscured by overlapping windows

Bug #968692 reported by Martin Stjernholm on 2012-03-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

With the latest update to flashplugin-installer , some flash content in web pages almost completely disregards overlapping windows:

If a flash player is visible on a web page, then placing another window (e.g. a terminal) on top of it does not obscure it from view, i.e. it shows inside the terminal window. The same thing happens if I switch to another tab in the browser - the flash player is still present in the same position as it has in the other tab.

The flash widget is not rendered completely on top of everything else; text and images are typically still rendered on top of the player (with nonmatching antialiasing), as are most window decorations, and e.g. tables with background colors if another browser window overlaps the widget.

When the web page containing the flash widget is scrolled, the widget scrolls with it correctly. If the widget then is scrolled partly out of the browser window, it obscures parts of the browser window itself as well, it can e.g. show inside the address bar if it's scrolled up.

The bug does not affect all flash applications - I've seen it with smaller youtube players such as the one on http://www.google.co.uk/intl/en/jobs/uk/, and in the audio player at the bottom at http://sverigesradio.se/. It also seems to affect only the first widget instance.

I'm running Natty and thus a Gnome 2 environment. Firefox is 11.0+build1-0ubuntu0.11.04.1. The affected flashplugin-installer is 11.2.202.228ubuntu0.11.04.1 - downgrading to 10.2.159.1ubuntu1 makes the problem go away. I haven't been able to try downgrading to more recent versions since the flashplugin tarballs seems to be removed from archive.ubuntu.com very quickly, but I'd like to get hold of adobe-flashplugin_11.1.102.63.orig.tar.gz.

Martin Stjernholm (msub) wrote :

Update: Just noticed that the flash application may do something that corrects the problem while it's running. E.g. switching the youtube player to fullscreen and back makes it behave correctly.

Martin Stjernholm (msub) wrote :

Managed to get hold of an archive for 11.1.102.63, so I've been able to verify that this is a regression from 11.1.102.63ubuntu0.11.04.1 to 11.2.202.228ubuntu0.11.04.1.

Martin Stjernholm (msub) wrote :

This bug is still present in 11.2.202.233ubuntu0.11.04.3.

Martin Stjernholm (msub) wrote :

Looks like I'll be running a monologue on this one, but fwiw I can mention some of the actions I've done to narrow it down:

1. The same thing happens with flash widgets in both firefox (my standard browser) and chromium.

2. It's present in both Natty/Gnome 2 and Precise/Xubuntu.

3. Creating a new user on the same machine with the same desktop environment does not exhibit the problem.

4. Running firefox with add-ons disabled does not make a difference.

5. If I move away ~/.mozilla it doesn't appear to happen on the first firefox launch, but it's back again in subsequent launches.

6. Using strace I've tracked all files/dirs that are opened on launch in my home directory, e.g. .adobe, .macromedia, .config, .local, .cache, .fontconfig, .gtkrc-2.0, .fonts.conf, .nv, and of course .mozilla. I then moved them away all at once. It does not make any difference if I just launch another firefox instance, but it seemingly fixes the problem if I log out and back in.

This leads me to believe it's influenced by some setting communicated over D-Bus or somesuch mechanism, but I'm at a bit of a loss as to how I'd trace that.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
root (shaman-t) wrote :

You are not alone man =) Same here. Was trying to google some info about how to fix this but nothing interesting.

root (shaman-t) wrote :

Try to install flashplugin-installer. I tried it now and while installing it download and install flashplugin 11.2.202.238.orig
Now everything seems to work correctly. I'll write back after testing more.
As I found there are no other options to fix it but to update flashplugin. Hope this will help you too =)

Martin Stjernholm (msub) wrote :

Ah, yes. I stopped experiencing this issue some time ago. Found a thread somewhere (sorry, can't find it anymore) that gave the tip to uncheck "Enable hardware acceleration" in the Settings dialog. I did that, and at the same time I also upgraded to 11.2.202.235 iirc.

I haven't gotten the problem since then. But because I did both changes at the same time I don't know for sure which of them, or maybe both, fixed/worked around the bug. I've never been able to check the hardware acceleration option again either, because the Settings dialog always freezes immediately after that uncheck.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers