ubuntu-restricted-addons 64bit depends on flash 32bit

Bug #873512 reported by mikewhatever on 2011-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Installing ubuntu-restricted-addons or ubuntu-restricted-extras on a 64bit system pulls in flashplugin-installer, nspluginwrapper, and lots of other 32bit dependencies.
The same happens if the codec box is checked during the installation process.

For example, here is what happens on Oneiric 64bit:

sudo apt-get install flashplugin-installer
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
flashplugin-downloader:i386 libasound2:i386 libasound2-plugins:i386
libasyncns0:i386 libatk1.0-0:i386 libavahi-client3:i386
libavahi-common-data:i386 libavahi-common3:i386 libcairo2:i386 libcups2:i386
libcurl3:i386 libdatrie1:i386 libexpat1:i386 libflac8:i386
libfontconfig1:i386 libfreetype6:i386 libgcrypt11:i386
libgdk-pixbuf2.0-0:i386 libgnutls26:i386 libgpg-error0:i386
libgssapi-krb5-2:i386 libgtk2.0-0:i386 libice6:i386 libidn11:i386
libjack-jackd2-0:i386 libjasper1:i386 libjpeg62:i386 libjson0:i386
libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
libldap-2.4-2:i386 libnspr4:i386 libnspr4-0d:i386 libnss3:i386
libnss3-1d:i386 libogg0:i386 libpango1.0-0:i386 libpixman-1-0:i386
libpulse0:i386 librtmp0:i386 libsamplerate0:i386 libsasl2-2:i386
libsasl2-modules:i386 libsm6:i386 libsndfile1:i386 libspeexdsp1:i386
libsqlite3-0:i386 libstdc++6:i386 libtasn1-3:i386 libthai0:i386
libtiff4:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386
libx11-6:i386 libxau6:i386 libxcb-render0:i386 libxcb-shm0:i386 libxcb1:i386
libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386
libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386 libxinerama1:i386
libxrandr2:i386 libxrender1:i386 libxt6:i386 nspluginviewer:i386
nspluginwrapper
Suggested packages:
firefox:i386 x-ttcidfont-conf:i386 msttcorefonts:i386
ttf-bitstream-vera:i386 ttf-dejavu:i386 ttf-xfree86-nonfree:i386 xfs:i386
libasound2-python:i386 cups-common:i386 rng-tools:i386 gnutls-bin:i386
krb5-doc:i386 krb5-user:i386 librsvg2-common:i386 gvfs:i386 jackd2:i386
libjasper-runtime:i386 ttf-japanese-gothic:i386 ttf-japanese-mincho:i386
ttf-thryomanes:i386 ttf-baekmuk:i386 ttf-arphic-gbsn00lp:i386
ttf-arphic-bsmi00lp:i386 ttf-arphic-gkai00mp:i386 ttf-arphic-bkai00mp:i386
libsasl2-modules-otp:i386 libsasl2-modules-ldap:i386
libsasl2-modules-sql:i386 libsasl2-modules-gssapi-mit:i386
libsasl2-modules-gssapi-heimdal:i386
The following NEW packages will be installed:
flashplugin-downloader:i386 flashplugin-installer libasound2:i386
libasound2-plugins:i386 libasyncns0:i386 libatk1.0-0:i386
libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
libcairo2:i386 libcups2:i386 libcurl3:i386 libdatrie1:i386 libexpat1:i386
libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libgcrypt11:i386
libgdk-pixbuf2.0-0:i386 libgnutls26:i386 libgpg-error0:i386
libgssapi-krb5-2:i386 libgtk2.0-0:i386 libice6:i386 libidn11:i386
libjack-jackd2-0:i386 libjasper1:i386 libjpeg62:i386 libjson0:i386
libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
libldap-2.4-2:i386 libnspr4:i386 libnspr4-0d:i386 libnss3:i386
libnss3-1d:i386 libogg0:i386 libpango1.0-0:i386 libpixman-1-0:i386
libpulse0:i386 librtmp0:i386 libsamplerate0:i386 libsasl2-2:i386
libsasl2-modules:i386 libsm6:i386 libsndfile1:i386 libspeexdsp1:i386
libsqlite3-0:i386 libstdc++6:i386 libtasn1-3:i386 libthai0:i386
libtiff4:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386
libx11-6:i386 libxau6:i386 libxcb-render0:i386 libxcb-shm0:i386 libxcb1:i386
libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386
libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386 libxinerama1:i386
libxrandr2:i386 libxrender1:i386 libxt6:i386 nspluginviewer:i386
nspluginwrapper
0 upgraded, 76 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/13.5 MB of archives.
After this operation, 39.3 MB of additional disk space will be used.
Do you want to continue [Y/n]?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers