can no longer play youtube videos

Bug #766130 reported by Rolf Leggewie on 2011-04-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

I can no longer play videos on Youtube after the recent security update to flashplugin-installer 10.2.159.1ubuntu0.10.04.1 (lucid system, obviously. 32bit). I get a warning "You need to upgrade your Adobe Flash player to watch this video". Downloading the video with youtube-dl and then watching it with mplayer works fine. Anybody else affected?

Rohit R (rr0hit) wrote :

Did you get an error message during the update you did ? If yes see if the error was bug #762968

If you could run "apport-collect 766130" and add the additional information to this report, it would be helpful.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Incomplete
Rolf Leggewie (r0lf) wrote :

Rohit, thank you for having a look. I don't recall any issue during the upgrade. To test, I reinstalled the package and found some interesting results (output is from the etckeeper package which tracks changes to /etc for me).

$ sudo aptitude reinstall flashplugin-installer
[...]
  4800K .......... .......... ......... 100% 36,3K=93s

2011-04-20 00:41:01 (52,1 KB/s) - `./adobe-flashplugin_10.2.159.1.orig.tar.gz' saved [4945652/4945652]

Download done.
Flash Plugin installed.

[master 567582f] committing changes in /etc after apt run
 Author: Rolf Leggewie <email address hidden>
 7 files changed, 7 insertions(+), 0 deletions(-)
 create mode 120000 alternatives/firefox-flashplugin
 create mode 120000 alternatives/iceape-flashplugin
 create mode 120000 alternatives/iceweasel-flashplugin
 create mode 120000 alternatives/midbrowser-flashplugin
 create mode 120000 alternatives/mozilla-flashplugin
 create mode 120000 alternatives/xulrunner-addons-flashplugin
 create mode 120000 alternatives/xulrunner-flashplugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

It looks like the plugin was not registered with the alternatives system the first time around. Here's the git log.

commit 567582f8ebac7c5c5b5d5fa8ec2fce469794927b
Author: Rolf Leggewie <email address hidden>
Date: Wed Apr 20 00:41:09 2011 +0800

    committing changes in /etc after apt run

commit de3b3f82cb77eb38a0417da42431b1a4f6faf323
Author: root <root@localhost.(none)>
Date: Mon Apr 18 08:39:12 2011 +0800

    committing changes in /etc after apt run

    Package changes:
    -flashplugin-installer 10.2.153.1ubuntu0.10.04.1
    -flashplugin-nonfree 10.2.153.1ubuntu0.10.04.1
    +flashplugin-installer 10.2.159.1ubuntu0.10.04.1
    +flashplugin-nonfree 10.2.159.1ubuntu0.10.04.1

looking more closely into the commits, de3b3f82cb77eb38a0417da42431b1a4f6faf323 only deletes the files, no other changes.

I hope this gives enough information for the package maintainer to understand where the postinst or other scripts fail.

Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → New
Rolf Leggewie (r0lf) on 2011-04-19
description: updated
Rolf Leggewie (r0lf) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers