package flashplugin-installer 10.2.153.1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #745459 reported by Anthony Hook on 2011-03-30
218
This bug affects 33 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Medium
Unassigned
ia32-libs (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

Flash stopped working for me, so I purged and reinstalled flashplugin-nonfree, and got this:

2011-03-29 23:37:18 (654 KB/s) - `./adobe-flashplugin_10.2.153.1.orig.tar.gz' saved [4967805/4967805]

Download done.
Flash Plugin installed.
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so
dpkg: error processing flashplugin-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: flashplugin-installer 10.2.153.1ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
AptOrdering:
 flashplugin-installer: Install
 flashplugin-nonfree: Install
 flashplugin-installer: Configure
 flashplugin-nonfree: Configure
Architecture: amd64
Date: Tue Mar 29 23:37:19 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
SourcePackage: flashplugin-nonfree
Title: package flashplugin-installer 10.2.153.1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Anthony Hook (anthonyhook) wrote :

I found a way to get working Flash using Adobe's experimental 64-bit Flash plugin, but this is not a bug fix. Here it is:

wget http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_64bit_linux_111710.tar.gz
tar zxf flashplayer10_2_p3_64bit_linux_111710.tar.gz
sudo mv libflashplayer.so /usr/lib/mozilla/plugins/
sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox-addons/plugins/

Before doing this, make sure the flashplugin-installer package is completely removed.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
ngsupb (ngsupb) wrote :

Hi,

Today flash stopped working for me too. Reinstall shows the same error.

Anders Kaseorg (andersk) wrote :

After downgrading ia32-libs to 20090808ubuntu9 from
https://launchpad.net/ubuntu/+source/ia32-libs/20090808ubuntu9/+buildjob/1996308
and then reinstalling flashplugin-installer, the problem goes away. So this is a regression with ia32-libs 20090808ubuntu10.

Anders Kaseorg (andersk) wrote :

The problem is the disappearance of these seven libraries from ia32-libs:

$ ldd /usr/lib/flashplugin-installer/libflashplayer.so | grep 'not found'
 libssl3.so => not found
 libsmime3.so => not found
 libnss3.so => not found
 libnssutil3.so => not found
 libplds4.so => not found
 libplc4.so => not found
 libnspr4.so => not found

All of them were present in ia32-libs 20090808ubuntu9 and are gone in ia32-libs 20090808ubuntu10.

Feras Abdullah (pianoforte) wrote :

I've deleted flashplugin-installer and went back to gnash. It is buggy, but at least I can play flash videos.
Thank you.

Anders Kaseorg (andersk) wrote :

ia32-libs (20090808ubuntu11) natty; urgency=low

  * Add libqtwebkit4 (LP: #677397)
  * Add ibus-gtk, libibus2 (LP: #646954)
  * Another manual libpng link, libpng.so.3 (LP: #707770)
  * Add gtk2-engines-oxygen (LP: #719568)
  * Add libopenvg1-mesa (LP: #693969)
  * Add libwbclient0, winbind (LP: #694953)
  * Change some libraries that are now just symlink packages (should fix Flash)
    - libnss3-1d to libnss3
    - libnspr4-0d to libnspr4

 -- Scott Ritchie <email address hidden> Tue, 29 Mar 2011 18:44:49 -0700

Changed in ia32-libs (Ubuntu):
status: New → Fix Released
Changed in flashplugin-nonfree (Ubuntu):
status: Confirmed → Fix Released
Download full text (3.2 KiB)

Hi Anders,

Hey thanks for your revert... Wanted to check though....why would be required to install the dependencies on my own when I am installing the flash from Ubuntu Software center?

Best Regards
Kedar Apte

--- On Wed, 3/30/11, Anders Kaseorg <email address hidden> wrote:

From: Anders Kaseorg <email address hidden>
Subject: [Bug 745459] Re: package flashplugin-installer 10.2.153.1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
To: <email address hidden>
Date: Wednesday, March 30, 2011, 10:23 PM

ia32-libs (20090808ubuntu11) natty; urgency=low

  * Add libqtwebkit4 (LP: #677397)
  * Add ibus-gtk, libibus2 (LP: #646954)
  * Another manual libpng link, libpng.so.3 (LP: #707770)
  * Add gtk2-engines-oxygen (LP: #719568)
  * Add libopenvg1-mesa (LP: #693969)
  * Add libwbclient0, winbind (LP: #694953)
  * Change some libraries that are now just symlink packages (should fix Flash)
    - libnss3-1d to libnss3
    - libnspr4-0d to libnspr4

-- Scott Ritchie <email address hidden>  Tue, 29 Mar 2011 18:44:49
-0700

** Changed in: ia32-libs (Ubuntu)
       Status: New => Fix Released

** Changed in: flashplugin-nonfree (Ubuntu)
       Status: Confirmed => Fix Released

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (745613).
https://bugs.launchpad.net/bugs/745459

Title:
  package flashplugin-installer 10.2.153.1ubuntu1 failed to
  install/upgrade: subprocess installed post-installation script
  returned error exit status 1

Status in “flashplugin-nonfree” package in Ubuntu:
  Fix Released
Status in “ia32-libs” package in Ubuntu:
  Fix Released

Bug description:
  Binary package hint: flashplugin-nonfree

  Flash stopped working for me, so I purged and reinstalled flashplugin-
  nonfree, and got this:

  2011-03-29 23:37:18 (654 KB/s) - `./adobe-
  flashplugin_10.2.153.1.orig.tar.gz' saved [4967805/4967805]

  Download done.
  Flash Plugin installed.
  nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so
  dpkg: error processing flashplugin-installer (--configure):
   subprocess installed post-installation script returned error exit status 1
  E: Sub-process /usr/bin/dpkg returned an error code (1)

  ProblemType: Package
  DistroRelease: Ubuntu 11.04
  Package: flashplugin-installer 10.2.153.1ubuntu1
  ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
  Uname: Linux 2.6.38-7-generic x86_64
  NonfreeKernelModules: nvidia
  AptOrdering:
   flashplugin-installer: Install
   flashplugin-nonfree: Install
   flashplugin-installer: Configure
   flashplugin-nonfree: Configure
  Architecture: amd64
  Date: Tue Mar 29 23:37:19 2011
  ErrorMessage: subprocess installed post-installation script returned error exit status 1
  InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
  SourcePackage: flashplugin-nonfree
  Title: package flashplugin-installer 10.2.153.1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
  UpgradeStatus: No upgrade log present (probably fresh install)

To unsubscribe from this bug, go to:
https...

Read more...

Anders Kaseorg (andersk) wrote :

On Thu, 31 Mar 2011, Kedar Apte wrote:
> Hey thanks for your revert... Wanted to check though....why would be
> required to install the dependencies on my own when I am installing the
> flash from Ubuntu Software center?

You don’t. The software center will get you all the dependencies of Flash
automatically.

This bug was that ia32-libs, one of the dependencies of Flash, did not
actually provide all the dependencies that it claimed to. However, since
that’s now been fixed, everything will work automatically when you perform
your next upgrade.

When you’re running an Ubuntu development release, you should expect
things to break like this occasionally. If you don’t want things to
break, stick with a stable release like 10.04 LTS or 10.10 instead.

Anders

Kedar Apte (kedar-apte) wrote :
Download full text (3.1 KiB)

Appreciated...

Best Regards
Kedar Apte

--- On Thu, 3/31/11, Anders Kaseorg <email address hidden> wrote:

From: Anders Kaseorg <email address hidden>
Subject: Re: [Bug 745459] Re: package flashplugin-installer 10.2.153.1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
To: <email address hidden>
Date: Thursday, March 31, 2011, 10:29 AM

On Thu, 31 Mar 2011, Kedar Apte wrote:
> Hey thanks for your revert... Wanted to check though....why would be
> required to install the dependencies on my own when I am installing the
> flash from Ubuntu Software center?

You don’t.  The software center will get you all the dependencies of Flash
automatically.

This bug was that ia32-libs, one of the dependencies of Flash, did not
actually provide all the dependencies that it claimed to.  However, since
that’s now been fixed, everything will work automatically when you perform
your next upgrade.

When you’re running an Ubuntu development release, you should expect
things to break like this occasionally.  If you don’t want things to
break, stick with a stable release like 10.04 LTS or 10.10 instead.

Anders

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (745613).
https://bugs.launchpad.net/bugs/745459

Title:
  package flashplugin-installer 10.2.153.1ubuntu1 failed to
  install/upgrade: subprocess installed post-installation script
  returned error exit status 1

Status in “flashplugin-nonfree” package in Ubuntu:
  Fix Released
Status in “ia32-libs” package in Ubuntu:
  Fix Released

Bug description:
  Binary package hint: flashplugin-nonfree

  Flash stopped working for me, so I purged and reinstalled flashplugin-
  nonfree, and got this:

  2011-03-29 23:37:18 (654 KB/s) - `./adobe-
  flashplugin_10.2.153.1.orig.tar.gz' saved [4967805/4967805]

  Download done.
  Flash Plugin installed.
  nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so
  dpkg: error processing flashplugin-installer (--configure):
   subprocess installed post-installation script returned error exit status 1
  E: Sub-process /usr/bin/dpkg returned an error code (1)

  ProblemType: Package
  DistroRelease: Ubuntu 11.04
  Package: flashplugin-installer 10.2.153.1ubuntu1
  ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
  Uname: Linux 2.6.38-7-generic x86_64
  NonfreeKernelModules: nvidia
  AptOrdering:
   flashplugin-installer: Install
   flashplugin-nonfree: Install
   flashplugin-installer: Configure
   flashplugin-nonfree: Configure
  Architecture: amd64
  Date: Tue Mar 29 23:37:19 2011
  ErrorMessage: subprocess installed post-installation script returned error exit status 1
  InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
  SourcePackage: flashplugin-nonfree
  Title: package flashplugin-installer 10.2.153.1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
  UpgradeStatus: No upgrade log present (probably fresh install)

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/745459/+subscri...

Read more...

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers