Error during upgrade from Kubuntu 8.04 to 9.10

Bug #612276 reported by oxi on 2010-08-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

I picked this data after the upgrading error, before I agree to run dpkg --configure -a by the update-manager:
1. release: Ubuntu 9.10
2. package version: None (Apparently update-manager removed itself during upgrade)
3. expected: Clean upgrade from Kubuntu 8.04 to Kubuntu 9.10
4. what happened: By the end of the upgrading process, the graphical upgrading tool in Kubuntu brought up a window saying it could not install upgrades:
"The upgrading process has been cancelled. Your system might have been left in an unusable state. A recovering process will be started next (dpkg --configure -a). Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report. InstallArchives() failed" <- part of this is a rough translation from spanish to english, sorry for the inconvenience.

P.S.: I'm sorry if this bug report does not belong in here, but I'm thinking if that was the case, Kubuntu should have intercepted the error report and changed the link to the suitable site.

oxi (oxiroxt) wrote :
oxi (oxiroxt) wrote :
oxi (oxiroxt) wrote :
oxi (oxiroxt) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Download full text (3.1 KiB)

Thanks for your report.

The relevant error is
Preparando para reemplazar flashplugin-nonfree 10.0.1.218+really9.0.277.0ubuntu1 (usando .../flashplugin-nonfree_10.1.53.64ubuntu0.9.10.1_i386.deb) ...
update-alternatives: atención: la alternativa /usr/lib/flashplugin-nonfree/libflashplayer.so (parte de un vínculo de grupo iceape-flashplugin) no existe. Eliminando de la lista de alternativas.
update-alternatives: atención: /etc/alternatives/iceape-flashplugin está pendiente, será actualizado con la mejor opción.
update-alternatives: atención: la alternativa /usr/lib/flashplugin-nonfree/libflashplayer.so (parte de un vínculo de grupo iceweasel-flashplugin) no existe. Eliminando de la lista de alternativas.
update-alternatives: atención: /etc/alternatives/iceweasel-flashplugin está pendiente, será actualizado con la mejor opción.
update-alternatives: atención: la alternativa /usr/lib/flashplugin-nonfree/libflashplayer.so (parte de un vínculo de grupo mozilla-flashplugin) no existe. Eliminando de la lista de alternativas.
update-alternatives: atención: /etc/alternatives/mozilla-flashplugin está pendiente, será actualizado con la mejor opción.
update-alternatives: atención: la alternativa /usr/lib/flashplugin-nonfree/libflashplayer.so (parte de un vínculo de grupo firefox-flashplugin) no existe. Eliminando de la lista de alternativas.
update-alternatives: atención: /etc/alternatives/firefox-flashplugin está pendiente, será actualizado con la mejor opción.
update-alternatives: atención: la alternativa /usr/lib/flashplugin-nonfree/libflashplayer.so (parte de un vínculo de grupo xulrunner-flashplugin) no existe. Eliminando de la lista de alternativas.
update-alternatives: atención: /etc/alternatives/xulrunner-flashplugin está pendiente, será actualizado con la mejor opción.
update-alternatives: atención: la alternativa /usr/lib/flashplugin-nonfree/libflashplayer.so (parte de un vínculo de grupo midbrowser-flashplugin) no existe. Eliminando de la lista de alternativas.
update-alternatives: atención: /etc/alternatives/midbrowser-flashplugin está pendiente, será actualizado con la mejor opción.
update-alternatives: atención: la alternativa /usr/lib/flashplugin-nonfree/libflashplayer.so (parte de un vínculo de grupo xulrunner-addons-flashplugin) no existe. Eliminando de la lista de alternativas.
update-alternatives: atención: /etc/alternatives/xulrunner-addons-flashplugin está pendiente, será actualizado con la mejor opción.
update-alternatives: error: no hay alternativas para iceape-flashplugin.
update-alternatives: error: no hay alternativas para iceape-flashplugin.
dpkg: aviso: script de `pre-removal' antiguo devolvió un error de salida 2
dpkg - probando el script del nuevo paquete en su lugar...
dpkg: error al procesar /var/cache/apt/archives/flashplugin-nonfree_10.1.53.64ubuntu0.9.10.1_i386.deb (--unpack):
 no hay ningún script en la nueva versión del paquete - abandono
postinst called with argument `abort-upgrade'
dpkg: error al reorganizar:
 el subproceso script post-installation instalado devolvió el código de salida de error 1

This is reported in 429841 amd I'm marking thi...

Read more...

affects: update-manager (Ubuntu) → flashplugin-nonfree (Ubuntu)
Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers