package flashplugin-nonfree 10.0.1.218 really9.0.262.0ubuntu1 failed to install/upgrade: Package is in a very bad inconsistent state - you should reinstall it before attempting a removal.

Bug #578143 reported by Greg McNamara on 2010-05-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

Maybe I don't understand, since I thought what I was doing was reinstalling.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: flashplugin-nonfree 10.0.1.218+really9.0.262.0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: nvidia
AptOrdering:
 flashplugin-nonfree: Remove
 adobe-flashplugin: Install
 adobe-flashplugin: Configure
Architecture: i386
Date: Mon May 10 04:02:46 2010
ErrorMessage: Package is in a very bad inconsistent state - you should reinstall it before attempting a removal.
SourcePackage: flashplugin-nonfree
Title: package flashplugin-nonfree 10.0.1.218+really9.0.262.0ubuntu1 failed to install/upgrade: Package is in a very bad inconsistent state - you should reinstall it before attempting a removal.

Greg McNamara (g-mcnamara) wrote :

Hello,
I tried to uninstall break package flashplugin-nonfree with the following command in a terminal :
sudo dpkg --force all --purge flashplugin-nonfree

This is the result (sorry, in french- Look at the end of this comment for a translation in english...) :
dpkg: la zone de la base de données d'état est verrouillée par un autre processus
paps@paps-desktop-2:~$ sudo dpkg --force all --purge flashplugin-nonfree
dpkg : avertissement : problème contourné par utilisation de --force :
 Le paquet est dans un état incohérent - vous devriez
 le réinstaller avant d'essayer de le supprimer.
(Lecture de la base de données... 235648 fichiers et répertoires déjà installés.)
Suppression de flashplugin-nonfree ...
update-alternatives: error: pas d'alternatives pour iceape-flashplugin.
update-alternatives: error: pas d'alternatives pour iceape-flashplugin.
dpkg : erreur de traitement de flashplugin-nonfree (--purge) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 2
postinst called with argument `abort-remove'
dpkg : erreur lors du nettoyage :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 flashplugin-nonfree

ENGLISH VERSION OF THE MESSAGE
dpkg: database state zone is locked by another process
paps@paps-desktop-2:~$ sudo dpkg --force all --purge flashplugin-nonfree
dpkg : warning : problem bypassed by the use of --force :
 the package is in incoherent or disconnected state - you might
reinstall it before trying to remove it.
(reading database... 235648 files and folders already installed.)
Removing flashplugin-nonfree ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg : error processing flashplugin-nonfree (--purge) :
sub process script pre-removal installed returned an exit state error 2
postinst called with argument `abort-remove'
dpkg : error during cleaning :
sub process script post-installation installed returned an exit state error 1
Errors occurred during execution :
 flashplugin-nonfree

Thanks by advance
J.D. BRIERE

Bonjour, Hello,
J'ai trouvé la solution à l'adresse suivante (I found the solution at following address) :
http://forum.ubuntu-fr.org/viewtopic.php?pid=3253110#p3253110

sudo rm /var/lib/dpkg/info/flashplugin-nonfree.prerm
sudo dpkg --remove --force-remove-reinstreq flashplugin-nonfree
sudo dpkg --purge --force-remove-reinstreq flashplugin-nonfree

J.D. BRIERE
FRANCE

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers