no sound in flash in several browsers on kubuntu

Bug #543035 reported by deichschuh on 2010-03-20
80
This bug affects 17 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by noushi

Bug Description

Binary package hint: flashplugin-nonfree

I use Kubuntu 10.04, I installed the proprietary flashplugin and tried to play flash videos (i.e. on youtube) with the result, that the video played, but I didnt get any sound, I tried this with konqueror, rekonq and google-chrome, it never played sound.
In other areas of my system I do have sound (amarok, startupsounds, videos...), so I am pretty sure this is a flash problem, I tried reinstalling the plugin which didnt help.

ProblemType: Bug
Architecture: amd64
Date: Sat Mar 20 16:28:01 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
Package: flashplugin-installer 10.0.45.2ubuntu1
ProcEnviron:
 LANGUAGE=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: flashplugin-nonfree
Uname: Linux 2.6.32-16-generic x86_64

deichschuh (deichschuh) wrote :
permafrost91 (permafrost91) wrote :

Same problem. AMD 64, Kubuntu 10.04. No sound in online flash videos. Haven't given the 10.1 beta version of flash a try yet though ...

permafrost91 (permafrost91) wrote :

Just tried the 10.1 beta. No success either.

permafrost91 (permafrost91) wrote :

Found the problem: PCM mixer slider was set to 0%. Turned that up and now flash videos have sound. Hope this helps somebody.

gwenn59 (gwenn-moreilles) wrote :

Same problem. I have usb speakers. No sound problem with other applications like amarok. The problem exists in konqueror, firefox.

permafrost91 (permafrost91) wrote :

@gwenn59: Did you check all your mixer settings? Your problem doesn't seem to be related as this bug was opened for having system sounds but no sound from flash videos. If you are having absolutely no sound output, the problem is somewhere else.

Josef Engelfrost (engelfrost) wrote :

I had the same problem as permafrost91. The PCM slider wasn't visible in KMixer, I had to go into Settings->Configure Channels..., select Speaker and click OK to make it show.

Rune K. Svendsen (runeks) wrote :

I had the same problem.
I tried removing flashplugin-installer and installing gnash and mozilla-plugin-gnash instead, which didn't work.
But then I removed gnash, and installed flashplugin-installer again, and now it's working :).

Rune K. Svendsen (runeks) wrote :

So I suggest people try executing the following command, which reinstalls the package flashplugin-installer:

sudo apt-get --reinstall install flashplugin-installer

Guido Do (guido-dornbusch) wrote :

#9 works for me

lanig (alainbe) wrote :

#9 works for me to. Need to restart firefox though.

Fabio Marzocca (thesaltydog) wrote :

Each time I need to watch a flash video, I have to --reinstall flashplugin-reinstaller.
Will this bug be fixed before release?

Carambolos (carambolos) wrote :

Works for me, reinstalling each time.

noushi (noushisubs) wrote :

#9 works, reinstalling every reboot.

Fabio Marzocca (thesaltydog) wrote :

Do we have to stay with this reinstallation issue at every boot? No kind of fix/workaround?

xplong (xplong666) wrote :

Could you test this????
rm ~/.mozilla/plugins/libflashplayer.so

It works for me (in Ubuntu):
Source: http://www.willmcgugan.com/blog/tech/2010/5/2/no-audio-in-flash-on-ubuntu-1004/

Fabio Marzocca (thesaltydog) wrote :

@xplong. Yes, I have already reported this workaround here: https://bugs.edge.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/532542

b_b (brunobergot) wrote :

@xplong : great this works for me too :) I had two versions of flashplayer isntalled Shockwave Flash 10.0 r45 and Shockwave Flash 10.0 r42. Now with only 10.0 r45 it works !

Carambolos (carambolos) wrote :

Great, it works! :)
Thanks xplong

noushi (noushisubs) wrote :

Thanks #16, worked!

Onewing (williammitc) wrote :

# 4 worked for me.

komputes (komputes) on 2011-01-05
Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
summary: - no sound in flash in several browsers on kubuntu 10.04
+ no sound in flash in several browsers on kubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers