package flashplugin-installer (not installed) failed to install/upgrade:

Bug #518263 reported by Tom Pino on 2010-02-07
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

This is an apport generated report of a failure during an upgrade from a clean install of 8.04 to10.04.

ProblemType: Package
Architecture: amd64
Date: Sat Feb 6 20:19:33 2010
DistroRelease: Ubuntu 10.04
ErrorMessage:
 ErrorMessage: no package named `flashplugin-installer' is installed, cannot configure
Package: flashplugin-installer (not installed)
ProcVersionSignature: Ubuntu 2.6.24-27.65-generic
SourcePackage: flashplugin-nonfree
Title: package flashplugin-installer (not installed) failed to install/upgrade:
Uname: Linux 2.6.24-27-generic x86_64

Tom Pino (metalsmith-rangeweb) wrote :
Monkey (monkey-libre) wrote :

1. Please do in the Terminal the next command and copy the output here:
sudo dpkg --configure -a

2. Try ro reinstall

3. If You can´t do it. Please do in the terminal the next command and copy the output here:
sudo apt-get -f install flashplugin-nonfree

Thank You for making Ubuntu better.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Incomplete
ub_user (yahoo-bikesatwork) wrote :

I experienced the same problem on upgrade from 32-bit 8.04 to 10.04.

'sudo dpkg --configure -a' returns nothing
'sudo apt-get -f install flashplugin-nonfree' returns :

You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  flashplugin-nonfree: Depends: flashplugin-installer but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

'sudo apt-get -f install flashplugin-installer' returns:
dpkg: error processing flashplugin-nonfree (--remove):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)

Alexey Gaskov (gaskovster) wrote :

Here is the solution:
1. Backup your /var/lib/dpkg/status file NB You MUST do this first, because if you lose this file, your system is hosed.
In a terminal, run: sudo cp /var/lib/dpkg/status /var/lib/dpkg/status.backup

2. In a terminal, type in the following command: sudo nano /var/lib/dpkg/status
Replace "nano" with gedit, kate or whatever other editor you use.

3. Search for "flashplugin-nonfree" in the opened file.
In nano you can press Ctrl-W, then type "flashplugin-nonfree" (without the quotes) and press Enter
The different entries are delimited by empty lines. This means everything within the block containing
Do not delete the first and best match you get. Keep searching (press Crtl-W, then Enter again in nano) until you find a block (content between two empty lines) starting with:
Package: flashplugin-nonfree

4. Delete this block.
In nano, you can press Crtl-K to delete single lines until the next package appears (you will recognize this by the empty line and another "Package: something" line)

5. Save the file
In nano, Ctrl-X, Y, Enter

5.1 Run this:
sudo apt-get install flashplugin-nonfree
(not needed to get a working system, but wanted to keep the package installed)

5.2 In my case, as I started out doing a dist-upgrade, I ran the following commands:
sudo apt-get -f install
sudo apt-get autoremove
sudo aptitude dist-upgrade

6. restart the system (sudo shutdown -r now).

Source:
https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/365392

David Bowen (lilypatch) wrote :

Last night I did an 8.04 - 10.04 upgrade, yup still beta 2.
I had the flashplayerplugin-nonfree problem.
It took me a few hours to find monkey's solution.

Monkey wrote on 2010-02-08: #2

1. Please do in the Terminal the next command and copy the output here:
sudo dpkg --configure -a

2. Try ro reinstall

3. If You can´t do it. Please do in the terminal the next command and copy the output here:
sudo apt-get -f install flashplugin-nonfree

I guess it is not resolved, perhaps recommending that flashplugin be uninstalled before an upgrade in the relalease notes would be a good idea?

Anyway thanks for the good work

fjfrean (fjfrean) wrote :

I had the same problem when upgraded from 8.04 to 10.04, and I resolved it following the steps provided by Alexey Gaskov (#4).

Thanks for all, pal.

Roland Burton (rwburton) wrote :

Thank you Alexey Gaskov (#4). Fixed it for me.

Darby (darby19d) wrote :

Alexey Gaskov's fix worked for me.

YoBa (ya-baeyens) wrote :

Alexey Gaskov's fix worked for me, too. Thanks a lot Alexey.

Siribillo (kasperkasper) wrote :

Thank you Alexey Gaskov, once again your fix worked!
Siribillo

Denny Johnson (djspn) wrote :

Thanks Alexey, worked for me.
Great, simple, thorough instruction.

zeroadrenaline (paz-mariano) wrote :

Excelent solution. Works for me. Before this, I have the 10.01 r999 version of the shockwave plugin on my firefox.
After this solution, 10.01 r82 (My desktop have this version, and works fine) working excelent.
Txs Alexey.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers