package flashplugin-nonfree 10.0.1.218+really9.0.260.0ubuntu1 failed to install/upgrade:

Bug #504991 reported by dr4c4n on 2010-01-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

1) currently (i believe 8.04)
2) I have no idea, since it's hung
 I received this error message while upgrading my xubuntu from 8.04 to 9.10.

the last thing that I can see on the distribution upgrade box (since there's a black box cut out of it, is:

File "/usr/lib/python2.5/logging/__init__.py", line 731, in flush self.stream.flush()
IOError: [Errno 9] Bad File descriptor

3) I'm expecting to upgrade my xubuntu from 8.04 to 9.10 using the distribution upgrade dialog.

4) A message dialog came up so I thought id' be nice and send you this in :) Have a great day!

ProblemType: Package
Architecture: amd64
Date: Fri Jan 8 18:10:15 2010
DistroRelease: Ubuntu 9.10
ErrorMessage:
 ErrorMessage: Package is in a very bad inconsistent state - you should reinstall it before attempting configuration.
NonfreeKernelModules: nvidia
Package: flashplugin-nonfree 10.0.1.218+really9.0.260.0ubuntu1
ProcVersionSignature: Ubuntu 2.6.24-26.64-generic
SourcePackage: flashplugin-nonfree
Title: package flashplugin-nonfree 10.0.1.218+really9.0.260.0ubuntu1 failed to install/upgrade:
Uname: Linux 2.6.24-26-generic x86_64

dr4c4n (dr4c4n) wrote :
dr4c4n (dr4c4n) wrote :

Is anyone going to help me out with this?!? For, at the moment I cannot view / install / uninstall this flash plugin and therefore cannot view any flash content on websites. And it currently says unassigned.

dr4c4n (dr4c4n) wrote :

ha, I also tried to sign the code of conduct on launchpad but found out I cannot install gpa to generate my pgp key due to a dependancy on flashplugin-installer!!!

see below:

sudo apt-get install gpa
[sudo] password for ******:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  flashplugin-nonfree: Depends: flashplugin-installer but it is not going to be installed
  gpa: Depends: libgpgme11 (>= 1.1.6) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

could someone please help me?

dr4c4n (dr4c4n) wrote :

as an update I checked my ubuntu version now .. the output of lsb_release -a is as follows:

****@********:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic

Charlie Kravetz (charlie-tca) wrote :

Thanks for this report. What happened when you ran 'apt-get -f install' ? Was that able to fix the issue for you?

Changed in flashplugin-nonfree (Ubuntu):
status: New → Incomplete
Remco (remco47) wrote :

When I run "sudo apt-get -f install" I get the error that I should reinstall it before attempting removal, because the package is in a very inconsistent state.

Remco (remco47) wrote :

When I follow the advice of the previous command, which is to reinstall the package (sudo apt-get install --reinstall flashplugin-nonfree), I get dependency errors. flashplugin-nonfree depends on flashplugin-installer, but it is not going to be installed.

Remco (remco47) on 2010-02-02
Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → Confirmed
dr4c4n (dr4c4n) wrote :

when I ran apt-get -f install I got this message:

sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libjaxp1.3-java libarts1c2a ispell ibritish libartsc0 libwxbase2.6-0 libmtp7
  liblzo1 libopenal0a libneon27 libavutil1d libxerces2-java
  thunderbird-locale-en-gb nvidia-kernel-common libicu38 libmysqlclient15off
  libgpod3-nogtk libfame-0.9 libxalan2-java g++-4.2 libcrypto++7 libswscale1d
  openoffice.org-l10n-en-gb libpvm3 openoffice.org-l10n-en-za libtunepimp5
  openoffice.org-help-en-gb libdns35 openoffice.org-help-en-us libsgutils1
  libamrnb3 libdvbpsi4 libstdc++6-4.2-dev libdirectfb-1.0-0 libavcodec1d
  libxosd2 libx264-57 python-ogg libvlc0 libamrwb3 bsh libwxgtk2.6-0
  libsilc-1.1-2 libggi2 libgii1 libpostproc1d libifp4
  openoffice.org-l10n-common libgii1-target-x language-support-translations-en
  python-pyvorbis libdc1394-13 libavformat1d openoffice.org-writer2latex
  libmjpegtools0c2a binutils-static iamerican libnjb5 libofa0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  flashplugin-installer flashplugin-nonfree
Suggested packages:
  konqueror-nsplugins ttf-xfree86-nonfree xfs
The following NEW packages will be installed:
  flashplugin-installer
The following packages will be upgraded:
  flashplugin-nonfree
1 upgraded, 1 newly installed, 0 to remove and 17 not upgraded.
1 not fully installed or removed.
Need to get 21.3kB of archives.
After this operation, 61.4kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ca.archive.ubuntu.com karmic-updates/multiverse flashplugin-installer 10.0.42.34ubuntu0.9.10.1 [19.5kB]
Get:2 http://ca.archive.ubuntu.com karmic-updates/multiverse flashplugin-nonfree 10.0.42.34ubuntu0.9.10.1 [1,774B]
Fetched 21.3kB in 0s (32.3kB/s)
Preconfiguring packages ...
dpkg: error processing flashplugin-nonfree (--remove):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)

dr4c4n (dr4c4n) wrote :

sorry I didn't add that output as attachment..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers