Chinese input methods stop working in flash

Bug #472787 reported by Qianqian Fang on 2009-11-03
44
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned
ibus (Ubuntu)
Undecided
Unassigned
scim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

In Karmic, the default Chinese input method, ibus, does not work in a flash page. Neither does SCIM.

Pressing Ctrl+Space does not invoke the input method when a input box is in focused.

To replicate, first browse http://1g1g.com, then click on the inputbox in the top bar, pressing Ctrl+space, it will not invoke the pre-set Chinese input method (set by im-switch -s), instead, a space will be typed in the box.

Of course, you may not be able to see Chinese characters out-of-box, due to Bug#207198.

Qianqian Fang (fangq) on 2009-11-03
Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
Zeniff (zeniffmartineau) wrote :

I have this problem in Karmic, too. When SCIM was default in Jaunty, I was able to type... but it was not Chinese. It was messed up as though it was in the wrong encoding. Coping and pasting (if I remember right) would work. The website worked fine on Firefox in Windows, though, so I don't think it had anything to do with the website itself.

Just in case, here's the website where I had the problem (choose the first section, then Vocabulary, and then the typing game):
http://edu.ocac.gov.tw/lang/chineselearn/

David Planella (dpm) on 2009-11-04
tags: added: input-method

Relevance is high cause many websites use flash to interact with the
user, forms, validate information, and so on

David Planella wrote:
> ** Also affects: ubuntu-translations
> Importance: Undecided
> Status: New
>
> ** Tags added: input-method
>
>

Aron Xu (happyaron) on 2009-11-11
Changed in ubuntu-translations:
assignee: nobody → Aron Xu (happyaron)
importance: Undecided → Medium
status: New → Confirmed
Aron Xu (happyaron) wrote :

We need concern about this adobe upstream bug, which is lacking for people confirming and providing more information. It seems to be hard when we want to solve this problem since flash-player is a non-free software and the problem might be some issue internal of it.
http://bugs.adobe.com/jira/browse/FP-136

Aron Xu (happyaron) on 2009-12-26
Changed in ubuntu-translations:
assignee: Aron Xu (happyaron) → nobody
Peng Huang (shawn-p-huang) wrote :

FYI, The problem has been fixed in the latest Adobe flash player for Linux (10.1 beta 2).

http://code.google.com/p/chromium/issues/detail?id=19926#c19

Panyarak (panya-me) wrote :

Hi, what I am experiencing are :
1. The IM will not work, i.e. no input available, every first time I login to the computer. The IM will work if I logout and login again.
2. The IM still does not work with flash pages. The have checked with the link suggested by Peng Huang and found that my system is using Adobe Flash Player version 10,0,42,34 which is supposed to be the latest version.

Peng Huang (shawn-p-huang) wrote :

The latest beta version is 10,1,51,66.

areteichi (areteichi) wrote :

Yeah, using the latest beta does solve this issue.
Thank you!

Aron Xu (happyaron) wrote :

A quick comment, does this bug get fixed in the newly release Flash for Linux?

Rolf Leggewie (r0lf) wrote :

FWIW, I have the newest flash version installed, I think. Yet, the test case given in comment 0 still fails for me.

Rolf Leggewie (r0lf) wrote :

ii flashplugin-nonfree 10.1.53.64ubuntu0.10.04.1 Adobe Flash Player plugin installer (transitional package)

Qianqian Fang (fangq) wrote :

On 06/13/2010 02:12 AM, Aron Xu wrote:
> A quick comment, does this bug get fixed in the newly release Flash for
> Linux?
>

Tested on two machines at home running Lucid, one fresh installation,
one upgraded from older versions. The input method (ibus) in the
latter one worked ok, but in the former one it failed. Not sure why.

Both machines use en_US locale, with Chinese support installed.
The "im-switch -l" output are almost identical.

Is this ibus and/or scim's fault? Please respond if you think so.

Changed in ibus (Ubuntu):
status: New → Incomplete
Changed in scim (Ubuntu):
status: New → Incomplete
Aron Xu (happyaron) wrote :

Please check whether latest version of flash still have this problem.

Changed in ubuntu-translations:
status: Confirmed → Incomplete
Changed in flashplugin-nonfree (Ubuntu):
status: Confirmed → Incomplete
Aron Xu (happyaron) wrote :

Verified that this problem doesn't appear anymore, so close it.

Changed in ubuntu-translations:
status: Incomplete → Fix Released
Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → Fix Released
Changed in ibus (Ubuntu):
status: Incomplete → Invalid
Changed in scim (Ubuntu):
status: Incomplete → Invalid
antoirehew (antoirehew-uk) wrote :

i have this same problem of playing flash shockwave game (chinese mmorpg) , the ibus work fine in non-flash input area but not the flash input area (ctrl+space) not trigger ibus

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.