Flash audio stutters on video collaboration websites

Bug #457846 reported by Kwinz on 2009-10-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
PulseAudio
New
Undecided
Unassigned
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

Flash audio stutters on video collaboration websites

How to reproduce:

Start Firefox 3.5.3
go to http://tinychat.com
enter any chatroom with a live video stream

In the "sound preference dialog" in the "applications" tab there are
some ALSA plug-in [firefox] entries, of which the last one flickers as the sound stutters.

If you switch the device profile, in the in the "hardware" section of the "sound preference" dialog, to some other setting and then switch back, the stuttering disappears for a few seconds.

Opera 9.64 for Linux has the same issue. However on Windows the firefox works fine.

I also tried to work arround this bug by starting firefox with OSS:
FIREFOX_DSP="aoss" firefox
or aoss firefox
but that approach seems to be outdated and did not work.

I have a 64bit installation. It would be nice if somebody could confirm this on 32bit.
Please tell me, whether you need any more information.

Kwinz (ldm) on 2009-10-22
affects: pulseaudio (Ubuntu) → flashplugin-nonfree (Ubuntu)
Kwinz (ldm) wrote :
Kwinz (ldm) wrote :

I am sorry i can not post a better example. I did not know that it was that hard to find a channel to reproduce this that has not 10 screaming teenagers playing hip hop music in it. :X

Jan Girke (jangirke) wrote :

I have a similar problem.
It seems to be triggered by the hibernation on my machine.
After restarting the whole system everything works for a while.
Until I close the lid of my laptop.
YouTube videos stutter.

Jan Girke (jangirke) wrote :

I forgot to mention I run Kubuntu 9.10 with recent upgrades.

Daniel T Chen (crimsun) wrote :

Please use apport-collect -p alsa-base 457846

Changed in flashplugin-nonfree (Ubuntu):
status: New → Incomplete

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: renji 1895 F.... pulseaudio
 /dev/snd/pcmC0D0p: renji 1895 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xf4100000 irq 22'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1458e601,00100002'
   Controls : 40
   Simple ctrls : 22
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
Uname: Linux 2.6.31-20-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
gitpik (gitpik) wrote :

I have the same problem as Kwinz but on a 32bit install. Same issue using Karmic Main pulseaudio and also with Ubuntu Audio Dev team PPA version of Pulse. I notice that when a video collaboration window is open PA volume control shows a separate mono "ALSA plug-in [firefox] " stream for each of the broadcasted microphones with one or two extra ones flickering in and out at the bottom of the list but too fast to tell how many. The creation and removal of the extra sources continues even if you mute your speakers from within tinychat, but you can only hear the stuttering if there is another flash audio source playing at that time. I hope this isn't too confusing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers