flash plugin not react mouse click in firefox, karmic koala, amd64

Bug #434606 reported by asch on 2009-09-22
This bug report is a duplicate of:  Bug #410407: Buttons don't respond to mouse clicks. Edit Remove
98
This bug affects 22 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Andrew Somerville
Nominated for Lucid by Andrew Somerville

Bug Description

Binary package hint: flashplugin-installer

With nvidia restricted driver installed (using system/administration/Hardware Drivers) the flash plugin does not react on mouse click. Mouse over seems to work, ad Tooltip popups can be seen but buttons can not be clicked.

Reproduce:
 1. Install flashplugin-installer
 2. install nvidia restricted driver
 3. launch Firefox
 4. browse a video on youtube.com
 5. try to use the controls on the video player - they don't work

With the nvidia driver uninstalled and using the open source driver (the one that is used by default) the bug does not occur. The video can be controlled fine.

Ubuntu version: Ubuntu 9.10 - the Karmic Koala - amd64 release
Plugin version:
~$ apt-cache policy flashplugin-installer
flashplugin-installer:
  Installed: 10.0.32.18ubuntu1
  Candidate: 10.0.32.18ubuntu1
  Version table:
 *** 10.0.32.18ubuntu1 0
        500 http://hu.archive.ubuntu.com karmic/multiverse Packages
        100 /var/lib/dpkg/status

Jonathan Steinhart (jsteinhart) wrote :

I have this too. It began upon upgrading to Karmic. I had been using the flashplugin-nonfree package (which is now labeled as a transitional package), and I also tried purging that and using the (new?) adobe-flashplugin package; but neither work.

I'm using the open source radeon video driver.

hass (sceptre0) wrote :

I am having the same problem. Some flash video players work, but not Youtube. http://www.engadget.com/video.

I using Ubuntu 9.10 64bit with the latest Nvidia driver.

~$ apt-cache policy flashplugin-installer
flashplugin-installer:
  Installed: 10.0.32.18ubuntu1
  Candidate: 10.0.32.18ubuntu1
  Version table:
 *** 10.0.32.18ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/multiverse Packages
        100 /var/lib/dpkg/status

wensveen (wensveen) wrote :

A workaround for me is to disable visual effects (in the Appearance Preferences). See: http://ubuntuforums.org/showpost.php?p=7746335&postcount=15

So this might have to do something with compiz. Turning compiz on or off has immediate effect, I don't even need to reload the flash app.

Jonathan Steinhart (jsteinhart) wrote :

For what it's worth, I'm not using Compiz... the Visual Effects tab has "None" selected.

This is a duplicate bug report. You should not post new comments here. Please read all comments on the other bug report before posting anything new. The large list of comments is a good indication what you have said is already there.

You should read the description carefully as well. This is a duplicate of 410407 which is stated on the top of this bug report.

Tony (tony-hatz) wrote :

I have tried the following and mouse clicks are working again.

sudo gedit /usr/lib/nspluginwrapper/i386/linux/npviewer
Add this before the last line of text “export GDK_NATIVE_WINDOWS=1″, then save and restart firefox.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers