flash not recognizing mouse clicks

Bug #434050 reported by Clueless on 2009-09-21
This bug report is a duplicate of:  Bug #410407: Buttons don't respond to mouse clicks. Edit Remove
This bug affects 13 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Nominated for Karmic by yeus
Nominated for Lucid by yeus

Bug Description

I am running the latest alpha of ubuntu 9.10 .

The flash player in firefox appears to load ok, but never plays any content.

I have updated my system to get all the latest updates but that has had no effect.

The install of 9.10 alpha is a new install

John Vivirito (gnomefreak) wrote :

Please post the output to the following commands:
lsb_release -a
uname -a
apt-cache policy flashplugin-nonfree flashplugin-installer firefox-3.5 firefox swfdec-mozilla

can you please post a few different sites you see this on. link to video itself would be great.

affects: firefox-3.0 (Ubuntu) → flashplugin-nonfree (Ubuntu)
Changed in flashplugin-nonfree (Ubuntu):
status: New → Incomplete
Clueless (imateene) wrote :

here is the info you requested:

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu karmic (development branch)
Release: 9.10
Codename: karmic

$ uname -a
Linux rapa-nui 2.6.31-10-generic #34-Ubuntu SMP Wed Sep 16 01:09:15 UTC 2009 x86_64 GNU/Linux

$ apt-cache policy flashplugin-nonfree flashplugin-installer firefox-3.5 firefox swfdec-mozilla
  Installed: (none)
  Version table: 0
        500 http://us.archive.ubuntu.com karmic/multiverse Packages
  Installed: (none)
  Version table: 0
        500 http://us.archive.ubuntu.com karmic/multiverse Packages
  Installed: 3.5.3+build1+nobinonly-0ubuntu2
  Candidate: 3.5.3+build1+nobinonly-0ubuntu2
  Version table:
 *** 3.5.3+build1+nobinonly-0ubuntu2 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status
  Installed: 3.5.3+build1+nobinonly-0ubuntu2
  Candidate: 3.5.3+build1+nobinonly-0ubuntu2
  Version table:
 *** 3.5.3+build1+nobinonly-0ubuntu2 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status
  Installed: (none)
  Candidate: 0.8.2-1ubuntu2
  Version table:
     0.8.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com karmic/universe Packages

Clueless (imateene) wrote :

none of these flash sites is working properly ..


you can also try any video on youtube.com

the flash page seems to load but you don't see anything, almost like looking at a blank page ..

Clueless (imateene) wrote :

I found the problem, I upgrade from 9.04 32 bit to 9.10 alpha 64 bit. I happen to have the 32 bit version of the libflashplayer.so in my local directory .mozilla/plugins

I removed the plugin but now firefox couldn't find a suitable plugin to load. I went to Adobe website and it allowed me to download a falsh plugin but I was unable to install it as gdebi failed with a wrong architecture error message.

finally I downloaded Adobe beta 64 bit flashplayer plugin and now my flash pages are all working.

Users who switch from 32bit to 64 bit will have this issue, there probaly needs to be a flashplayer plugin included with firefox for 64 bit users, if that is not already being done ..

ownsyouall (ownsuall2) wrote :

I have the same problem in Ubuntu 9.10 64-Bit BETA.
I can view and listen to flash content but I can not click on but mouse-overs still work though.
I did find a work around for this by left clicking and then right clicking about 3 times I'm able to click.

mac.ryan (macryan) wrote :

I can confirm same problem on 9.10 RC.

Peter Lewis (pllewis72) wrote :

I can confirm that this is still an issue.

mac.ryan (macryan) wrote :

Just wishing to share a workaround that is prooving helpful in my case (at least on youtube.com).

You first rightclick and keeping the button pressed drag the mouse, then you can left-click without problem. After the first click, the procedure needs to be repeated for further left-clicking.

DrKay (dr-jameskay) wrote :

I'm having this problem with 64-bit Ubuntu 9.10

ben van 't ende (benvantende) wrote :

Same problem after the update to the stable 9.10. On 32bit and 64bit

Dexter (pogany-tamas+bug) wrote :

Same problem as ownsyouall has under 9.10 64 bit.

Patrick Walker (phobiac) wrote :

This is occurring on my system as well. To be clear, it EVERYTHING with flash works except for left clicking. This did not occur before an update to 9.10 from 9.04. I installed the package flashplugin-installer in order to get flashplayer.

Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → Confirmed
Dexter (pogany-tamas+bug) wrote :

Affected sites for me: youtube, google analytics (date selector), all flash games.

Patrick Walker (phobiac) wrote :

Can confirm that downloading and installing the flashplugin from the adobe website fixes this.
http://labs.adobe.com/downloads/flashplayer10.html Link to website
Here's a quick and dirty command string that should do all this for you.

Steps taken, so you know what happens:
1) Kill firefox, to make sure it isn't running (Best to do this before running, really)
2) purge flashplugin-installer from your system
3) get the archive of libflashplayer.so
4) extract the archive
5) make it executable (not sure if this is needed?)
6) copy libflashplayer.so to your home firefox plugins directory
killall firefox;sudo apt-get purge flashplugin-installer;wget http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-;tar -xvf libflashplayer-;chmod +x libflashplayer.so;cp libflashplayer.so ~/.mozilla/plugins/

I tested the command on my system twice, so it should run fine for you. I am assuming normal usage, if one or two of those commands varies you should know why. (Not using bash shell, prefer aptitude, etc.)

Patrick Walker (phobiac) wrote :

I apologize, on my system the relevant package was flashplugin-installer. It is possible you installed flashplugin-nonfree or another package, in that case just substitute the proper package name in.


Using the howto in link above, I now have flash player working flawlessly.

Dexter (pogany-tamas+bug) wrote :

I can confirm, that Thierry Daucourt's workaround is working!

jlms (jjllmmss) wrote :

This is still not working.

I downloaded the plugin from Adobe's website and followed the HowTos.

It seems to work initially but the browser remains unstable and crashes very easily.

I am just using the provided plugin, in some Flash applications (BBC iPlayer for example) one can use key shortcuts to gain some functionality, but other applications are now broken (www.metro.co.uk for example).

Maybe some people that claim the problem is solved could try to check if it is really solved or if they have just been lucky.

Funnily enough and to make matters more confusing, Adobe's demos seem to work fine.

mckemie (mckemie) wrote :

I recently upgraded from 9.04 to the released 9.10. I noticed that flash had stopped working and started googling around to find the reason. How disappointing to find this bug known in the release candidate but unaddressed in the release. Indeed, "unassigned".

I wonder if that had to do with the fact that in the bug title there was "alpha". Who knows? I changed that, let's hope! :-|

summary: - flash not running in 9.10 alpha 64 bit
+ flash not running in 9.10 64 bit (Final Release)
mckemie (mckemie) wrote :

Thierry Daucourt's workaround worked for me, too.

marwayusuf (marwayusuf) wrote :

I'm trying to open Thierry Daucourt's workaround, but the page doesn't load.

AllanEising (allan-eising) wrote :

I must protest. Circumventing the bug by installing the flashplugin from the official site isn't a solution. Besides, it makes my browser really unstable. We need the firefox and the flash maintainers to look into this. I'm very shocked that the bug hasn't been assigned to anyone yet.

mckemie (mckemie) wrote :

The work around link just worked again for me. Here is the same through is.gd:

I agree that it is a bug that should be fixed; should have been fixed before the release. Meanwhile, I/we need working systems, so the work around IS needed.

Since I don't contribute much to Ubuntu, I'm reluctant to cast many stones.

Now, I need to look into why 9.10 broke my power management :-(

Patrick Walker (phobiac) wrote :

Marked this as duplicate of https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/410407, please go there for further assistance

summary: - flash not running in 9.10 64 bit (Final Release)
+ flash not recognizing mouse clicks
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers