package flashplugin-installer 10.0.32.18ubuntu0.9.04.1 failed to install/upgrade: cd: 143: can't cd to /var/cache/flashplugin-installer

Bug #433000 reported by Arkansis on 2009-09-19
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

arkansis@dharma-initiative:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]?
Setting up flashplugin-installer (10.0.32.18ubuntu0.9.04.1) ...
cd: 143: can't cd to /var/cache/flashplugin-installer
dpkg: error processing flashplugin-installer (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 flashplugin-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
arkansis@dharma-initiative:~$ sudo mkdir -p /var/cache/flashplugin-nonfree
arkansis@dharma-initiative:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]?
Setting up flashplugin-installer (10.0.32.18ubuntu0.9.04.1) ...
cd: 143: can't cd to /var/cache/flashplugin-installer
dpkg: error processing flashplugin-installer (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 flashplugin-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
arkansis@dharma-initiative:~$

ProblemType: Package
Architecture: amd64
DistroRelease: Ubuntu 9.04
ErrorMessage: subprocess post-installation script returned error exit status 2
NonfreeKernelModules: nvidia
Package: flashplugin-installer 10.0.32.18ubuntu0.9.04.1
SourcePackage: flashplugin-nonfree
Title: package flashplugin-installer 10.0.32.18ubuntu0.9.04.1 failed to install/upgrade: subprocess post-installation script returned error exit status 2
Uname: Linux 2.6.28-15-generic x86_64

Arkansis (arkansis1) wrote :
DeadVirus (amfcosta13) on 2009-11-23
Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
summary: package flashplugin-installer 10.0.32.18ubuntu0.9.04.1 failed to
- install/upgrade: subprocess post-installation script returned error exit
- status 2
+ install/upgrade: cd: 143: can't cd to /var/cache/flashplugin-installer

I came the upgrade path 9.10 -> 10.04 and flash was not working. so I tried to remove and reinstall the flashplugin-nonfree package. Removing did not work, I used the workaround in Bug 429841 .
When trying to install I hit this bug. The workaround is easy in a terminal:

> sudo su

# mkdir /var/cache/flashplugin-installer

(Or open a root terminal and skip the first step) Then you can install the package.

Gonzalo (gonzalo-poseidonlinux) wrote :

Same to me. Not even the purge command solved the problem!
Cannot install, uninstall, re-install flash.

 flashplugin-installer
 flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)

The solution is only one to solve this recurrent problem: MAKE A 100% FREE, OPEN SOURCE PLUG-IN that really works and forget about Adobe.

alistair hookings (va-va) wrote :

I noted in apt-get that it was trying to cd to
/var/cache/flashplugin-nonfree, but the directory didn't exist. I did
sudo mkdir and then tried apt-get again, and got flashplugin-nonfree
to install.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers