jaunty: youtube crashes firefox

Bug #321586 reported by czaby on 2009-01-26
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

0. upgrade to jaunty
1. start firefox
2. go to youtube (or any other site that has embedded video)
3. start any video

firefox crashes as follows:

$ mozilla
ALSA lib pcm_pulse.c:626:(pulse_prepare) PulseAudio: Unable to create stream: Invalid argument
(repeated several times)

E: shm.c: mmap() failed: Cannot allocate memory
(repeated several times)

firefox: pulse.c:200: pulse_new: Assertion `p->context' failed.
Aborted (core dumped)

$ lsb_release -rd
Description: Ubuntu jaunty (development branch)
Release: 9.04

$ apt-cache policy firefox
firefox:
  Installed: 3.0.5+nobinonly-0ubuntu1
  Candidate: 3.0.5+nobinonly-0ubuntu1
  Version table:
 *** 3.0.5+nobinonly-0ubuntu1 0
        500 http://de.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

czaby (peter-czabala) wrote :

With the the updates coming today to jaunty, this problem has disappeared.
I don't know which package was actually causing it but thanks for the fix anyway.

Changed in firefox:
assignee: nobody → peter-czabala
status: New → Invalid
KLoK (klokane) wrote :

Hi there,
  I've got this problem again (jaunty alpha 6)

Any flash is working, until try to play sound.

klok@klok-laptop:~$ lsb_release -rd
Description: Ubuntu jaunty (development branch)
Release: 9.04

klok@klok-laptop:~$ apt-cache policy firefox
firefox:
  Installed: 3.0.7+nobinonly-0ubuntu1
  Candidate: 3.0.7+nobinonly-0ubuntu1
  Version table:
 *** 3.0.7+nobinonly-0ubuntu1 0
        500 http://cz.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

KLoK (klokane) on 2009-03-15
Changed in firefox:
status: Invalid → Confirmed
Changed in firefox (Ubuntu):
assignee: peter-czabala → nobody
Andrew Seyes (andrew-seyes) wrote :

Hello,
I had this problem and noticed I had flash version 9 installed.
On upgrading flash to version 10 I found that embedded video playback works again.

I have the same problem with jaunty beta and firefox 3.08, opera, epiphany . I installed flash 10 from adobe but nothing happens and the firefox shows version 9 yet.How can I solve this?

I solved the problem. I saw that plugin swfdec was the problem. I uninstalled from the synaptic the mozilla-plugins swfdec and gnash. I uninstalled also the flash 9. Then I installed the flash 10 and all are OK (firefox, opera, epiphany).
Thanks Andrew Seyes for your help.

Omacht András (omacht.andras) wrote :

Hi!

I'd following packages installed (9.04):
ii firefox 3.0.8+nobinonly-0ubuntu3 meta package for the popular mozilla web browser
ii pulseaudio 1:0.9.14-0ubuntu20 PulseAudio sound server
ii pulseaudio-esound-compat 1:0.9.14-0ubuntu20 PulseAudio ESD compatibility layer
ii pulseaudio-module-gconf 1:0.9.14-0ubuntu20 GConf module for PulseAudio sound server
ii pulseaudio-module-hal 1:0.9.14-0ubuntu20 HAL device detection module for PulseAudio sound server
ii pulseaudio-module-x11 1:0.9.14-0ubuntu20 X11 module for PulseAudio sound server
ii pulseaudio-utils 1:0.9.14-0ubuntu20 Command line tools for the PulseAudio sound server

when I starting any flash video WITH SOUND firefox crashes. (without sound everything is ok).
This message going to syslog all the time:
Apr 19 19:25:14 robinson pulseaudio[4300]: sink-input.c: Failed to create sink input: too many inputs per sink.

I can play videos with sound with players and everything is ok, expect the flash videos with sound...

With 8.10 everything was ok.

Age (a-deboer) wrote :

Had the same problem, tried many many things, but thanks to despotakisch I got it solved:
- removed the old flash player using synaptic: searched for a package with name 'swfdec' and got rid of it
- then (re-)installed the flash 10 from the adobe website

Flash content is now happily playing music. In the PulseAudio Manager you can see a client with name 'Alsa plug-in [firefox]'.
With flash version 9, some client with 'Alsa' in the name did also occur, but instead of one, hundreds of them which crashed firefox.

Glad I got it sorted.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers