flashplugin: incorrect unicode input

Bug #321143 reported by Nicolas Delvaux on 2009-01-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

Ubuntu 8.10
Version of flashplugin-nonfree: 10.0.15.3ubuntu1~intrepid1
Locale: fr_FR (maybe same problem with other?)

It's a long time bug but I can't find any bug-report about this, so here it is!

In flash sites (like deezer, open street map...) accent aren't displayed normally: typing "é" displays "é", "ô" displays "ô" and same kind of things with all accents!
However, if I type accents, for example in OO.o or any non-flash area in Firefox, and then I copy-paste it to the flash site, it displays very well.

Thank you for your attention! (and sorry for my English ;) )

Nicolas Delvaux (malizor) wrote :
description: updated
Daniel T Chen (crimsun) wrote :

Please report this bug upstream to Adobe then link to the issue tracker number here.

Changed in flashplugin-nonfree:
status: New → Incomplete
Nicolas Delvaux (malizor) wrote :

Well, I though it was an Ubuntu bug, sorry for that.
In fact it seems to be a long term bug: since flash 9.0.124.0 ! (I never noticed this before...)
Here is the link to the issue tracker:

http://bugs.adobe.com/jira/browse/FP-40

description: updated
Nicolas Delvaux (malizor) wrote :

This bug is still marked as « incomplete » and, unfortunately, should expire soon.

Sorry to insist, but this is still an important issue, which seems to affect many locales (German, French, Greek, Spanish, Portuguese...)

John Vivirito (gnomefreak) wrote :

Ubuntu is unablet o fix this bug since flash is not released under a free license.

John Vivirito (gnomefreak) wrote :

Daniel: Can you register flash so we can link to upstream bug? I tried and it failed.

mike (donotaskwhoiam) wrote :

I am From China, and have the same problem with Chinese.

As far as I know, the latest fedora does not have this problem.

So I guess it is a problem of both Adobe and Ubuntu?

BTY, I really hope this bug fixed soon. :)

Nicolas Delvaux (malizor) wrote :

Upstream said that this may be fix with the "next major release".
Since it is impossible to link this bug to the upstream bug tracker, I changed the status to confirmed.

Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → Confirmed
Nicolas Delvaux (malizor) wrote :

The new flash update have fixed this for me.
(adobe-flashplugin 10.0.32.18-1jaunty1)

Changed in flashplugin-nonfree (Ubuntu):
status: Confirmed → Fix Committed
Selmi (selmi) wrote :

for me it didn't worked before. now they promised its really fixed
http://bugs.adobe.com/jira/browse/FP-40
http://labs.adobe.com/downloads/flashplayer10.html

i hope fixed version will get to repositories soon

JC Hulce (soaringsky) wrote :

This bug has been marked as Fix Committed for over a year. If the fix has made it into Ubuntu, please mark this bug as Fix Released. If the fix has been released upstream, but not Ubuntu, create a new bug asking for the new version and tag it with upgrade-software-version. If this bug stays inactive for a long period, it may be expired.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments