flashplugin-nonfree on amd64 should use pure 64 bit plugin

Bug #299146 reported by Pelládi Gábor on 2008-11-17
166
This bug affects 31 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Debian)
Fix Released
Unknown
flashplugin-nonfree (Ubuntu)
Wishlist
Unassigned
Nominated for Intrepid by Luke Hoersten
Nominated for Jaunty by Luke Hoersten

Bug Description

Binary package hint: flashplugin-nonfree

Adobe has released a 64 bit version of their flash plugin. It is currently under development, but it should be considered for Jaunty. The current nspluginwrapper method pulls in ia32-libs, a huge package, and nspluginwrapper itself can contain bugs. Performance would be greater, and package maintenance would also be easier.
http://labs.adobe.com/downloads/flashplayer10.html

Luke Hoersten (lukehoersten) wrote :

I'm running the native flash 64bit now in Intrepid without nspluginwrapper. It works great! All the "fail to render" bugs are gone and large flash files like mint.com, youtube.com, and hulu.com work perfectly.

May I suggest replacing the almost unusable flashplugin-nonfree in Intrepid as well?

Changed in flashplugin-nonfree:
importance: Undecided → Wishlist
status: New → Confirmed
Savvas Radevic (medigeek) wrote :

I believe nspluginwrapper would actually keep the firefox window running even if the flash plugin crashes.. but I'm using the native 64-bit flash plugin as well, we'll see how it goes :)

Giuseppe Pennisi (giupenni78) wrote :

I can confirm flash 10-64bit works perfectly with Intrepid.
I think it ready for Intrepid but I don't know if may be other problems for the switch.
But it can try.

gp

I think it will be declined for Intrepid (maybe in hardy/intrepid
backports), but it's highly probable to make it in jaunty :)

Chris Coulson (chrisccoulson) wrote :

Yes, it almost certainly will be declined for Intrepid. The only way it will get in to Intrepid is via backports once it's been in Jaunty for a bit.

Savvas Radevic (medigeek) wrote :

filed upstream

Giuseppe Pennisi (giupenni78) wrote :

Sorry, yes.
for intrepid I wanted to tell backports. :)
I hope in this.

gp

Il giorno mar, 18/11/2008 alle 17.15 +0000, Chris Coulson ha scritto:
> Yes, it almost certainly will be declined for Intrepid. The only way it
> will get in to Intrepid is via backports once it's been in Jaunty for a
> bit.
>

Matteo Croce (teknoraver) wrote :

While the nspluginwrapped one crashed very often this is much more stable.
please backport it to intrepid!

Noel J. Bergman (noeljb) wrote :

Another vote for an Intrepid backport.

Hew (hew) wrote :

This is not a poll, there is no need for +1 comments. Please use the "affects me" feature at the top of the page if you're looking to show your support. We simply need to get this in Jaunty first before it is considered for intrepid-backports. You can read more about the backports process at https://help.ubuntu.com/community/UbuntuBackports . Thanks.

Noel J. Bergman (noeljb) wrote :

New 64 bit release from Adobe as of Tuesday: http://labs.adobe.com/downloads/flashplayer10.html

I've been using the 64-bit version with Jaunty, and do hope that it will be part of the Jaunty release, if there are no showstoppers when the time comes to make the go/no-go decision.

Hew (hew) wrote :

Fix Released with flashplugin-nonfree 10.0.15.3ubuntu1

Changed in flashplugin-nonfree:
status: Confirmed → Fix Released
Aaron Kelley (aaronkelley) wrote :

To clarify, this release Jaunty only?

I noticed that the Intrepid package has the same version number but it still depends on nspluginwrapper.

Hew (hew) wrote :

flashplugin-nonfree 10.0.15.3ubuntu1 is in Jaunty, which has the 64-bit version. This is not the same as flashplugin-nonfree 10.0.15.3ubuntu1~intrepid1 in Intrepid, which still has the 32-bit version. Bug 310061 tracks the 64-bit Intrepid backport request.

Alexander Sack (asac) wrote :

we will back this out until its final. we will download flash from archive.canonical.com instead of adobe ... becase at that place we get a stable URL which doesnt just disappear over night (which frequently causes issues for flasplugin-nonfree atm). Lets hope that amd64 will be final before jaunty.

Changed in flashplugin-nonfree:
status: Fix Released → Won't Fix
leech (leech) wrote :

Even though the 64bit plugin hasn't been marked as 'final' it is the same version as the 32bit version of flash. Debian's own package (version 2.8 in Squeeze and Sid) downloads the 64bit plugin with it's version of flashplugin-nonfree. It even works on Ubuntu's. So in this case, Ubuntu just hasn't synchronized the package with Debian.

I had a hell of a time on my Fedora 11 install to get Flash working with sound. Come to find out it's an issue between pulse and Flash (Surprise surprise!) and the core of the issue is that libflashsupport does not work under 64bit. It has in fact ceased development because the newer version of Flash 10 no longer needs it. But this means that unless you have 32bit pulse running with 32bit flash, then you won't get sound. 64bit really is the way to go. The less dependencies on 32bit libraries on a 64bit system, the better.

Firefox can really run at 64bit now since Java and Flash both have 64bit plugins. So just update the package already. Hell, just sync with Debian's package.

Changed in flashplugin-nonfree (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.