[intrepid] firefox crashes frequently on Intrepid with SIGABRT

Bug #282287 reported by Stephen Kendall on 2008-10-12
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
samba
Fix Released
Unknown
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

In 32-bit Intrepid, a recent upgrade from 8.04, I'm getting a lot of semi-random silent Firefox crashes. This one seems to be more repeatable than most:

This page reliably crashes the browser:

http://www.liliputing.com/2008/10/hp-2133-mini-note-prices-continue-to-drop.html

...leading to the attached gdb trace.

About my system:

spk@shermeen:~$ apt-cache policy firefoxfirefox:
  Installed: 3.0.3+build1+nobinonly-0ubuntu1
  Candidate: 3.0.3+build1+nobinonly-0ubuntu1
  Version table:
 *** 3.0.3+build1+nobinonly-0ubuntu1 0
        500 http://us.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
spk@shermeen:~$ uname -a
Linux shermeen 2.6.27-7-generic #1 SMP Fri Oct 10 03:55:24 UTC 2008 i686 GNU/Linux
spk@shermeen:~$ lsb_release -rd
Description: Ubuntu intrepid (development branch)
Release: 8.10
spk@shermeen:~$

This happens quite a bit, and always seemingly on a page with some animations (flash?). I've taken out all my add-ons and had no improvement.

Stephen Kendall (spkendall) wrote :

Good job on finding the link of death.

This links crashes firefox 303 reliably for me in intrepid as well.
But firefox303 on hardy does note crash on this link.
firefox minefield 3.1b2 on intrepid does not crash on this link (but it is very unstable/crashes randomly).

Alexander Sack (asac) wrote :

seems to be flash bug. doesnt happen here on intrepid. maybe video driver related. which video chipset/driver are you using?

Changed in firefox:
status: New → Incomplete

I'm also getting a lot of silent Firefox 3.0.3 SIGABRTs on Intrepid (32-bit desktop). The link of death doesn't work for me, though. I use the NoScript plugin so nothing Flash will load, but I can "temporarily allow all this page" (thus reloading the page) and no crash. Perhaps reloading doesn't trigger the crash condition?

My video driver is (according to "Hardware Drivers", anyway): ATI/AMD proprietary FGLRX graphics driver.

My GDB backtrace looks a lot like Stephen's:

#0 0xb7f8f430 in __kernel_vsyscall ()
#1 0xb7ce8880 in raise () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7cea248 in abort () from /lib/tls/i686/cmov/libc.so.6
#3 0xaf7d75dd in talloc_free () from /usr/lib/libtalloc.so.1
#4 0xaf9db289 in ?? () from /lib/libnss_wins.so.2
#5 0xaf7d7621 in talloc_free () from /usr/lib/libtalloc.so.1
#6 0xafa06758 in alloc_sub_basic () from /lib/libnss_wins.so.2
#7 0xafa06d3f in talloc_sub_basic () from /lib/libnss_wins.so.2
#8 0xaf946281 in ?? () from /lib/libnss_wins.so.2
#9 0xaf9473f2 in lp_lockdir () from /lib/libnss_wins.so.2
#10 0xafa00a75 in lock_path () from /lib/libnss_wins.so.2
#11 0xaf99f767 in receive_unexpected () from /lib/libnss_wins.so.2
#12 0xaf9a2375 in receive_nmb_packet () from /lib/libnss_wins.so.2
#13 0xaf9a4e4d in name_query () from /lib/libnss_wins.so.2
#14 0xaf942555 in _nss_wins_gethostbyname_r () from /lib/libnss_wins.so.2
#15 0xaf942853 in _nss_wins_gethostbyname2_r () from /lib/libnss_wins.so.2
#16 0xb7d82666 in ?? () from /lib/tls/i686/cmov/libc.so.6
#17 0xb7d84039 in getaddrinfo () from /lib/tls/i686/cmov/libc.so.6
#18 0xb7bf66b9 in PR_GetAddrInfoByName () from /usr/lib/libnspr4.so.0d
#19 0xb71d8454 in ?? () from /usr/lib/xulrunner-1.9.0.3/libxul.so
#20 0xb7c041e1 in ?? () from /usr/lib/libnspr4.so.0d
#21 0xb7f4a50f in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#22 0xb7d9e7ee in clone () from /lib/tls/i686/cmov/libc.so.6

HtH.

Mark Aiken (maiken) wrote :

I'm also getting a lot of SIGABRTs on Intrepid right after upgrading from Hardy. The repro URL supplied above crashed immediately the first time I tried it, with the backtrace below.

It's not my experience that crashes go along with loading Flash content. Also, unlike Adam, I'm running nvidia (closed-source driver 177), not ATX.

Firefox 3 is barely usable for me after upgrading; I can't keep it running under steady use for more than 10-15 minutes without a SIGABRT. Assuming we're actually experiencing the same bug, may I suggest that this isn't a video driver bug (since Adam and I are using different GPUs) and not Flash related (since Adam has disabled Flash?)

I'm attaching a more extensive dump.

#0 0xb7f57430 in __kernel_vsyscall ()
#1 0xb7cb4880 in raise () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7cb6248 in abort () from /lib/tls/i686/cmov/libc.so.6
#3 0xb08b70c5 in talloc_strdup () from /usr/lib/libtalloc.so.1
#4 0xb0b13972 in ?? () from /lib/libnss_wins.so.2
#5 0xb0b13a7f in lock_path () from /lib/libnss_wins.so.2
#6 0xb0ab2767 in receive_unexpected () from /lib/libnss_wins.so.2
#7 0xb0ab5375 in receive_nmb_packet () from /lib/libnss_wins.so.2
#8 0xb0ab7e4d in name_query () from /lib/libnss_wins.so.2
#9 0xb0a55555 in _nss_wins_gethostbyname_r () from /lib/libnss_wins.so.2
#10 0xb0a55853 in _nss_wins_gethostbyname2_r () from /lib/libnss_wins.so.2
#11 0xb7d4e666 in gaih_inet () from /lib/tls/i686/cmov/libc.so.6
#12 0xb7d50039 in getaddrinfo () from /lib/tls/i686/cmov/libc.so.6
#13 0xb7bc66b9 in PR_GetAddrInfoByName (
    hostname=0xb5220af4 "pixel.quantserve.com", af=0, flags=32800)
    at prnetdb.c:2042
        res = <value optimized out>
        hints = {ai_flags = 0, ai_family = 0, ai_socktype = 1,
  ai_protocol = 0, ai_addrlen = 0, ai_addr = 0x0, ai_canonname = 0x0,
  ai_next = 0x0}
        rv = <value optimized out>
#14 0xb71a8454 in nsHostResolver::ThreadFunc (arg=0x8ed23f8)
    at nsHostResolver.cpp:697
        flags = 32800
        status = <value optimized out>
        rec = (nsHostRecord *) 0xb5220ac0
        ai = (PRAddrInfo *) 0x1
#15 0xb7bd41e1 in _pt_root (arg=0xacf5f948) at ptthread.c:221
        detached = 1
#16 0xb7f1650f in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#17 0xb7d6a7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Mark Aiken (maiken) wrote :

More detail about my system:

maiken@maikendev:~$ sudo apt-cache policy firefox-3.0
firefox-3.0:
  Installed: 3.0.3+nobinonly-0ubuntu2
  Candidate: 3.0.3+nobinonly-0ubuntu2
  Version table:
 *** 3.0.3+nobinonly-0ubuntu2 0
        500 http://us.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
maiken@maikendev:~$ uname -a
Linux maikendev 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux
maiken@maikendev:~$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10

etsi (ets) wrote :

I am running release Intrepid Ibex with open source ATI driver using Radeon X1950 Pro graphics adapter. I've also been experiencing these silent crashes and can also confirm that the 'link of death' crashes Firefox 3.0.4 included with Intrepid.

I am also using NoScript to forbid Flash content by default.

Erich Pawlik (erichpawlik) wrote :

Like Mike, I don't think the problem is flash-related. I have been experiencing this problem also with pages with plain vanilla HTML. The "page of death2 didn't crash my firefox.

Since I have it on different machines with different graphics drivers, I don't think it is related to graphics drivers (a pretty old Dell Dimension 4700 with an ATI/AMD proprietary FGLRX graphics driver) and on a Dell Vostro 1510 with a NVIDIA accelerated graphics driver (version 177).

Changed in firefox:
status: New → Confirmed
Joe Sutton (joesutton) wrote :

I'm affected by this on a fresh install of 64-bit ubuntu.

From extensive Googling, I believe that the problem is related to adding WINS into your /etc/nsswitch.conf file. I found that last night and removed the entry. I did not have another FF crash since, but have not tried the Link of Death provided above, or used it for a long period to be sure that is the cause.

There seem to be a few bugs raised for this issue. For me (and probably for many others), the main problem was finding what was actually happening, because FF just exits and says "Aborted." in the console. Just searching for "linux firefox aborted" doesn't yield much of a response.

I will be doing more testing when I get home from work -- am stuck on a legacy OS at the moment.

Joe

Joe Sutton (joesutton) wrote :

I can confirm that the Link of Death works correctly. I have moved the WINS line to the end, so it reads:

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4 wins

Trouble is, now I can't access my samba host without defining it in hosts. I don't know what the problem is, but at least FF is usable again...

Joe

Mark Aiken (maiken) wrote :

It turns out this is a Samba bug, which is why disabling WINS resolution solves it. See this Samba bug:

https://bugzilla.samba.org/show_bug.cgi?id=5904

There is a proposed samba patch there for anyone who would like to try it; I haven't gotten a chance to do so but I'm sure the Samba team would appreciate confirmation of the fix.

John Vivirito (gnomefreak) wrote :

Not a flash bug

Changed in flashplugin-nonfree:
status: Incomplete → Invalid
John Vivirito (gnomefreak) wrote :

Added samba for task and added upstream bug.
Thanks for the link.

Changed in samba:
status: Unknown → In Progress
nanotube (nanotube) wrote :

Hi,
My firefox (3.0.4, out of the official repos) on intrepid (fresh install, not upgrade) crashes occasionally, and completely silently. it just /disappears/, without any messages.

I do not use samba, i have no "wins" anywhere in my /etc/nsswitch.conf

maybe that means this is a different bug... but i am not sure.

it doesn't even happen necessarily when i'm browsing. i can walk away from the comp, come back, and firefox is gone. i have noscript and adblock installed, so pages don't tend to "do" anything when i'm not there, so i'd think it shouldn't be crashing when i'm not actively browsing, at least.

just today, it crashed while i was entering a url into the urlbar, e.g. no pages were being loaded at the time.

i'd be glad to carry out any diagnostics, just tell me which ones, and how to do them. :)

since the symptoms are the same, i added this comment to the bug, hope that's ok.

Adam J Richardson wrote:
> I'm also getting a lot of silent Firefox 3.0.3 SIGABRTs on Intrepid
> (32-bit desktop). The link of death doesn't work for me, though. I use
> the NoScript plugin so nothing Flash will load, but I can "temporarily
> allow all this page" (thus reloading the page) and no crash. Perhaps
> reloading doesn't trigger the crash condition?
>
> My video driver is (according to "Hardware Drivers", anyway): ATI/AMD
> proprietary FGLRX graphics driver.
>
> My GDB backtrace looks a lot like Stephen's:
>
> #0 0xb7f8f430 in __kernel_vsyscall ()
> #1 0xb7ce8880 in raise () from /lib/tls/i686/cmov/libc.so.6
> #2 0xb7cea248 in abort () from /lib/tls/i686/cmov/libc.so.6
> #3 0xaf7d75dd in talloc_free () from /usr/lib/libtalloc.so.1
> #4 0xaf9db289 in ?? () from /lib/libnss_wins.so.2
> #5 0xaf7d7621 in talloc_free () from /usr/lib/libtalloc.so.1
> #6 0xafa06758 in alloc_sub_basic () from /lib/libnss_wins.so.2
> #7 0xafa06d3f in talloc_sub_basic () from /lib/libnss_wins.so.2
> #8 0xaf946281 in ?? () from /lib/libnss_wins.so.2
> #9 0xaf9473f2 in lp_lockdir () from /lib/libnss_wins.so.2
> #10 0xafa00a75 in lock_path () from /lib/libnss_wins.so.2
> #11 0xaf99f767 in receive_unexpected () from /lib/libnss_wins.so.2
> #12 0xaf9a2375 in receive_nmb_packet () from /lib/libnss_wins.so.2
> #13 0xaf9a4e4d in name_query () from /lib/libnss_wins.so.2
> #14 0xaf942555 in _nss_wins_gethostbyname_r () from /lib/libnss_wins.so.2
> #15 0xaf942853 in _nss_wins_gethostbyname2_r () from /lib/libnss_wins.so.2
> #16 0xb7d82666 in ?? () from /lib/tls/i686/cmov/libc.so.6
> #17 0xb7d84039 in getaddrinfo () from /lib/tls/i686/cmov/libc.so.6
> #18 0xb7bf66b9 in PR_GetAddrInfoByName () from /usr/lib/libnspr4.so.0d
> #19 0xb71d8454 in ?? () from /usr/lib/xulrunner-1.9.0.3/libxul.so
> #20 0xb7c041e1 in ?? () from /usr/lib/libnspr4.so.0d
> #21 0xb7f4a50f in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
> #22 0xb7d9e7ee in clone () from /lib/tls/i686/cmov/libc.so.6
>

hmm ... do you have some special nameserver? maybe wins? maybe using ipv6?

I think you might be on to something there. I am trying the likewise-open package to authenticate my Ubuntu with our AD domain. (It doesn't work very well, but I don't have time to remove it right now.)

The name server is a bog standard Windows SBS 2003 R2. I don't think it's providing WINS (although I could be wrong there, I'm not particularly up on WINS). We're definitely not using IPv6 though.

Some files that might be of interest:
arichardson@vostro-1:~$ cat /etc/resolv.conf
domain .
search .
nameserver 10.22.5.2
arichardson@vostro-1:~$ cat /etc/nsswitch.conf
passwd: files winbind lwidentity
shadow: files
group: files winbind lwidentity
hosts: files wins dns
networks: files
protocols: db files
services: db files
ethers: db files
rpc: db files
netgroup: nis

Hmm, that nsswitch.conf file doesn't look right... might explain why lwo gives me double password prompts. (In my defence, lwo itself sets up the file.)

mattcasters (matt-casters) wrote :

Same problem here on Kubuntu Intrepid, latest updates applied.
Tried all sorts of solutions, even going for bleeding edge Nvidia 180.16 drivers, nothing stops Firefox from crashing. (although I now enjoy all the fancy 3D goodies on KDE 4.1.2)

Uninstalled winbind, samba and anything related to both, /etc/resolv.conf couldn't be simpler:
----------------------snip--------------------------------------------------------
# Generated by NetworkManager
nameserver 192.168.1.1
----------------------snap--------------------------------------------------------

/etc/nsswitch.conf:

----------------------snip--------------------------------------------------------
# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd: compat
group: compat
shadow: compat

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis
----------------------snap--------------------------------------------------------

I don't think it's even related to Flash (running Flash 10) since it also happens on web pages devoid of Flash embedded joy. I bet it crashes on HTML 1.0 content just the same.
Symptoms that signal a problem in FF 3.0.5: corrupt right hand scroll bar.

Let me know if you guys need any other information.

Mark Aiken (maiken) wrote :

Since there is a specific samba bug, recognizable by a specific backtrace, that is known to cause a silent SIGABRT exit, can I suggest that a separate bug be established for mysterious exits that are definitely *not* the samba issue? It seems clear that whatever mattcasters and nanotube are experiencing is not the samba bug.

BTW, there are instructions at https://wiki.ubuntu.com/MozillaTeam/Bugs for getting a stacktrace for a Firefox crash, which is a necessary starting point for having the Firefox dev team figure out what these other failures are.

mattcasters (matt-casters) wrote :

Mark, I kinda guessed by now that you figured out it had nothing to do with samba since it sounds so silly to start with. Anyway, that same FF version worked absolutely perfect before the upgrade from 8.04 to 8.10. As such, I'm not so sure at all that getting into a back and forth "yes/no" ping-pong game between Mozilla and Ubuntu is going to do anyone any good. I'm just confirming the issue in a couple of bugs since after 3 weeks I still have no browser to work with in any reliable fashion.

Mark Mandel (mark-mandel) wrote :

On a side note - I'm wondering if the same samba issue is what is causing frequent crashes for me in Evolution.

DanielS (daniel-skogberg) wrote :

Can someone please tell me if this has been fixed? I still get these silent crashes in FF randomly and noone seems to have be working (or at least commenting) on it for some time now... Sorry, I am just a regular user who wants to be able to use my computer in a normal fashion. I'm really satisfied with Intrepid so far but this annoying bug is pushing my patients to abandon Linux all together...

mattcasters (matt-casters) wrote :

Daniel, I've been working without a crash for the last few hours (it means a lot, FF crashed every 5 minutes). The thing that I changed were these 2 things:
1) Upgrade my manually installed nvidia driver to 180.22 stable (from 180.20 beta). I don't think it's related but you never know.
2) Uninstalled the Adobe flash player version 10. (sudo apt-get remove adobe-flashplugin) Doing that I found out that there was a second version 9 still installed in ~/.mozilla. I noticed flash kept working in FF with version 9. I then manually removed the plugins in ~/.mozilla/plugins. Re-started FF. Then I re-installed the Adobe flash player version 10 and restarted FF again.

Fingers crossed but so far so good. Mark, sorry about the spam.

mattcasters (matt-casters) wrote :

Update : still crashing unfortunately. Switched to FF 3.1b2: still crashing (much less but still).

Mark Aiken (maiken) wrote :

Seriously, though -- could we open a new bug for Firefox crashes that are unrelated to the known and fixed Samba bug? This bug is now tracking the need to pick up the Samba fix; there's no point in posting information about unrelated Firefox crashes here. By all means, post the crosslink to the new bug when you settle on one, so people can find it.

Thierry Carrez (ttx) wrote :

Sounds like a duplicate of bug 286119, please confirm the fix from there

Changed in samba:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.