Flash Printing Doesn't Work in Firefox

Bug #275691 reported by Kevin
This bug affects 5 people
Affects Status Importance Assigned to Milestone
adobe-flashplugin (Ubuntu)
cups (Ubuntu)
flashplugin-nonfree (Ubuntu)

Bug Description

Binary package hint: firefox

Current upstream ticket: http://bugs.adobe.com/jira/browse/FP-1853



Using Ubuntu 7.10 and Firefox, I'm unable to print on the following page:


Note: I don't try to print using the typical browser print; rather, the Flash application has a red print button that you can use to print that pops open a slightly print dialogue that is slightly different than the typical browser print dialogue. On it you can only choose the printer and the page print range. After clicking the print button there, the print job never goes to the queue, and so it never prints. So, maybe this is a bug related to the Flash print dialogue?


ProblemType: Bug
Architecture: i386
Date: Sun Sep 28 22:12:54 2008
DistroRelease: Ubuntu 7.10
Package: firefox
PackageArchitecture: i386
SourcePackage: firefox
Uname: Linux kidsubuntu 2.6.22-15-generic #1 SMP Wed Aug 20 18:39:13 UTC 2008 i686 GNU/Linux

Revision history for this message
Kevin (weslowsk) wrote :
Revision history for this message
John Vivirito (gnomefreak) wrote :

Not printing in Firefox makes this a bug in whatever you are using. flash?
firrefox version 2.0 has reached EOLS a while ago

Changed in firefox-3.0 (Ubuntu):
status: New → Invalid
Revision history for this message
Kevin (weslowsk) wrote :

Confirmed bug exists in firefox 3 on Ubuntu 8.04 - so this must be a bug with the flash plugin? How/Where does that get reported?

Changed in firefox-3.0 (Ubuntu):
assignee: nobody → gnomefreak
Revision history for this message
John Vivirito (gnomefreak) wrote :

Updated task and status. I'm leaving incomplete until we find out exactly what causes this.

affects: firefox-3.0 (Ubuntu) → flashplugin-nonfree (Ubuntu)
Changed in firefox-3.0 (Ubuntu):
assignee: gnomefreak → nobody
Changed in flashplugin-nonfree (Ubuntu):
importance: Undecided → Low
status: Invalid → Incomplete
Revision history for this message
Re Persina (r99990) wrote :

I was having the exact same problem described in this bug while trying to print a different Flash applet display using the applet context menu. I enabled cups debug logging and kept noticing a message about cups having no default printer set (which is supposedly just informational). However, I tried setting the cups PDF printer as the default on a whim and it worked. I can now print from Flash applets where I never could before.

Specifically I edited /etc/cups/printer.conf and changed the PDF printer definition line from:
<Printer PDF>
<DefaultPrinter PDF>

and then restarted cups and it worked.

Revision history for this message
Re Persina (r99990) wrote :

I think I should have been more clear above... I couldn't print to any cups printers from the flash applet, neither actual printers nor the cups PDF printer. I was trying to print to PDF from the flash applet at the time I was looking at this issue, but after specifying a default printer in cups, printing to any printer from a flash applet now works, default or not. It doesn't seem to matter which is the default but there has to be a default printer in cups.

Revision history for this message
Alexander Sack (asac) wrote :

good catch. adding cups to get input on whether cups should always have a default printer set.

In any case, this is certainly a flash issue - which we cannot fix on our own. Can you open a bug on adobe.com and give us your ticket reference here?

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

It is not required that CUPS has a default printer set. One can always print if one selects a printer explicitly. A printing dialog should also work without a default printer set. It should simply select the first printer in the list in such a case. If there are no print queues at all, the dialog should show a decent message.

Changed in cups (Ubuntu):
status: New → Invalid
Revision history for this message
Re Persina (r99990) wrote :

Just for reference, I have updated the previously opened bug at adobe with this information here:

Revision history for this message
Alexander Sack (asac) wrote :
Changed in adobe-flashplugin (Ubuntu):
status: New → Triaged
Alexander Sack (asac)
Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → Triaged
description: updated
Revision history for this message
Juan Simón (simonbcn) wrote :

Same problem with Ubuntu 9.04 32 bits, Adobe Flash Player Plugin 10,0,32,18 and any browser: Firefox 3.5.2, Chromium,...

Revision history for this message
Juan Simón (simonbcn) wrote :

The solution #5, in my case, doesn't work.
My printers.conf (no printer.conf) file already indicates correctly the default printer:

# Printer configuration file for CUPS v1.3.9
# Written by cupsd on 2009-05-26 12:51
<DefaultPrinter HP-Color-LaserJet-2600n>
Info HP Color LaserJet 2600n
DeviceURI hp:/net/HP_Color_LaserJet_2600n?ip=
State Idle
StateTime 1243334969
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
Option number-up 1
Option sides one-sided
Option orientation-requested 3

Revision history for this message
Juan Simón (simonbcn) wrote :

I think I found the error.
I run Firefox from the console.
When I try to print a flash fails with error (it shows in console):
"Read_file_list: cannot stat required or included file '//etc/printcap' - No such file or directory"

Revision history for this message
Juan Simón (simonbcn) wrote :

My printer is connected via LAN.
I have executed:

"sudo ln -s /var/run/cups/printcap /etc/printcap"

but when I execute "lpstat" show an error:

"Printer 'HP-Color-LaserJet-2600n@localhost' - cannot open connection - No existe el fichero ó directorio
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023) ports"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers