Unable to install flashplugin-nonfree -- libxcb-render-util.so.0 not found

Bug #271392 reported by Gert Vanthienen on 2008-09-17
120
This bug affects 3 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned
ia32-libs (Ubuntu)
High
Stephan Ruegamer

Bug Description

Binary package hint: flashplugin-nonfree

dpkf --configure says:

Setting up flashplugin-nonfree (10.0.1.218+10.0.0.525ubuntu1) ...
Installing from local file /var/cache/flashplugin-nonfree/flashplayer10_install_linux_070208.tar.gz
Flash Plugin installed.
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libxcb-render-util.so.0: cannot open shared object file: No such file or directory
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-nonfree/libflashplayer.so
dpkg: error processing flashplugin-nonfree (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 flashplugin-nonfree

Related branches

Stepan Roucka (rouckas) wrote :

I have similar problem in Interpid. When trying to run firefox, It throws this error message:
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libxcb-render-util.so.0: cannot open shared object file: No such file or directory
This problem started after some todays updates. The same happens with epiphany and 32bit swiftweasel

Stepan Roucka (rouckas) wrote :

It seems that the 32bit version of libxcb-render-util.so.0 is missing in 64bit Interpid?

Stepan Roucka (rouckas) wrote :

It can be solved using

getlibs -p libxcb-render-util0 libxcb-render0

Conn O Griofa (psyke83) wrote :
Download full text (4.3 KiB)

Unmarked as duplicate and assigned to Stephen Hermann, as requested.

I'm reposting my message relevant to the new library requirements and flash 10:

Stephen,

Here's the output from the latest Flash 10 RC plugin, wrapped and unwrapped. I am also attaching file listing the packages that contain the refequired libraries, so you can check what's missing.

From the wrapped executable:

conn@dimension:~$ ldd /var/lib/flashplugin-nonfree/npwrapper.libflashplayer.so
 linux-gate.so.1 => (0xb7f72000)
 libX11.so.6 => /usr/lib/libX11.so.6 (0xb7e5b000)
 libXt.so.6 => /usr/lib/libXt.so.6 (0xb7e0a000)
 libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7df0000)
 libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb7d39000)
 libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7bdb000)
 libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb7bd8000)
 libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb7bbf000)
 libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7bbb000)
 libSM.so.6 => /usr/lib/libSM.so.6 (0xb7bb1000)
 libICE.so.6 => /usr/lib/libICE.so.6 (0xb7b99000)
 /lib/ld-linux.so.2 (0xb7f73000)
 libpcre.so.3 => /lib/libpcre.so.3 (0xb7b6f000)
 libXau.so.6 => /usr/lib/libXau.so.6 (0xb7b6c000)
 libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7b67000)

From the unwrapped executable:

conn@dimension:~$ ldd /usr/lib/flashplugin-nonfree/libflashplayer.so
 linux-gate.so.1 => (0xb7f35000)
 libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb73c5000)
 libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb73ac000)
 libX11.so.6 => /usr/lib/libX11.so.6 (0xb72bc000)
 libXext.so.6 => /usr/lib/libXext.so.6 (0xb72ad000)
 libXt.so.6 => /usr/lib/libXt.so.6 (0xb725c000)
 libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb71e6000)
 libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb71b9000)
 libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb6e1c000)
 libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb6d90000)
 libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb6d74000)
 libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb6d5a000)
 libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb6d4f000)
 libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb6d0d000)
 libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb6c9a000)
 libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb6c5b000)
 libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb6c56000)
 libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb6c52000)
 libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb6b9b000)
 libnss3.so => /usr/lib/libnss3.so (0xb6a7a000)
 libsmime3.so => /usr/lib/libsmime3.so (0xb6a55000)
 libssl3.so => /usr/lib/libssl3.so (0xb6a24000)
 libplds4.so => /usr/lib/libplds4.so (0xb6a20000)
 libplc4.so => /usr/lib/libplc4.so (0xb6a1b000)
 libnspr4.so => /usr/lib/libnspr4.so (0xb69e5000)
 libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb69bf000)
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb69b1000)
 libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb6852000)
 /lib/ld-linux.so.2 (0xb7f36000)
 libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb684f000)
 libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6836000)
 libXau.so.6 => /usr/lib/libXau.so.6 (0xb6833000)
 libSM.so.6 => /usr/lib/libSM.so.6 (0xb682a000)
 libICE.so.6 => /usr/lib/libICE.so.6...

Read more...

Changed in ia32-libs:
assignee: nobody → shermann
status: New → Confirmed
Stephan Ruegamer (sadig) on 2008-09-17
Changed in ia32-libs:
status: Confirmed → In Progress
Niels Egberts (nielsegberts) wrote :

I'm confirming this issue, getlibs gives me nothing, and I can't find it in the repo either.

niels@inoue:~$ getlibs -p libxcb-render-util0 libxcb-render0
bash: getlibs: opdracht niet gevonden

Conn O Griofa (psyke83) wrote :

Niels & all,

Using GetLibs is an unofficial workaround. It's available here: http://ubuntuforums.org/showthread.php?t=474790

This will be fixed officially in ia32-libs (which will probably appear tomorrow).

doorknob60 (doorknob60) wrote :

Hope it gets fixed soon, because ever since I updated earlier today (it dragged in a new ia32-libs), I'm unable to use Skype, Firefox 32 Bit, Flash, Prism (32 bit) and Unreal Tournament....glad it's already been reported and being worked on :)

On Thu, 2008-09-18 at 00:36 +0000, doorknob60 wrote:
> Hope it gets fixed soon, because ever since I updated earlier today (it
> dragged in a new ia32-libs), I'm unable to use Skype, Firefox 32 Bit,
> Flash, Prism (32 bit) and Unreal Tournament....glad it's already been
> reported and being worked on :)

Downgrading to the ia32-libs from hardy-upgrades works fine for me, and,
until this is fixed, could be considered a solution. Just d/l it to your
box and then dpkg -i on it.

Albin Tonnerre (lutin) on 2008-09-18
Changed in ia32-libs:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 2.2ubuntu13

---------------
ia32-libs (2.2ubuntu13) intrepid; urgency=low

  * fetch-and-build:
    + added lib: (LP: #271392)
      - libxcb-render-util0
      - libxcb-render0
    + removed lib:
      - libflashsupport (LP: #192888)

 -- Stephan Hermann <email address hidden> Wed, 17 Sep 2008 10:01:35 +0000

Changed in ia32-libs:
status: In Progress → Fix Released
Stephan Ruegamer (sadig) on 2008-09-18
Changed in flashplugin-nonfree:
status: New → Fix Released
juanillo_web (juanmbarreiro) wrote :

flash plugin fixed? what is fixed? the bug is still here

John Vivirito (gnomefreak) wrote :

Juanillo its a very possibile you are not seeing the same bug or you are not fully up to date. Can you please file a new bug against ia32-libs and add all version info including Ubuntu version version of ia32-libs and flash plugin where did you obtain flash version? can you also please add dpkg output on what you see when you try to install it, including the command you used.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers