Flash under Firefox sometimes loses keyboard events

Bug #243856 reported by David Nemeskey on 2008-06-29
86
This bug affects 15 people
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Undecided
Unassigned
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

When playing a flash game, such as http://www.freewebarcade.com/game/black-2/, every so often the game stops accepting keyboard events after a mouse click. If now I click again with the mouse, the keyboard will work again. The mouse keeps working during the keyboard lockup too.

It feels as if the flash game has lost focus, but it is clearly not the case: I cannot use Firefox shortcuts either.

The error appears every time I play a flash game. To reproduce it, try to move around the game linked above, keep shooting until the keyboard stops working. Be sure to leave a short time between the mouse clicks, so that you can register the keyboard failure.

I am under Kubuntu Hardy. Using the latest versions of everything. This bug does not appear under Konqueror. It appears every time under Firefox, even with all add-ons disabled.

David Nemeskey (nemeskeyd) wrote :

I forgot: I am not using compiz.

Thomas Kluyver (takluyver) wrote :

This could be a problem with your flash player. Can you find which one you use (try going to about:plugins in firefox)? The three main ones are the official Adobe one (package flashplugin-nonfree), Gnash and swfdec. Libflash is older.

David Nemeskey (nemeskeyd) wrote :

The only flash-related package I have installed is flashplugin-nonfree. Firefox reports

    File name: libflashplayer.so
    Shockwave Flash 9.0 r124

, which I guess must be the same (version 9 and all).

Also, as I have said before, the problem does not appear under Konqueror, which uses the same plugin.

Thomas Kluyver (takluyver) wrote :

I have tried the game you link to above, in firefox 3.0 with flashplugin-nonfree. I admit that I only tried it for a brief period, but it seemed to me that it only stopped responding to keyboard input (as you say, as if it had lost focus) when one clicks *outside* the flash bit, which I very much suspect to be by design--certainly I wouldn't want flash to carry on getting my keyboard input. Does this definitely happen for you with mouse clicks inside the flash box?

David Nemeskey (nemeskeyd) wrote :

Just to make sure, I have just tried it, and yes, it happens when the cursor is in the middle of the flash box. And if you click outside of the box, you will be able to invoke the Firefox shortcuts (obiously), which is not the case with the lock-up I reported.

By the way, I forgot to tell to use the non-automatic weapons to reproduce the problem (so the mouse is not pressed continuously), and you may have to shoot around a bit before it happens. Not much, though.

Thomas Kluyver (takluyver) wrote :

Still can't replicate it, I'm afraid--I fired a good few shots just now. Have you tried setting up a new user and testing it there?

Only other difference that might be relevant is that I'm in Kubuntu-KDE4--you say Kubuntu, does that mean KDE3?

Daniel T Chen (crimsun) wrote :

Fixed in the latest beta (2) of Flash 10.

Changed in firefox-3.0:
status: New → Invalid
Changed in flashplugin-nonfree:
status: New → Fix Released
BrianGilman (brian-gilman) wrote :

This bug still occurs using Flash 10,0,0,525, althought it is not as bad as it was before. This can be verified by playing Bubble Tanks at http://www.kongregate.com/games/HeroInteractive/bubble-tanks. The keyboard will intermittenly stop working until you mouse click within the flash window.

Changed in flashplugin-nonfree:
status: Fix Released → Incomplete
Ken Neely (kenwneely) wrote :

I get the same error. I notice that Flash tends to "loose focus" ( and stop accepting keyboard events) when one double clicks inside the running flash application/game. A third click will return focus and allow the keyboard to send events to the flash app again.

Specs: Ubuntu 8.10
Compiz up full
Firefox 3 (Latest) with extensions like NoScript and FlashGot
Flash player 10 (Adobe)
Quad Core 2.7Ghz with Nvidia 9800 GX2

Evan Nelson (ean5533) wrote :

Confirmed. This problem is not restricted to any one flash game. Play any game that requires both a significant amount of clicking and keyboard usage, and you'll stumble on this problem quite quickly. Just try clicking (not click and hold) in the game, then try to use the keyboard to move or do something. Do this repeatedly, and you'll usually run into the problem within ten clicks. I've noticed that the faster you click, the more frequent this problem is.

8.10 Intrepid, Firefox 3, flash 10 plugin (downloaded from adobe.com).

d4v1dv00 (davidvoo) wrote :

I can confirm this problem, it happens to me constantly.

Same problem everywhere, but the arrows will work ;-)

CU
Stéphane

Culip (nate-culip) wrote :

I had the same problem: I was unable to type in Flash on any browser (Firefox, Epiphany, Opera, Midori,) even though my Flash player was the Adobe's latest one (10.0.15.3.) So I solved this problem as follow:

1 In Firefox, [Tools] > [Add-ons] > Disable flash plugin(s), then quit all browser(s)

2 In Synaptic Package Manager, search with "flash" then remove (uninstall) flash entries.

3 Get the latest flash player from Adobe's website.

4 Launch it, then the dialog like "There is the later version in software manager and usually the later the better" and choose "ignore" and carry on installing the flash player which you downloaded from Adobe website.

That's it! I didn't need to reboot the system. Now flash contents works perfectly on my Ubuntu.

Nathan
(Ubuntu 8.10 Intel32 US-English, Adobe Flash Player 10.0.15.3)

Febell (felix-ga1) wrote :

This Fix doesn't work for me. I don't get dialog and the Flash plugin is installed irght away.

But what I wanted to say is:
I can reproduce the error by a single double click. If I then click again the Keyboard works again.

On my opinion this looks like a wanted feature from some component (must not be Flash). But thats just a thought, because it happens with double click.
But I couldn't finde "someone" who could stole the keyboard input.

Just thought this Information could be interesting.

      Febell

damalix92 (dam-dam) wrote :

Hi there,

I have exactly the same problem : flash loose the control if I double click in a flash animation. Clicking again gives back the control over the flash animation.

Another consequence is that the performances become very poor (even worse than usually with flash) when the flash animation gets/looses the control often.

Damien

RasF (rasmus-hite) wrote :

Hello
I encounter this problem as well. I didnt notice before but damalix92 is right: It happens when you double click. To reproduce:
1. Goto http://bubbletanks.fizzlebot.com/ and start the game
2. Double click somewhere
3. You cant move using keyboard

If you only single click the keys work. Im on a fresh ubuntu 9.04 with firefox and latest flash:
    File name: libflashplayer.so
    Shockwave Flash 10.0 r22

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10

-Ras

Luke Schlather (luke2760) wrote :

I'm on 9.10 64-bit alpha, and Hulu's player won't accept any clicks. I tried it also in Epiphany to rule out Firefox, and it still wouldn't work.

When I mouseover the buttons, they react, but clicking has no effect.

Luke Schlather (luke2760) wrote :

I also get a stream of these:
(npviewer.bin:22008): Gdk-WARNING **: XID collision, trouble ahead

And it's definitely not a general Flash issue - YouTube was fine, it's specific to Hulu among what I've tested.

Actually, I'm definitely experiencing a distinct bug, since hitting space to pause is about the only thing that consistently works on Hulu (though If I click enough it will eventually log something, usually pop out, rarely fullscreen.)

my terminal is normally filled with these messages when running firefox 3.5 on karmic beta

"(npviewer.bin:8060): Gdk-WARNING **: XID collision, trouble ahead

(npviewer.bin:8060): Gdk-WARNING **: XID collision, trouble ahead

(npviewer.bin:8060): Gdk-WARNING **: XID collision, trouble ahead

(npviewer.bin:8060): Gdk-WARNING **: XID collision, trouble ahead

(npviewer.bin:8060): Gdk-WARNING **: XID collision, trouble ahead"

all I have running is gmail, facebook and youtube.

SD (ssdtonoy) wrote :

This is not complete finished bug. Please solve this issue as soon as possible.

Brad Taylor (brad) wrote :

I'm seeing the same issue with Pandora (http://www.pandora.com) in Google Chrome (latest unstable build), so it seems not to be Firefox specific.

brad@phoenix:~$ dpkg -s google-chrome-unstable
Package: google-chrome-unstable
Status: install ok installed
Priority: optional
Section: net
Installed-Size: 48972
Maintainer: Chrome Linux Team <email address hidden>
Architecture: i386
Version: 4.0.237.0-r31086
Replaces: google-chrome
Provides: google-chrome
Depends: libasound2, libatk1.0-0 (>= 1.13.2), libc6 (>= 2.6-1), libcairo2 (>= 1.4.0), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.3.5), libgcc1 (>= 1:4.2.1), libgconf2-4, libglib2.0-0 (>= 2.14.0), libgtk2.0-0 (>= 2.12.0), libnspr4-0d (>= 4.7.1), libnss3-1d (>= 3.12.3), libpango1.0-0 (>= 1.18.3), libstdc++6 (>= 4.2.1), lsb-base (>= 3.2), xdg-utils (>= 1.0.1), zlib1g (>= 1:1.2.3.3.dfsg-1)
Pre-Depends: dpkg (>= 1.14.0)
Conflicts: google-chrome
Description: The web browser from Google
 Google Chrome is a browser that combines a minimal design with sophisticated technology to make the web faster, safer, and easier.

flashplugin-installer is at 10.0.32.18ubuntu1.

SoulDr0p (souldr0p) wrote :

When I am in focused in the flash and interacting, it disables all shortcuts, but when I click on something outside the flash, say a blank space, it restores control.

Jmadero (jmadero) wrote :

I am having this problem as well. Mots notable is Pandora where it almost never recognizes keystrokes (I have to type in my address bar and then use my mouse to copy paste, no keystrokes are recognized). This has also happened recently in a flash game on addictinggames.com

Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → Confirmed
SD (ssdtonoy) wrote :

Go to http://www.sticksports.com/cricket/gameallstarslog.php and try the game. I am sure you will have no hope on getting it working. But the bubble game is working fine for me.

Artscoop93 (artscoop93) wrote :

Still the same problem. I had it already with Ubuntu 8.10 and Flash 9.
The issue applies to Ubuntu 9.10/Firefox and Flash 10.0 r42.

Thav (thavilden) wrote :

Affected on numerous games. Ubuntu 9.10 32 bit i386 Flash 10.0 r42 as well. No compiz.

David Nemeskey (nemeskeyd) wrote :

I can't believe, I reported this bug ages ago, and after 3 Ubuntu versions, it _still_ persists. It's seriously annoying. A fine example is http://www.stickpage.com/siftheads3gameplay.shtml

What do we have to do to help it get solved?

I guess it would depend on whether it's a bug in flash or in ubuntu. If the
bug is in flash, then it depends on when Adobe gets off their ass and starts
fixing bugs, this isn't the only bug that's been in their codebase for
years...

On Sat, Mar 27, 2010 at 1:36 PM, David Nemeskey <email address hidden> wrote:

> I can't believe, I reported this bug ages ago, and after 3 Ubuntu
> versions, it _still_ persists. It's seriously annoying. A fine example
> is http://www.stickpage.com/siftheads3gameplay.shtml
>
> What do we have to do to help it get solved?
>
> --
> Flash under Firefox sometimes loses keyboard events
> https://bugs.launchpad.net/bugs/243856
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Ken Neely (kenwneely) wrote :

Fun fact: Firefox and Google Chrome (Unstable beta) use the same version of flash in Ubuntu (well, I only have one version of flash installed), but Chrome is not effected by this bug...

So the error is in the Ubuntu version of Firefox! Not Ubuntu or Flash itself.

Note: You can get Google Chrome for Ubuntu through Ubuntu Tweak if you are interested.

David Nemeskey (nemeskeyd) wrote :

BrianGilman, Ken: true and true. The problem is apparently know by Adobe (https://bugs.adobe.com/jira/browse/FP-295), yet it's still unresolved there. BTW: it appears on other systems as well, not just Ubuntu. Also, the issue really does not happen (or is not so perceivable) on Chromium. So I guess this is really a Firefox + Flash problem, which is incidentally what I wrote in the summary & description.

Hyung JIn Han (backtrack303) wrote :

Good & Bad NEws- Note- Fix could be only me but anyways
Good, the error for me seems to be because SCIM- I got around this by using command "env GTK_IM_MODULE=gtk-im-context-simple firefox" (Not including quotes)

Bad- Since scim is disables for me Korean becomes disabled, and there is not a permanent(?) fix.

Hyung JIn Han (backtrack303) wrote :

Add to my previous one disable Scim and use Ibus?

David Nemeskey (nemeskeyd) wrote :

Hyung JIn Han: I am using uim, and still I am experiencing this problem, so I guess it's not scim-related. I have not tried without uim, so it is possible that there is no problem without any IME, but I don't know.

Still, Chrome doesn't suffer from this problem, so I don't see why this bug is invalid for Firefox.

SD (ssdtonoy) wrote :

The problem has been fixed in my system after some tweaks with metacity and compiz. Looks like those were the main problems, mostly compiz.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers