wrong color mask

Bug #242362 reported by Joerg Delker on 2008-06-23
6
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

Description: Ubuntu 8.04
Release: 8.04

flashplugin-nonfree:
  Installed: 10.0.1.218ubuntu1
  Candidate: 10.0.1.218ubuntu1

Adobe's flash plugin obviously uses a hard-coded color mask
(red, green, blue masks: 0xff0000, 0xff00, 0xff) which does not necessarily fit the actual mask used by the X Server.

As a consequence flash content (e.g. videos) shows wrong colors, when run on alternate X-Servers (like Sun Ray Xnewt).
The plugin shall not use hard coded values, but query the XServer for the correct mask to be used.

See more on
http://<email address hidden>/msg05751.html

Daniel T Chen (crimsun) wrote :

Please test the newer beta 2.

Changed in flashplugin-nonfree:
status: New → Incomplete
Joerg Delker (ubuntu-delker) wrote :

I've installed
flashplugin-nonfree_10.0.1.218+10.0.0.525ubuntu1_i386.deb
which I assume is what you are referring to as "beta 2".

The plugin shows in "about:plugins" as
    File name: /usr/lib/flashplugin-nonfree/libflashplayer.so
    Shockwave Flash 10.0.0 d525

The problem remains the same though :-(

Daniel T Chen (crimsun) on 2008-07-04
Changed in flashplugin-nonfree:
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers