flash plugin md5sum outdated

Bug #214341 reported by xtknight on 2008-04-09
4
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned
Nominated for Gutsy by xtknight

Bug Description

Setting up flashplugin-nonfree (9.0.115.0ubuntu5) ...
Downloading...
--00:19:05-- http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
           => `./install_flash_player_9_linux.tar.gz'
Resolving fpdownload.macromedia.com... 72.247.130.70
Connecting to fpdownload.macromedia.com|72.247.130.70|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3,044,538 (2.9M) [application/x-gzip]

00:19:30 (123.21 KB/s) - `./install_flash_player_9_linux.tar.gz' saved [3044538/3044538]

Download done.
md5sum mismatch install_flash_player_9_linux.tar.gz
The Flash plugin is NOT installed.

-----
SRU Gutsy

1. Nobody who installs Gutsy fresh can use Flash, because it tries to download a version with an md5sum that doesn't patch what is currently in the package.
2. The MD5sums in the package have been updated to match the Flash player download, so that it can install properly

New package version: 9.0.124.0ubuntu1~gutsy1

3. Patch available below for gutsy-proposed.
4. TEST CASE: Simply install flashplugin-nonfree. Install will fail because of mismatched md5sums.
5. The new Flash might cause a regression for certain browsers but it's unlikely.

I get the same error on Hardy AMD64.

Its works for me...
I had a .deb that I made for flash plugin, without md5sum check...

http://guigouz.googlepages.com/flashplugin-nonfree_9.0.666_i386.deb

Its install without problems... nice...
After this... link the /usr/lib/flashplugin-nonfree/libflashplayer.so to /usr/lib/xulrunner-addons/plugins
Done! Its working for me on Hardy Heron 32bit version!

xtknight (xt-knight) wrote :

This debdiff should fix the issue.

Also you can try this at my PPA: https://launchpad.net/~xt-knight/+archive

flashplugin-nonfree_9.0.124.0ubuntu1~ppa2

Tested and works here, both i386 and amd64. Hope it works for upgrades as well.

A workaround on AMD64 that worked for me is to install the plugin manually.
First, apt-get nspluginwrapper.
Then, download Flash from Adobe http://www.adobe.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash
extract, and install the plugin with
sudo nspluginwrapper -i libflashplayer.so

joshrobinson (josh-ruins-edge) wrote :

thanks xtknight, the flashplugin-nonfree amd64 package in your repo's fixed the problem for me

xtknight (xt-knight) wrote :

Here is a debdiff for gutsy-proposed.

xtknight (xt-knight) wrote :

gutsy-proposed debdiff w/ fixed version (this causes it to be earlier than Hardy)

xtknight (xt-knight) on 2008-04-09
description: updated
xtknight (xt-knight) on 2008-04-09
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers