firefox, epiphany-gecko crash on flash content in hardy

Bug #196588 reported by Stéphane Marguet on 2008-02-28
8
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Jeff Fortin Tam

Bug Description

Binary package hint: epiphany-browser

Epiphany Browser crashed when trying to watch a Flash movie (imbedded youtube). Not always reproductible.

This affects Firefox in the same way than epiphany-gecko with flashplugin-nonfree. To reproduce. Just watch random youtube videos until it crashes. You don't have to watch entire youtube videos. Just watching the first few seconds will determine if it's going to crash or not. So, go to youtube, and play 10 seconds of video, go to the next video, play 10 secs, etc.

It may crash on the very first one. It may crash on the 5th. On the 10th. But it will crash, sometime. I have not tried, but maybe opening multiple youtube pages in tabs at once could make it crash faster. Heck, even osnews.com makes the browser crash, and it happens so often that I disabled apport because it took me too much time to recover.

Epiphany+flash used to be very stable (as in: crash maybe once every 2-3 months?) in gutsy and previous releases, and now it crashes *every* day, on 25-50% of trials (trial = loading a web page containing flash content, be it youtube or something else). This is unacceptable, I had to remove flashplugin-nonfree to keep a crash-free experience for the moment being, but half of the web is crippled now (though I don't miss those ads ;).

Nothing to do with memory/swap usage.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Thu Feb 28 15:11:14 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/epiphany-gecko
NonfreeKernelModules: nvidia
Package: epiphany-gecko 2.21.90-0ubuntu4
PackageArchitecture: i386
ProcCmdline: epiphany-browser --sm-config-prefix /epiphany-browser-YSg1yW/ --sm-client-id 117f000001000119465025900000099820080 --screen 0 --load-session /home/username/.gnome2/epiphany/session_gnome-6kdNgc.xml
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: epiphany-browser
StacktraceTop:
 memcpy () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
 ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
 ?? () from /usr/lib/libflashsupport.so
 ?? ()
Title: epiphany-gecko crashed with SIGSEGV in memcpy()
Uname: Linux 2.6.24-10-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy lpadmin netdev plugdev powerdev scanner src users video

Stéphane Marguet (stemp) wrote :

StacktraceTop:memcpy () from /lib/tls/i686/cmov/libc.so.6
?? ()
?? ()
?? ()
?? ()

Thank you for your bug. That is a closed source flash player issue

Changed in epiphany-browser:
importance: Undecided → Medium
status: New → Invalid
Changed in epiphany-browser:
status: Invalid → New
Jeff Fortin Tam (kiddo) wrote :

me too. Epiphany never crashed at all before hardy (as in, it might have crashed once or twice in 4-6 months).

I now see epiphany crashing multiple times a day, because when I have flash content in the page, it has a 50% chance or so to crash. This is a dealbreaker for me. Any way I can help provide more information for this?

Changed in flashplugin-nonfree:
status: New → Confirmed
Jeff Fortin Tam (kiddo) on 2008-03-25
description: updated
description: updated
LGB [Gábor Lénárt] (lgb) wrote :

Ack. It seems there is some connection with libflashsupport to be able to use pulseaudio with flash plugin: I have this bug even in gutsy when I've installed PA just to play with it, and of course in hardy where PA is installed by default. Yes, flash plugin is a kind of binary blob, but it worked quite well before. Please check out bug #192888 and bug #198020 as well, thanks.

Krister Koski (kikke) wrote :

Yes this is definitely Pulseaudio server problem, i tested it and FLash crashing stopped example with Youtube videos.
LGB [Gábor Lénárt] information is correct and i found nasty solution.

I removed all Pulseaudio packages by using Synaptic, use search and find pulse, only packages what i left there are these:
libao2
libgsm1
libpulse0
vlc
vlc-nox

so remove all other and do reboot.

But now there is still bug in PulseAudio server what need to be fixed.

Krister Koski (kikke) wrote :

And problem is in (forgot this sorry):

Description: Ubuntu hardy (development branch)
Release: 8.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers