Ubuntu

Flash framerate is slower than the older version of Flash

Reported by Allan MacKinnon on 2008-01-27
14
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

Using Gutsy 32-bit.

With the last upgrade to Flash, the framerate has slowed drastically and makes video playback/image rendering choppy.

Everything worked flawlessly with the last version of Flash. I changed to using the version available on the Adobe website when the md5 mess-up occurred a while back, but after checking both versions and getting the same result I can be certain its the plugin itself that is causing the problems.

Can anyone else fathom a guess at what is causing the slowed, choppy playback?

I downgraded to the 9r48 version of Flash and everything works well.

The buggy version that is giving me problems is the newer 9r115.

I'm attaching the 9r48 version so anyone who has thee same problem and finds this thread can see if it will work for them. Just download it and put it in the folder ~/.mozilla/plugins (create the folder if it doesn't exist)

Dara Adib (daradib) wrote :

Sorry to be a nuisance, but Adobe forbids distribution of the flash plugin (that is why the Ubuntu package merely fetches the installer from Adobe and sets up nspluginwrapper). The file attachment should be removed.

"No. The Adobe free Player distribution agreement does not allow you to distribute the Players from your website. You must direct visitors to the Adobe Web Players area of our Downloads site. To easily link to our website, we provide Adobe Web Player buttons that you can display on your site. You can download the buttons and view the guidelines here: http://www.adobe.com/macromedia/style_guide/buttons/"
http://www.adobe.com/licensing/distribution/faq/#item-1-4
http://www.adobe.com/products/eulas/players/flash/

The only legal option is to have people download older versions of flash from http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp9_archive.zip which is an archived file of major Flash 9 releases (75 MB). Extract the file, navigate to /fp9_archive/9r48/ and then extract install_flash_player_9r48_linux.tar.gz. In the newly created directory you will find libflashplayer.so which you can use as said in the previous comment.

Meh, thought that would happen.

Thanks for the link though, Cyrus! I hope others will find a downgrade as a good workaround.

Fred (eldmannen+launchpad) wrote :

When in window mode it runs okay.
But when I watch flash in fullscreen, it goes slow.

I cant enjoy porno!

I am Intel Core 2 Duo 2,13 GHz and 4gb RAM.

Åskar (olskar) wrote :

Flash is slow for me only when compiz is activated..perhaps try to turn compiz off if that is activated?

Dara Adib (daradib) wrote :

Marking as needs more info.

The r48 package is used in Ubuntu 7.10, so please do not issue bug reports with r115 in Ubuntu 7.10. However, if you still have choppy flash playback in Ubuntu Hardy (which uses r115) please confirm.

Thank you.

Changed in flashplugin-nonfree:
status: New → Incomplete
manny (estelar57) wrote :

yes, confirmed in hardy, choppy playback in youtube (in fullscreen mode) for version 9,0,115, Big CPU usage.

Does not happen with last version v9,0,48

had to downgrade.

Intel Core 2 Duo 2,0 GHz and 2gb ram

extremelly slow on athlon 2.0ghz 512mb ram. Again v9,0,48 works really well in this setup too.

seems hardware acceleration does not really work in 9,0,115 for linux. In windows speed is fine, even in FF under wine.

also, swfdec (last version, not one in repos) seems to work well. Would be a good candidate to substitute gnash or include it as extra option. Since we can't redistribute flash, swfdec might be a good alternative for the population with slower PCs and UMPCs.

Really worth looking into this problem, as some people only use linux to "surf" the web and the slowness will sure disappoint many thanks to adobe :(

Dara Adib (daradib) wrote :

If you start Firefox from the terminal (Applications -> Terminal, type "firefox" (without quotes), enter) do you have any messages appearing in the terminal when reproducing the bug.

Changed in flashplugin-nonfree:
status: Incomplete → Confirmed
Taavi S. (tuisu) wrote :

For me it's choppy even if I don't try to watch flash videos fullscreen. When I try to watch fullscreen, it's totally unusable.

Is it really that my system is too low spec for this? My system is 1.7ghz celeron, 512mb ram, integrated 32mb sis video card. On the other hand, on XP I'm having no problems whatsoever. So maybe the problem is with the video card or maybe with its drivers. Anyway, it's kind of frustrating cause using youtube, googlevideo etc is a big part of my everyday computer use.

I'm on Hardy beta with all the latest updates, flash 9.0 r124, 32bit. Downgrading to r48 didn't help either. Obviously I don't have any effects turned on, cause my video card just can't handle that :)

Any help appreciated.

Taavi S. (tuisu) wrote :

Hmm, when watching youtube videos through totem youtube plugin then there's no choppyness, even in fullscreen.

manny (estelar57) wrote :

@tuisu

which flash version you have now ?

Taavi S. (tuisu) wrote :

I'm back to 9.0 r124. I tried downgrading to r48 but it didn't make any difference.

Is this bug still present for you?

Changed in flashplugin-nonfree (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for flashplugin-nonfree (Ubuntu) because there has been no activity for 60 days.]

Changed in flashplugin-nonfree (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers