Gutsy 64: nspluginwrapper errors with flashplugin-nonfree 9.0.115

Bug #177856 reported by Riccardo Pellegrini on 2007-12-21
278
This bug affects 14 people
Affects Status Importance Assigned to Milestone
nspluginwrapper
Invalid
Undecided
Unassigned
flashplugin-nonfree (Debian)
Fix Released
Unknown
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Dara Adib
nspluginwrapper (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Dara Adib

Bug Description

Binary package hint: flashplugin-nonfree

Aflter last upgrade of flashplugin-nonfree, Flash apps crash leaving a greyed rectangle in the page. The issue appears frequently, but sometimes all works fine.
At this url I obtain a 100% fail: www.speedtest.net
Sometimes I can load the application entirely, but it hangs anyway by starting a speed test.

Launching firefox from shell shows this message when Flash app crash:
$ firefox
*** NSPlugin Wrapper *** ERROR: NPP_NewStream() invoke: Connessione abbattuta dal corrispondente (in English it means: connection reset by peer)
*** NSPlugin Wrapper *** ERROR: NPP_URLNotify() invoke: Connection closed

All worked flawless before the last update of flashplugin-nonfree (version 9.0.48).
I can't revert to previous version because it's no more available on Adobe site.

Firefox 2.0.0.11
nspluginwrapper 0.9.91.5

Riccardo Pellegrini (cionci) wrote :

Copying libflashplayer.so version 9.0.48 over /usr/lib/flashplugin-nonfree/libflashplayer.so 9.0.115 solves the issue.
I think this should be a problem of synchronization between nspluginwrapper and libflshplayer.so.

Now I can definitively confirm that support of Adobe Flash plugin it's broken in Gutsy 64.

description: updated
Riccardo Pellegrini (cionci) wrote :

The issue seems to be present only in SMP/SMT machines, as nspluginwrapper author told me.
Now I'm testing a Makefile patch. Preliminary results are encouraging.

Riccardo Pellegrini (cionci) wrote :

This is the patch made by nspluginwrapper author.
It works for me with Ubuntu repository source.

Bret Towe (magnade) wrote :

I'm seeing this grey box issue on my amd64 box also
it is single cpu system
I'm trying the patch out now to see if it helps had some issues getting it to apply tho

Bret Towe (magnade) wrote :

looking at ldd output of /usr/lib/nspluginwrapper/i386/linux/npviewer.bin I do see gthread so I'll assume its applied right
but is ineffective for me

Riccardo Pellegrini (cionci) wrote :

It's strange, it solved the issue on two gutsy AMD64 machines for me.
Do you see any flash animation or no animation at all ?

Insert about:plugins as URL in Firefox, do you see any info about flashplugin ?

I see:

Shockwave Flash

    Nome file: npwrapper.libflashplayer.so
    Shockwave Flash 9.0 r115

Tipo MIME Descrizione Estensione Attivo
application/x-shockwave-flash Shockwave Flash swf Sì
application/futuresplash FutureSplash Player spl Sì

Bret Towe (magnade) wrote :

well on youtube its doing what it did before for me and thats show the static first image
then as soon as it seems to have the video downloaded enough to play it goes grey
and I think video alone seems to break for me as I recall a few other flash things working
that never touched video

    File name: npwrapper.libflashplayer.so
    Shockwave Flash 9.0 r48

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes

Riccardo Pellegrini (cionci) wrote :

So you don't have libflashplayer 9.0.115. I think you have another problem.

Bret Towe (magnade) wrote :

seems the libflashplayer.so I had wasn't happy doing whats in the below url fixed my issue
(and got me 9.0.115)
http://ubuntu-tutorials.com/2007/12/26/manually-install-adobe-flash-temporary-flashplugin-nonfree-fix/

Dara Adib (daradib) wrote :

I tried the speedtest site and the flash plugin worked for the first test (and I got results), but crashed the second time. I have had flash crash (very occasionally). I'll try the patch, and move this bug to Confirmed soon if nothing comes up.

Colin Dean (colindean) wrote :

This happens to me regularly. It seems to happen most often when I open a few sites all at once, for example while reading Digg and opening articles in a new tab and moving to the next Digg tab before reading the newly-opened tab. It's almost like there can only be a few instances of Flash running at any given time.

Riccardo Pellegrini (cionci) wrote :

Have you tried www.speedtest.net ? Are you able to complete a speed test ?

Rashad Tatum (rmtatum) wrote :

cionci,

The patch file you posted works for me.

I have attached a patched package that I built using the repository source packages.

Riccardo Pellegrini (cionci) wrote :

Cyrus, Rashad and Colin: do you have an SMP/SMT machine ?

Rashad Tatum (rmtatum) wrote :

Yes, I have an SMP machine.

Colin Dean (colindean) wrote :

Riccardo: yes, I am able to run the speedtest. I do have an SMP machine--X2 6000+.

I must reiterate that it seems to only happen when I have multiple tabs open. If I close all but one, it usually works.

Rashad: I tried your package, but I'm not sure if I installed it correctly. It appears to be working better--I can have multiple tabs open all playing video whereas it was spotty previously. I'll report back in a day or two.

yannack (yannack) wrote :

Rashad and all: Thanks, I was having the exact same problem as described and your package helped and solved it!

Dara Adib (daradib) wrote :

Sorry for the delay. Yes, I also have an SMP machine. AMD Athlon64 X2. I will test the package soon.

Dara Adib (daradib) wrote :

I forgot to test the package, but I just tested it and it worked. Thanks.

Changed in nspluginwrapper:
status: New → Confirmed

Installed the fixed package and things seem to be working again.

Thanks!

Andrew Hutchings (linuxjedi) wrote :

Same problem for me on Hardy 64bit with Intel Core2Duo MacBook Pro.

Downgrading to Rashad's package appears to fixed it for me.

Dara Adib (daradib) wrote :

LinuxJedi: If possible, please try applying the patch made by nspluginwrapper's author (attached to comments above by Riccardo Pellegrini) to the Ubuntu Hardy package and test. If these is not feasible, please let me know and I will upload a package to test on Hardy (I currently use Ubuntu 7.10). Thanks,

Andrew Hutchings (linuxjedi) wrote :

Hardys nspluginwrapper = Gustys nspluginwrapper. They point to the same binary in the repository.

I've been using the patched package all day (Youtube and other flash heavy sites used) with no problems to report so far.

Dara Adib (daradib) on 2008-02-26
Changed in nspluginwrapper:
status: New → Confirmed
Dara Adib (daradib) wrote :

I am marking this bug as invalid in the nspluginwrapper (project) since it does not use Launchpad Bugs (see the Launchpad overview of the project). Instead, I have added the nspluginwrapper package in Ubuntu and marked it as confirmed.

The nspluginwrapper author does not appear to have any bug tracking system. The best bet seems to be Debian's bug tracking, which the nspluginwrapper author appears to follow. The closest Debian bug (only one to have the error message) is Debian (bug) 454782: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=454782

However, this bug is related to the reason Konqueror does not start. If the cause of these (this bug and the Konqueror bug) bugs are the same, it would be acceptable to add the Debian bug.

LinuxJedi: Yes, you are correct. I didn't bother checking when you wrote that you dowgraded. Anyways, it's over.

Changed in nspluginwrapper:
status: Confirmed → Unknown
status: New → Invalid
Andrew Hutchings (linuxjedi) wrote :

Indeed I did, sorry, I should have checked before installing the package.

Thanks Cyrus and everyone involved in the patch / package so far.

Changed in flashplugin-nonfree:
status: Unknown → Fix Released
Harold (harold-v) wrote :

Hello,

 I had exactly the same problem (64 bit SMP computer).
Rashad Tatum 's file seemed to do the trick :)

Thank you !

Actually, it would be *upgrading* to my package :-) . Glad it worked for
you.

On Tue, Feb 26, 2008 at 2:23 AM, LinuxJedi <email address hidden> wrote:

> Same problem for me on Hardy 64bit with Intel Core2Duo MacBook Pro.
>
> Downgrading to Rashad's package appears to fixed it for me.
>
> --
> Gutsy 64: nspluginwrapper errors with flashplugin-nonfree 9.0.115
> https://bugs.launchpad.net/bugs/177856
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Rashad Tatum
---------
"[W]e shall not fight our battles alone. There is a just God who presides
over the destinies of Nations, and who will raise up friends to fight our
battles for us. The battle, Sir, is not to the strong alone. It is to the
vigilant, the active, the brave." - Patrick Henry on the fight for
independence

"The moral and constitutional obligations of our representatives in
Washington are to protect our liberty, not coddle the world, precipitating
no-win wars, while bringing bankruptcy and economic turmoil to our people."
Freedom Under Siege, 1987 by Ron Paul

"I sincerely believe that banking establishments are more dangerous than
standing armies, and that the principle of spending money to be paid by
posterity, under the name of funding, is but swindling futurity on a large
scale. " - Thomas Jefferson

Dara Adib (daradib) wrote :

This bug apparently appears in Debian twice (meaning duplicates). Debian bug 458584 and Debian bug 454782. Can anyone clarify? If so, please notify Debian appropriately.

I'm having this same problem. I'm just posting here to subscribe to this list.

Do you guys think this problem will be fixed for Hardy? If that fixed package made its way to Hardy, I would be EXTREMELY happy!

venerdi (mendem) wrote :

I have also this problem expecially at the end of the animation/film.
I have an AMD Athlon64 X2.
If i restart the Firefox browser the plugin restart normally.
On same sites the problem wasn't verify.

Rashad Tatum (rmtatum) wrote :

Some sites with a lot of flash objects cause the plugin to fail.

Dara Adib (daradib) on 2008-04-05
Changed in flashplugin-nonfree:
status: New → Invalid
Matthew Tighe (tighem) wrote :

Confirming the problem still exists in Hardy Beta with Firefox beta 5.

Rashad Tatum (rmtatum) wrote :
  • unnamed Edit (1.7 KiB, text/html; charset=ISO-8859-1)

Flash crashes more in Firefox 3 beta 5 than beta 4.

On Sun, Apr 6, 2008 at 9:50 PM, Matthew Tighe <email address hidden>
wrote:

> Confirming the problem still exists in Hardy Beta with Firefox beta 5.
>
> --
> Gutsy 64: nspluginwrapper errors with flashplugin-nonfree 9.0.115
> https://bugs.launchpad.net/bugs/177856
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Rashad Tatum
----

"[W]e shall not fight our battles alone. There is a just God who presides
over the destinies of Nations, and who will raise up friends to fight our
battles for us. The battle, Sir, is not to the strong alone. It is to the
vigilant, the active, the brave." - Patrick Henry on the fight for
independence

"The moral and constitutional obligations of our representatives in
Washington are to protect our liberty, not coddle the world, precipitating
no-win wars, while bringing bankruptcy and economic turmoil to our people."
Freedom Under Siege, 1987 by Ron Paul

"I sincerely believe that banking establishments are more dangerous than
standing armies, and that the principle of spending money to be paid by
posterity, under the name of funding, is but swindling futurity on a large
scale. " - Thomas Jefferson

Matthew Tighe (tighem) wrote :

> Flash crashes more in Firefox 3 beta 5 than beta 4.

Definitely agreed. I've had much more crashes.

David Bogner (davidbogner) wrote :

I am on Hardy 64 problem still exists Firfefox 3b05

EzNet (zeroezezero) wrote :

Same problem for me.

-Linux eznet-mobile 2.6.24-15-generic #1 SMP Fri Apr 4 03:10:59 UTC 2008 x86_64 GNU/Linux
-File name: npwrapper.libflashplayer.so
 Shockwave Flash 9.0 r115
-Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008040514 Firefox/3.0b5

Normally I can load one flash file, but it I attempt to view another afterwards (or an flash advertisement loads) then the area will be replaced with a gray box instead of the flash. Right clicking on the gray area produces NO drop down menu.

-Matt

EzNet (zeroezezero) wrote :

update:
I have attempted to install the above patch - no success. I still get the grayed box after opening multiple flash files.
I have compiled nspluginwrapper from source, with patch - no success.
I have installed the above 'fixed' .deb - no success. Still gray.
I have performed variants of the aforementioned : ex. compiled ns and installed flash from repos - compiled and installed flash from adobe - etc. any variant of suggestions I can think of and still no go. I can play a flash file or two, but inevitable will get the gray box...

Any ideas? Crazy thing was, I was not havint this problem at all until Friday-ish. Before then I was able to view flash files on my 64bit hardy without issues.

-Matt

Paulo Tanimoto (tanimoto) wrote :

I don't know if this happens to other people, but I noticed that the gray box problem pretty much always occurs after I close a tab that had flash in it. This started with Firefox 3 beta 5.

-- snippet --
$ firefox &
GCJ PLUGIN: thread 0x622900: NP_GetMIMEDescription
GCJ PLUGIN: thread 0x622900: NP_GetMIMEDescription return
GCJ PLUGIN: thread 0x622900: NP_GetValue
GCJ PLUGIN: thread 0x622900: NP_GetValue: returning plugin name.
GCJ PLUGIN: thread 0x622900: NP_GetValue return
GCJ PLUGIN: thread 0x622900: NP_GetValue
GCJ PLUGIN: thread 0x622900: NP_GetValue: returning plugin description.
GCJ PLUGIN: thread 0x622900: NP_GetValue return
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)

(npviewer.bin:20107): Gtk-CRITICAL **: gtk_style_detach: assertion `style->attach_count > 0' failed
*** NSPlugin Wrapper *** ERROR: NPP_Destroy() invoke: Connection reset by peer
*** NSPlugin Wrapper *** ERROR: NPClass::Invalidate() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Connection closed
GCJ PLUGIN: thread 0x622900: NP_GetMIMEDescription
GCJ PLUGIN: thread 0x622900: NP_GetMIMEDescription return
GCJ PLUGIN: thread 0x622900: NP_GetValue
GCJ PLUGIN: thread 0x622900: NP_GetValue: returning plugin name.
GCJ PLUGIN: thread 0x622900: NP_GetValue return
GCJ PLUGIN: thread 0x622900: NP_GetValue
GCJ PLUGIN: thread 0x622900: NP_GetValue: returning plugin description.
GCJ PLUGIN: thread 0x622900: NP_GetValue return
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Connection closed
-- snippet --

Dara Adib (daradib) wrote :

I think this bug is related to bug 212877. Just like this bug, the people there report having 64-bit SMP (multicore/multiprocessor) systems and it was brought by Mozilla Firefox 3.0 Beta 5. The difference, however, is that bug 212877 relates to Mozilla Firefox crashing, not just Flash alone.

On April 6th, I decided to test if the Firefox 3 Beta 5 update was causing the problem. I had not upgraded to Firefox Beta 5 (didn't check for updates), but found the update to Beta 5. I updated all other (irrelevant) packages, except firefox, firefox-3.0, firefox-3.0-gnome-support, and firefox-gnome-support. I then opened Firefox from the console (to see any error messages) and proceeded to test extensively and try to make nspluginwrapper and/or flashplugin crash. This including opening many Youtube videos as tabs, and refreshing random Youtube tabs. Firefox did slow down dramatically, and it did "freeze" for a few moments, but Firefox/flashplugin/nspluginwrapper did not crash. The Youtube videos continued to play. No error messages relevant to nspluginwrapper/flashplugin were on the console.

I then upgraded the specified packages. Once again, I opened Firefox from the console (to see any error messages) and proceeded to test extensively and try to make nspluginwrapper and/or flashplugin crash. Nearly immediately, without opening more than one or two Youtube video tabs, the flashplugin crashed and nspluginwrapper outputed errors on the console.

I think, unless someone knows the solution, we should narrow done what difference in Firefox 3.0 from Beta 4 to Beta 5 caused the problem. I think I should look at Swiftweasel as well.

Alexander Sack (asac) wrote :

please move your libflashsupport.so out of /usr/lib/ (move it somewhere else where the runtime linker cannot find it, e.g. to $HOME) and see if your frequent issues go away.

Ludwig (lvb2k2) wrote :

Same problem, hardy ff 3b5 updated as of today.
With b4 I had more seldom crashes, and apport triggers. With 3b5 the crashes are much more often but they seem to be silent (no apport) for some reason.

Jeremy Wilkins (wjeremy) wrote :

I can also confirm this is a major problem in Hardy. I only upgraded to Hardy recently and I run amd64 Hardy now, but Firefox 3 beta 5 does not run flash more than once or twice and I DO NOT have a dual/quad core CPU. I cleaned out my local mozilla plugins folders as was mentioned somewhere, but no go. I have just a basic Turion64 chip on a laptop. So I think this may be a new issue now. It isn't restricted to multi-core systems.

willie_wang (wil-hoang) wrote :

I can also confirm this problem. Like DaFlame, I run a Turion64 single core processor.

Zorael (zorael) wrote :

Confirming on my Intel Core2Duo (so two cores, lewl).

The issue occurs with or without libflashsupport, so I find it hard to believe it's related to pulse. Furthermore, it works in firefox-2 with the same wrapped file, so I'm betting there's something new in FF3 which the plugin doesn't handle well. Please see http://ubuntuforums.org/showthread.php?t=786392 and http://ubuntuforums.org/showthread.php?t=791127.

I've tried both the nspluginwrapper from the repositories and the one from the .deb package Rashad Tatum attached earlier, with no discernible differences. I haven't had any luck with compiling from source.

http://gwenole.beauchesne.info/en/blog/2007/12/25/nspluginwrapper_and_new_flash_player

Jeremy Wilkins (wjeremy) wrote :

I think the problem for me stemmed from some old nspluginwrapper files (I built it manually awhile back) that were still in /usr/bin or /usr/local/bin. Please check there to see if you have any older nsplugin files and reinstall nspluginwrapper and flashplayer-nonfree. That solved my problem so it may not be related to this bug.

panton41 (panton41) wrote :

This may be a thorny thing to add, but I dual-boot Kubuntu Heron with Windows Vista and if I remember right I had the issue under 32-bit Windows with 32-bit Firefox as well, so this might be pointing to Firefox or Flash more than the wrapper.

schmoo2x (louis-ok-computers) wrote :

Problem still exists in Intrepid Beta 64-bit. shows an error "npviewer.bin" crashed.

yes i can confirm that flash is borked on 64bit 8.10

heethen (heethen) wrote :

So I've been getting grey boxes, npviewer.bin freezings and stuff. I have 32bit architecture, but I have a processor that supports intel's HyperThreading and that's what causing troubles for me, apparently. When I turn it off in BIOS, everything is OK - but this is not a solution ! I want both HyperThreading & Flash. :-) I'm getting little pissed off about whole situation. :-( Any help would be appreciated.

Karsten W. Rohrbach (byteborg) wrote :
Download full text (6.6 KiB)

I can second this annoying bug on hardy/amd86 (up-to-date as of 2008-10-23) as well.
My box is, SMP, too (Athlon 64 X2)

My config:
`--> uname -a
Linux pollux 2.6.24-21-generic #1 SMP Mon Aug 25 16:57:51 UTC 2008 x86_64 GNU/Linux
`--> dpkg -l|grep nspl
ii nspluginwrapper 0.9.91.5-2ubuntu2 A wrapper to run Netscape plugins on other architectures
`--> dpkg -l|grep flashpl
ii flashplugin-nonfree 10.0.1.218+10.0.0.525ubuntu1~hardy1+really9.0.124.0ubuntu2 Adobe Flash Player plugin installer
`--> dpkg -l|grep firefox
ii firefox 3.0.3+build1+nobinonly-0ubuntu0.8.04.1 meta package for the popular mozilla web browser
ii firefox-2 2.0.0.17+1nobinonly-0ubuntu0.8.04.1 lightweight web browser based on Mozilla
ii firefox-3.0 3.0.3+build1+nobinonly-0ubuntu0.8.04.1 safe and easy web browser from Mozilla
ii firefox-3.0-gnome-support 3.0.3+build1+nobinonly-0ubuntu0.8.04.1 Support for Gnome in Mozilla Firefox
ii firefox-gnome-support 3.0.3+build1+nobinonly-0ubuntu0.8.04.1 meta package pointing to the latest gnome-support package for fi
ii firefox-launchpad-plugin 0.2 Launchpad firefox integration
ii firefox-themes-ubuntu 0.5.4.4 Firefox themes matching the Ubuntu desktop look

Starting Firefox (with and without -safe-mode) results in the following error pattern:
`--> firefox -safe-mode 'http://www.youtube.com/watch?v=YAlGk6NKZHI'
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
GCJ PLUGIN: thread 0x623940: NP_GetMIMEDescription
GCJ PLUGIN: thread 0x623940: NP_GetMIMEDescription return
GCJ PLUGIN: thread 0x623940: NP_GetValue
GCJ PLUGIN: thread 0x623940: NP_GetValue: returning plugin name.
GCJ PLUGIN: thread 0x623940: NP_GetValue return
GCJ PLUGIN: thread 0x623940: NP_GetValue
GCJ PLUGIN: thread 0x623940: NP_GetValue: returning plugin description.
GCJ PLUGIN: thread 0x623940: NP_GetValue return
*** PULSEAUDIO: Unable to create stream.
npviewer.bin: pcm_pulse.c:115: pulse_stop: Assertion `pcm->stream' failed.
*** NSPlugin Wrapper *** ERROR: NPP_WriteReady() invoke: Connection reset by peer
*** NSPlugin Wrapper *** ERROR: NPP_WriteReady() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_WriteReady() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_WriteReady() invoke: Connection closed
*** NSPlugin Wrapper ...

Read more...

Karsten W. Rohrbach (byteborg) wrote :

Update:
After some investigation, switching from pulseaudio to native ALSA solved 80% of the problem.
Now, most of the time, Videos and Flash movies will play, but every 5th or so not. A page reload solves the symptom, but the bug is still there...

Christopher Skelton (sketec) wrote :

I was completely fed up with this issue as well, but I found out that nspluginwrapper is at a newer version 1.1.4 which I found here http://freshmeat.net/projects/nspluginwrapper/?branch_id=75051&release_id=288070. I installed it from source on my system and the problems went away, so far at least. Here I built a .deb for you all to use. I didn't know how to put in a description. I'm sure there is a way to add it, but I spent hours researching and finding all the dependencies I need to compile/make nspluginwrapper and I was just too tired to figure that out. Just uninstall the version currently installed and flashplugin-nonfree. Then install the nspluginwrapper I provided and then reinstall flashplugin-nonfree. Restart Firefox and it should be fixed now.

exactt (giesbert) wrote :

adobe finally released a 64-bit (alpha) version of flash player. get it here: http://labs.adobe.com/downloads/flashplayer10.html

Rashad Tatum (rmtatum) wrote :

Woot, woot!

On Mon, Nov 17, 2008 at 5:57 AM, exactt <email address hidden> wrote:

> adobe finally released a 64-bit (alpha) version of flash player. get it
> here: http://labs.adobe.com/downloads/flashplayer10.html
>
> --
> Gutsy 64: nspluginwrapper errors with flashplugin-nonfree 9.0.115
> https://bugs.launchpad.net/bugs/177856
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Compatibility plugin for Netscape 4 (NPAPI) plugins: Invalid
> Status in "flashplugin-nonfree" source package in Ubuntu: Invalid
> Status in "nspluginwrapper" source package in Ubuntu: Confirmed
> Status in "flashplugin-nonfree" source package in Debian: Fix Released
>
> Bug description:
> Binary package hint: flashplugin-nonfree
>
> Aflter last upgrade of flashplugin-nonfree, Flash apps crash leaving a
> greyed rectangle in the page. The issue appears frequently, but sometimes
> all works fine.
> At this url I obtain a 100% fail: www.speedtest.net
> Sometimes I can load the application entirely, but it hangs anyway by
> starting a speed test.
>
> Launching firefox from shell shows this message when Flash app crash:
> $ firefox
> *** NSPlugin Wrapper *** ERROR: NPP_NewStream() invoke: Connessione
> abbattuta dal corrispondente (in English it means: connection reset by peer)
> *** NSPlugin Wrapper *** ERROR: NPP_URLNotify() invoke: Connection closed
>
> All worked flawless before the last update of flashplugin-nonfree (version
> 9.0.48).
> I can't revert to previous version because it's no more available on Adobe
> site.
>
> Firefox 2.0.0.11
> nspluginwrapper 0.9.91.5
>

José M. López-Cepero (cepe) wrote :

The Flash 64-bit is rather unstable on my system. Has anybody had any success with Christopher's .deb file? It does not seem to contain the binary...

Christopher Skelton (sketec) wrote :

The 64bit flash Adobe released runs flawlessly for me. Might want to make sure its actually installed. nspluginwrapper and flashplayer-nonfree should be removed/uninstalled and the new Adobe's 64bit flash .so file should be moved/copied to /usr/lib/mozilla/plugins

p.s. See this bug https://bugs.launchpad.net/ubuntu/+source/nspluginwrapper/+bug/298604. I didn't create the .deb correctly that I previously posted, sorry about that, but opened another bug and someone built it correctly.

José M. López-Cepero (cepe) wrote :

Yes, I did uninstall everything, the only thing I did not do was copying it to the global plugins dir (I left it at ~/.mozilla/plugins). I checked that it was detected OK. Unfortunately, it would bring the browser down every so often. With the stock nspluginwrapper, at least the browser did not crash (just the Grey Box of Death). It might be a case of a bad interaction with FlashBlock, but I did not get around to try it.

I already built my own .deb file; it's a pity I redid the work :) It seems to work for now with the 32-bit Flash plugin. When I have some more time I'll keep experimenting.

Thanks for your reply!

Yang (yaaang) wrote :
Download full text (6.1 KiB)

Installed the nspluginwrapper package (running Ubuntu 8.10), but still no luck:

$ uname -a
Linux yang-xps410 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux

$ sudo dpkg -i nspluginwrapper_0.9.91.5-1ubuntu2_amd64.deb
dpkg - warning: downgrading nspluginwrapper from 1.1.2-0ubuntu1 to 0.9.91.5-1ubuntu2.
(Reading database ... 274569 files and directories currently installed.)
Preparing to replace nspluginwrapper 1.1.2-0ubuntu1 (using nspluginwrapper_0.9.91.5-1ubuntu2_amd64.deb) ...
Unpacking replacement nspluginwrapper ...
Setting up nspluginwrapper (0.9.91.5-1ubuntu2) ...
Processing triggers for man-db ...

Then removed the and installed the 64-bit Flash 10 alpha from Adobe, but that leads to a segfault in the plugin:

$ sudo aptitude remove nspluginwrapper
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  flashplugin-nonfree
The following packages will be REMOVED:
  nspluginwrapper
0 packages upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
Need to get 0B of archives. After unpacking 483kB will be freed.
The following packages have unmet dependencies:
  flashplugin-nonfree: Depends: nspluginwrapper (>= 0.9.91.4-2ubuntu1) but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
flashplugin-nonfree

Leave the following dependencies unresolved:
ubuntu-restricted-extras recommends flashplugin-nonfree
Score is -81

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  flashplugin-nonfree{a} nspluginwrapper
0 packages upgraded, 0 newly installed, 2 to remove and 2 not upgraded.
Need to get 0B of archives. After unpacking 651kB will be freed.
Do you want to continue? [Y/n/?]
Writing extended state information... Done
(Reading database ... 274568 files and directories currently installed.)
Removing flashplugin-nonfree ...
Removing nspluginwrapper ...
dpkg - warning: while removing nspluginwrapper, directory `/usr/lib/firefox/plugins' not empty so not removed.
Processing triggers for man-db ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

$ gdb --args /usr/lib/firefox-3.0.5/firefox
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu"...
(no debugging symbols found)
(gdb) r
Starting program: /usr/lib/firefox-3.0.5/firefox -P default -no-remote
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread 0x7f99d16ad6f0 (LWP 19655)]
[New ...

Read more...

Colin Dean (colindean) wrote :

Is this bug still relevant now that there is a 64-bit version of Adobe Flash / flashplugin-nonfree?

Christopher Skelton (sketec) wrote :

I would say yes, since their 64-bit version is still in Alpha.

Brian Murray (brian-murray) wrote :

I've unchecked the patch flag for the attachment as it seems to be a part of nspluginwrapper version 1.2.2-0ubuntu8 included in Natty. I've also unsubscribed the ubuntu-reviewers team as there is no patch to review.

I'm curious if anybody is experiencing this in a supported release of Ubuntu at this point in time. Thanks in advance!

Changed in nspluginwrapper (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.