flashplugin-nonfree doesn't install on Dapper Drake

Bug #177290 reported by Kristaps Esterlins on 2007-12-18
4
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

Dapper Drake 6.06.1 , Flashplugin-nonfree (7.0.63.3ubuntu3)

The plugin doesn't install at all :

$ sudo update-flashplugin
automatic installation failed due to network problems or upstream changes

After inspecting the script, the link for tarballed plugin in adobe and rest of the links don't have the plugin anymore

  # downloading the plugin
                        if [ $FAIL = "false" ]; then
                                WGETRC=wgetrc wget -q http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_7_linux.tar.gz || FAIL="true"
                                if [ $FAIL = "true" ]; then
                                        rm -f install_flash_player_7_linux.tar.gz
                                        FAIL="false"
                                        WGETRC=wgetrc wget -q http://fpdownload.macromedia.com.edgekey.net/get/flashplayer/current/install_flash_player_7_linux.tar.gz || FAIL="true"
                                fi
                                if [ $FAIL = "true" ]; then
                                        rm -f install_flash_player_7_linux.tar.gz
                                        FAIL="false"
                                        WGETRC=wgetrc wget -q http://e526.d.akamaiedge.net/get/flashplayer/current/install_flash_player_7_linux.tar.gz || FAIL="true"
                                fi
                                if [ $FAIL = "true" ]; then
                                        rm -f install_flash_player_7_linux.tar.gz
                                        FAIL="false"
                                        WGETRC=wgetrc wget -q http://fpdownload-marc.wip3.adobe.com/get/flashplayer/current/install_flash_player_7_linux.tar.gz || FAIL="true"
                                fi
                                if [ $FAIL = "true" ]; then
                                        rm -f install_flash_player_7_linux.tar.gz
                                        FAIL="false"
                                        WGETRC=wgetrc wget -q http://84.53.150.70/get/flashplayer/current/install_flash_player_7_linux.tar.gz || FAIL="true"
                                fi
                        fi

Dara Adib (daradib) wrote :

Originally, I was thinking this would be a problem with the change in md5 in the flash player stuff (Bug 173890). However, the script shows otherwise.

The new link would have to be: http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp7_archive.zip
Unfortunately, that is for all systems (including Windows and Mac), so it could mess up a part of the script

However, maybe you should try installing a newer flash player (Flash Player 9). Remove flashplugin-nonfree, and try using this package: http://archive.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-nonfree/flashplugin-nonfree_9.0.115.0ubuntu0.6.06_i386.deb

You could try enabling the backports repository, but that might give you Bug 173890. So try enabling the backports repository first; if it doesn't work, remove flashplugin-nonfree and then install the package.

I hope this is of help.

Kristaps Esterlins (esters) wrote :

Thanks for the advice, but i have decided - no backports, 3rd party repositories, because i want to run a clean ubuntu system without "alternative" packages. Why won't ubuntu dev(s) who are responsible for the package include the plugin in the package, because as you see now, it is removed from these sites and thus i can't enjoy flash content on the web.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers