md5sum error in postinstall for package flashplugin-nonfree

Bug #174090 reported by scguy318 on 2007-12-05
2
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

As of now, installing the flashplugin-nonfree package results in an MD5 error which occurs during the postinstallation:

md5sum mismatch install_flash_player_9_linux.tar.gz
The Flash plugin is NOT installed.

These lines in the postinstallation script of the flashplugin-nonfree package need to be updated:

 # verify MD5 checksum of (copied or downloaded) tarball
 rm -rf install_flash_player_9_linux/
 echo "821cc72359a937caef85bb4cc74ef5cd install_flash_player_9_linux.tar.gz"| md5sum -c > /dev/null 2>&1 \
  || fp_exit_with_error "md5sum mismatch install_flash_player_9_linux.tar.gz"

 # unpacking and checking the plugin
 tar xzf install_flash_player_9_linux.tar.gz || fp_exit_with_error "cannot unpack plugin"
 echo "be5a2f9032f8fc8bccbbf5d96c5028f9 install_flash_player_9_linux/libflashplayer.so"| md5sum -c > /dev/null 2>&1 \
  || fp_exit_with_error "plugin changed, not trusted"
 echo "a81fd3b03b8c6d6e5a14298110718d3f install_flash_player_9_linux/flashplayer.xpt"| md5sum -c > /dev/null 2>&1 \
  || fp_exit_with_error "plugin changed, not trusted"

I got the same error while trying to install the Flash plugin from the repositories on a friend's computer. I haven't tried it on mine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers