package flashplugin-installer 25.0.0.127ubuntu0.14.04.1 failed to install/upgrade: subprocess new pre-removal script returned error exit status 2

Bug #1682761 reported by DEnis on 2017-04-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

#apt-get upgrade
.....
Use 'apt autoremove' to remove them.
The following packages have been kept back:
  googleearth-package
The following packages will be upgraded:
  flashplugin-installer google-chrome-stable libfaac0 unrar
4 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
2 not fully installed or removed.
Need to get 47,5 MB of archives.
After this operation, 18,4 kB disk space will be freed.
Do you want to continue? [Y/n] y
Get:1 http://dl.google.com/linux/chrome/deb stable/main amd64 google-chrome-stable amd64 57.0.2987.133-1 [47,3 MB]
Get:2 http://de.archive.ubuntu.com/ubuntu xenial-security/multiverse amd64 flashplugin-installer amd64 25.0.0.148ubuntu0.16.04.1 [6.834 B]
Get:3 http://de.archive.ubuntu.com/ubuntu xenial/multiverse amd64 libfaac0 amd64 1.28+cvs20151130-1 [51,3 kB]
Get:4 http://de.archive.ubuntu.com/ubuntu xenial/multiverse amd64 unrar amd64 1:5.3.2-1 [123 kB]
Fetched 47,5 MB in 8s (5.697 kB/s)
Preconfiguring packages ...
(Reading database ... 377527 files and directories currently installed.)
Preparing to unpack .../google-chrome-stable_57.0.2987.133-1_amd64.deb ...
Unpacking google-chrome-stable (57.0.2987.133-1) over (57.0.2987.110-1) ...
Preparing to unpack .../flashplugin-installer_25.0.0.148ubuntu0.16.04.1_amd64.deb ...
update-alternatives: error: cannot append to '/usr/local/var/log/alternatives.log': No such file or directory
dpkg: warning: subprocess old pre-removal script returned error exit status 2
dpkg: trying script from the new package instead ...
update-alternatives: error: cannot append to '/usr/local/var/log/alternatives.log': No such file or directory
dpkg: error processing archive /var/cache/apt/archives/flashplugin-installer_25.0.0.148ubuntu0.16.04.1_amd64.deb (--unpack):
 subprocess new pre-removal script returned error exit status 2
Preparing to unpack .../libfaac0_1.28+cvs20151130-1_amd64.deb ...
Unpacking libfaac0:amd64 (1.28+cvs20151130-1) over (1.28-6) ...
Preparing to unpack .../unrar_1%3a5.3.2-1_amd64.deb ...
Unpacking unrar (1:5.3.2-1) over (1:5.0.10-1ubuntu0.14.04.1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Errors were encountered while processing:
 /var/cache/apt/archives/flashplugin-installer_25.0.0.148ubuntu0.16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: flashplugin-installer 25.0.0.127ubuntu0.14.04.1
ProcVersionSignature: Ubuntu 4.4.0-72.93-generic 4.4.49
Uname: Linux 4.4.0-72-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
Date: Fri Apr 14 10:54:57 2017
ErrorMessage: subprocess new pre-removal script returned error exit status 2
InstallationDate: Installed on 2014-11-19 (876 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.19
SourcePackage: flashplugin-nonfree
Title: package flashplugin-installer 25.0.0.127ubuntu0.14.04.1 failed to install/upgrade: subprocess new pre-removal script returned error exit status 2
UpgradeStatus: Upgraded to xenial on 2017-04-11 (3 days ago)

DEnis (p-d) wrote :
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers