adobe-flashplugin_20161213.1.orig.tar.gz is missing

Bug #1654511 reported by Maia on 2017-01-06
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running Ubuntu 16.04.1. When I try to install the flashplugin-installer package (version 24.0.0.186ubuntu0.16.04.1), the post-install script tries to download the file http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20161213.1.orig.tar.gz. However, it fails with a 404 Not Found error every time. I'm not familiar with how Ubuntu packages the Flash plugin, so I don't know what that file is supposed to be or why it's missing. Here's the full error message:

$ sudo apt install flashplugin-installer
[...]
Preparing to unpack .../flashplugin-installer_24.0.0.186ubuntu0.16.04.1_amd64.deb ...
Unpacking flashplugin-installer (24.0.0.186ubuntu0.16.04.1) ...
Processing triggers for update-notifier-common (3.168.3) ...
flashplugin-installer: processing...
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20161213.1.orig.tar.gz
Err:1 http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20161213.1.orig.tar.gz
  404 Not Found [IP: 91.189.92.150 80]
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20161213.1.orig.tar.gz' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
E: Failed to fetch http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20161213.1.orig.tar.gz 404 Not Found [IP: 91.189.92.150 80]

E: Download Failed
[...]

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
lhotari (lartsa) wrote :

I found out that adding "91.189.92.191 archive.canonical.com" to /etc/hosts works around the problem. For some reason the files are missing only on the server that's IP is 91.189.92.150 .

Maia (bumblingkitty) wrote :

Interesting. Sounds like an infrastructure problem, rather than someone just forgetting to make a file public.

Maia (bumblingkitty) wrote :

The file was added to .150 today or yesterday, so I guess this particular bug is resolved. Because .150 and .191 still serve different sets of files (even though , I feel like another bug should be filed somewhere (tell me if you know the right place).

Changed in flashplugin-nonfree (Ubuntu):
status: Confirmed → Fix Released
Maia (bumblingkitty) wrote :

I botched an edit, obviously. Here's what I meant to say:

Because .150 and .191 still serve different sets of files, I feel like another bug should be filed somewhere (tell me if you know the right place).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers