Sound Broke in Ubuntu Gutsy firefox

Bug #151849 reported by Joe Baker on 2007-10-12
62
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned
libflashsupport (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

Upgraded to latest Gutsy flashplugin-nonfree in the test version of Ubuntu 10/12/2007 and now youtube flash presentations do not have sound.

Present broken version:
flashplugin-nonfree_9.0.48.0.2+really0ubuntu12_i386.deb

I'm beginning to install PulseAudio to see if it will work with Puls.
I should mention that before Thursday Oct, 11th my YouTube flash vdeos played very well.

-Joe Baker

Joey Stanford (joey) wrote : me too

I have a similar issue. So far I've been unable to resolve it. It appears to only affect FF+flash. Gnash+FF works in that there is sound but of course it can't play anything but the basic flash items.

Sabaki (crbell) wrote :

I finally got the flashplugin-nonfree to work, with audio, in Firefox64 on Ubuntu64 Gutsy. I had to resort to installing and configuring PulseAudio and a somewhat kludgy PulseAUdio 'libflashsupport' package, and also involving copying a missing dependency from, a feisty32 system with libasyncns0 installed from /usr/lib/ libasyncns.so.0.0.0 to my Ubuntu64 box /usr/lib32/libasyncns.so.0.0.0 and making a symlink to it to /usr/lib32/libasyncns.so.0.

See thread:

Gutsy64 Flash9 on Firefox64 with sound, Finally! With PulseAudio!!!
http://ubuntuforums.org/showthread.php?t=617142

I don't know as I call it 'solved' but, for myself, it is at least somewhat 'triaged' and is working nicely now.
It works in Swiftweasel now , too.

Jacqueline (jwegscheid) wrote :

I have this problem too. Updated to Gutsy from Feisty, and now no sound on Youtube. "sudo apt-get flashplugin-nonfree" reports that I'm at the newest version, and the video portion works fine, but no sound.

Dara Adib (daradib) wrote :

I do not have this problem (Ubuntu 7.10 64-bit), although I can't try it at this moment since Youtube is down. Try using the method here to install the newest version of Flash- 9.0 Update 3: http://ubuntuforums.org/showthread.php?p=3923465

And although this seems obvious, try making sure that sound does work in other applications (make sure everyone here is reporting the same exact bug). It is possible that System -> Preferences -> Sound Preferences, which has been known to be faulty, may have changed your sound settings. Navigate to your home directory (in Nautilus- the Ubuntu file manager), enable the viewing of hidden folders (View -> Check "Show Hidden Files" or simply Ctrl-H), and delete the file .asoundrc if it exists (This will remove any custom sound settings that you have).

More information is needed for the bug report.

Dara Adib (daradib) wrote :

Try starting Firefox from the terminal (Applications -> Accessories -> Terminal) by entering the command firefox. Note any error messages or warnings. Thanks for your bug report.

Jacqueline (jwegscheid) wrote :

The sound is definitely working for other programs (sorry, should have stated that for sure).
I went through and installed the newest version of Flash as per the instructions in the thread you linked to above, Cyrus.
There is no .asoundrc file in my home directory (or in anyone else's).
There are no messages (error or otherwise) when I start Firefox from the command line.
I'm using Ubuntu release 7.10; 2.6.22-14-generic kernel.
(Also, may be helpful to note that it's not just a problem with Youtube. I also get no sound from Pandora Radio, which is also flash based.)

Anything else that I could try/give information on?

era (era) wrote :

I am on Gutsy amd64, upgraded from Feisty, which caused me some woes which involved ditching esound in favor of PulseAudio. I get the same symptoms as described above, and in addition, a host of error messages from Firefox:

ALSA lib ../../../src/pcm/pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
ALSA lib ../../../src/pcm/pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
ALSA lib ../../../src/pcm/pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
ALSA lib ../../../src/pcm/pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave

When I upgraded to Pulse, I had to reconfigure e.g. xmms so that it would work; it seems that opening up the preferences and making some change, then reverting it and closing the preferences was sufficient. (Humor me.)

For what it's worth, some discussions on similar topics seem to mention Nvidia video drivers in passing. I have those drivers, too.

Installing 32-bit libasyncns0 did nothing to solve this for me. Or do I need the libflashsupport as well before it will work?

era (era) wrote :

> Installing 32-bit libasyncns0 did nothing to solve this for me. Or do I need the
> libflashsupport as well before it will work?

Apparently yes. To summarize, here's what I did. I already had

sudo aptitude install libasyncns0 # dunno if this is required or useful
sudo aptitude install libasound2-plugins # already had these, but I guess they're required

# pick a mirror near you
wget http://www.nic.funet.fi/pub/mirrors/archive.ubuntu.com/pool/universe/liba/libasyncns/libasyncns0_0.3-1_i386.deb
dpkg -x libasyncns0_0.3-1_i386.deb libasyncns0_i386
sudo mv libasyncns0_i386/usr/lib/* /usr/lib32/
rm -rf libasyncns0_i386

wget http://jean-christophe.dubacq.fr/public/source/amd64/libflashsupport_1.0_2219-1_amd64.deb
# this isn't really useful other than as documentation for myself
sudo mv /usr/lib32/libssl.so.0.9.8 /usr/lib32/libssl.so.0.9.8_ia32-libs_overwritten_by_libflashsupport_1.0_2219-1_amd64
sudo dpkg --force-overwrite -i libflashsupport_1.0_2219-1_amd64.deb

Mind you, this is for a system with working PulseAudio. This closely follows "lean"'s instructions at http://ubuntuforums.org/showthread.php?t=617142&page=2 (thanks!)

Dara Adib (daradib) wrote :

According to Daniel T Chen from duplicate bug 144356:

"It's not a regression; ALSA still works; flashplugin-nonfree still works. It's libflashsupport that's broken."

Changed in libflashsupport:
status: New → Confirmed

I had same problem when upgrading to Gutsy. I solved it by removing ".asoundrc" and ".asoundrc.asoundconf" files from my home directory.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flashplugin-nonfree - 10.0.1.218ubuntu1

---------------
flashplugin-nonfree (10.0.1.218ubuntu1) intrepid; urgency=low

  * New upstream beta fixes many crashers (most significantly
    LP: #192888).
  * debian/config:
    debian/postinst: Update md5sums, filenames, and paths. Remove
    debugging bits (LP: #176226).
  * debian/control: Readd versioned dependency for libflashsupport|
    libasound2-plugins to play nicely with either PulseAudio config
    while preserving OSSv4 users' ability to have audible "shiny"
    (LP: #206307, #186726, #183943, #151849).

 -- Daniel T Chen <email address hidden> Tue, 20 May 2008 16:34:40 -0400

Changed in flashplugin-nonfree:
status: New → Fix Released
Ederic (ederic) wrote :

Is it possible to get the package flashplugin-nonfree - 10.0.1.218ubuntu1 now?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Ederic wrote:
| Is it possible to get the package flashplugin-nonfree -
| 10.0.1.218ubuntu1 now?
|
Yes Daniel just updated flash for most of the supported Ubuntu versions
if not all supported. If they arre not in repos yet they will be. When
you see a changelog entry on bugs from Launchpad-Bug Tracker it means it
was uploaded and waiting to be pushed into repos.

- --
Sincerely Yours,
~ John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFINPh3qig4QTwcPCoRAst5AJ9vnbq1aGZrpzRwU5Uc3/zhQ9IbNQCdGTk+
m8EiL9/yyQ4fFIHtxFSW0sI=
=KudQ
-----END PGP SIGNATURE-----

So is this bug fixed now?

Changed in libflashsupport (Ubuntu):
status: Confirmed → Incomplete
James Aspnes (aspnes) wrote :

I don't use Gutsy, Firefox, or Ubuntu any more, so I really couldn't say.

Best,

Jim Aspnes

On Mon, Sep 17, 2012 at 1:16 AM, Thomas Hotz <email address hidden> wrote:

> So is this bug fixed now?
>
> ** Changed in: libflashsupport (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/151849
>
> Title:
> Sound Broke in Ubuntu Gutsy firefox
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/151849/+subscriptions
>

Changed in libflashsupport (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers