package initramfs-tools 0.98.8ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #779410 reported by Phil Scull on 2011-05-08
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
flash-kernel (Ubuntu)
Medium
Adam Conrad
Oneiric
Medium
Adam Conrad

Bug Description

Binary package hint: initramfs-tools

Description: Ubuntu 11.04
Release: 11.04

During apt-get upgrade on pandaboard

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: initramfs-tools 0.98.8ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-1208.11-omap4 2.6.38.2
Uname: Linux 2.6.38-1208-omap4 armv7l
Architecture: armel
Date: Sun May 8 11:07:41 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
PackageArchitecture: all
SourcePackage: initramfs-tools
Title: package initramfs-tools 0.98.8ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Phil Scull (pmscull) wrote :
maximilian attems (maks-debian) wrote :

Generating u-boot configuration from /boot/boot.script... done.
umount: /tmp/tmp.RcxHGDubVu: device is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))

affects: initramfs-tools (Ubuntu) → u-boot (Ubuntu)
Loïc Minier (lool) on 2011-06-27
affects: u-boot (Ubuntu) → flash-kernel (Ubuntu)
tags: added: iso-testing
Ricardo Salveti (rsalveti) wrote :

Also able to reproduce this issue from time to time. Calling flash-kernel again generally makes it work.

Seems it may be missing a sync or a remaining process writing data to the partition.

Changed in flash-kernel (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Changed in flash-kernel (Ubuntu Oneiric):
assignee: nobody → Ubuntu ARM Team (ubuntu-arm)
Tobin Davis (gruemaster) wrote :

I can reliably reproduce this issue with my 16G Class 6 Micro Center SD on Oneiric daily.

From the oneiric 20110928 omap4 daily desktop syslog:
Sep 28 10:29:41 localhost ubiquity: Using u-boot partition: /dev/mmcblk0p1
Sep 28 17:29:41 localhost bluetoothd[831]: accept: Socket operation on non-socket (88)
Sep 28 17:29:41 bluetoothd[831]: last message repeated 10 times
Sep 28 10:29:41 localhost ubiquity: Creating backups of boot files ...
Sep 28 10:29:43 localhost ubiquity: done.
Sep 28 10:29:43 localhost ubiquity: Generating kernel u-boot image...
Sep 28 10:29:55 localhost ubiquity: done.
Sep 28 10:29:55 localhost ubiquity: Generating Initramfs u-boot image...
Sep 28 10:29:58 localhost ubiquity: done.
Sep 28 10:29:58 localhost ubiquity: Generating u-boot configuration from /boot/boot.script...
Sep 28 10:29:58 localhost ubiquity: done.
Sep 28 10:29:58 localhost ubiquity: umount: /tmp/tmp.LDEgSFGr8R: device is busy.
Sep 28 10:29:58 localhost ubiquity: (In some cases useful info about processes that use
Sep 28 10:29:58 localhost ubiquity: the device is found by lsof(8) or fuser(1))
Sep 28 10:29:58 localhost ubiquity:

Adam Conrad (adconrad) wrote :

flash-kernel (2.28ubuntu34) oneiric; urgency=low
.
  * Avoid races between umount and rm of the mountpoint with umount -l
.
 -- Adam Conrad <email address hidden> Wed, 28 Sep 2011 15:32:57 -0600

Changed in flash-kernel (Ubuntu Oneiric):
assignee: Ubuntu ARM Team (ubuntu-arm) → Adam Conrad (adconrad)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers