Add Raspberry Pi 4 rev 1.2 entry

Bug #1854487 reported by Dave Jones on 2019-11-29
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flash-kernel (Ubuntu)
High
Unassigned
Eoan
High
Unassigned

Bug Description

Impact
======

A new variant of the Raspberry Pi 4 (revision 1.2) has been released (presumably to deal with the USB-C power issue [1]). Without a corresponding entry in the flash-kernel database, users of this board will receive an error whenever flash-kernel is run (e.g. on kernel updates); see LP: #1848790 comment #44 for an example.

[1] https://www.scorpia.co.uk/2019/06/28/pi4-not-working-with-some-chargers-or-why-you-need-two-cc-resistors/

Test Case
=========

* On a Pi 4 Rev 1.2 board, boot an Eoan image (working around LP: #1848790 as necessary)
* Attempt to run "sudo flash-kernel"
* Observe the "Unsupported platform" message
* Enable proposed
* Run "sudo apt upgrade" to upgrade the flash-kernel installation
* Run "sudo flash-kernel" once more, observe no error

Regression Potential
====================

Extremely low; the change is a one liner adding a matching "Machine" line to the database. It doesn't remove or alter existing lines. The worst case scenario is that the Machine line doesn't match the model in the device-tree (in which case it'll still produce "Unsupported platform").

Other Info
==========

The following branch contains the relevant changes: https://code.launchpad.net/~waveform/ubuntu/+source/flash-kernel/+git/flash-kernel/+ref/ubuntu/eoan-devel

Dave Jones (waveform) wrote :

Proposed package available from ppa:waveform/flash-kernel at https://launchpad.net/~waveform/+archive/ubuntu/flash-kernel/+packages (with version bump to build in PPA)

Related branch is https://code.launchpad.net/~waveform/ubuntu/+source/flash-kernel/+git/flash-kernel/+ref/pi4-rev-1-2

Łukasz Zemczak (sil2100) wrote :

Sponsored for focal. Let's think about getting it into eoan as well.

Changed in flash-kernel (Ubuntu):
status: New → Fix Committed
Changed in flash-kernel (Ubuntu Eoan):
status: New → Triaged
importance: Undecided → High
Changed in flash-kernel (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.98ubuntu8

---------------
flash-kernel (3.98ubuntu8) focal; urgency=medium

  * Add support for the Raspberry Pi 4 rev 1.2 board (LP: #1854487)

 -- Dave Jones <email address hidden> Fri, 29 Nov 2019 11:35:00 +0000

Changed in flash-kernel (Ubuntu):
status: Fix Committed → Fix Released
Dave Jones (waveform) on 2019-11-29
description: updated
description: updated

Hello Dave, or anyone else affected,

Accepted flash-kernel into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/flash-kernel/3.98ubuntu5.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in flash-kernel (Ubuntu Eoan):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-eoan
Łukasz Zemczak (sil2100) wrote :

We were not able to fully verify this bugfix yet (due to not having the required device), but since the change is really small, Brian did a quick sanity smoke test of it on a regular Pi4 device. Nothing seemed to be broken so that should be enough.

We will be extensively testing flash-kernel as part of the new images we'll be building once this lands.

tags: added: verification-done verification-done-eoan
removed: verification-needed verification-needed-eoan
Brian Murray (brian-murray) wrote :

For the record my testing involved installing flash-kernel from -proposed, running sudo flash-kernel, rebooting, installing the new kernel from -proposed (which runs flash-kernel) and then rebooting again. I saw no error messages from flash-kernel and rebooted successfully each time.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.98ubuntu5.3

---------------
flash-kernel (3.98ubuntu5.3) eoan; urgency=medium

  * Add support for the Raspberry Pi 4 rev 1.2 board (LP: #1854487)

flash-kernel (3.98ubuntu5.2) eoan; urgency=medium

  * Reverted updated pi bootscript to work around boot regression in proposed
    eoan image (LP: #1854347).

 -- Dave Jones <email address hidden> Fri, 29 Nov 2019 16:33:13 +0000

Changed in flash-kernel (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for flash-kernel has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Brian Murray (brian-murray) wrote :

This has worked for a user with a v1.2 Raspberry Pi 4 as seen here:

https://bugs.launchpad.net/ubuntu/+source/linux-raspi2/+bug/1848790/comments/55

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers