Add entries for Pi 4

Bug #1847587 reported by Dave Jones on 2019-10-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
flash-kernel (Ubuntu)
Undecided
Unassigned

Bug Description

Impact
======

Apt upgrades performed on a Raspberry Pi 4 complain about missing database entries during the flash-kernel trigger. An updated version of flash-kernel with a Pi 4 entry in the database is available in the following PPA:

    https://launchpad.net/~waveform/+archive/ubuntu/ubpi4

Test Case
=========

* Boot the latest eoan daily on a pi3
* Migrate the boot config to operate on a pi4 (these steps won't be necessary once the gadget snap is updated):

    $ sudo -i
    $ . /usr/share/rpi-config-migration
    $ is_old_config && migrate_config

* Reboot the card on a pi4
* Run sudo /usr/sbin/flash-kernel
* Without the upgrade, it will report "Unsupported platform" with exit code 1
* Upgrade package to 3.98ubuntu4
* Re-run sudo /usr/sbin/flash-kernel
* With the upgrade, should report the usual "Using DTB: bcm2711-rpi-4-b.dtb", etc. with exit code 0

Regression Potential
====================

None; this change only adds the Pi 4 entry to the flash-kernel db. It doesn't alter / remove any existing entries or change any code. The worst case scenario is that it still doesn't work on the Pi 4.

Łukasz Zemczak (sil2100) wrote :

Looks fine, I have sponsored this for eoan. This doesn't explicitly require an FFe because it's basically a bugfix for the new pi4 support that we already had an FFe for.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.98ubuntu4

---------------
flash-kernel (3.98ubuntu4) eoan; urgency=medium

  * Add support for Raspberry Pi 4 (LP: #1847587)

 -- Dave Jones <email address hidden> Thu, 10 Oct 2019 10:41:43 +0100

Changed in flash-kernel (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers