Missing db entry for Raspberry Pi CM3 and CM3+

Bug #1816029 reported by Dave Jones on 2019-02-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
flash-kernel (Ubuntu)
Medium
Unassigned
Bionic
Critical
Unassigned
Cosmic
Low
Unassigned

Bug Description

[Impact]

flash-kernel is missing db entries for the Raspberry Pi Compute Module 3 and 3+ (which use a separate .dtb to the regular Pi 3B and 3B+).

[Test Case]

Perform both on a CM3 and CM3+: Install the ubuntu raspi3 bionic image, log into it and run sudo flash-kernel. The command should succeed without any 'Unsupported platform' errors.

For cosmic, as we do not support the pi, making sure that the package builds fine should be a sufficient test.

[Regression Potential]

None, this only adds new device ids to the database. The only issue might be if a different device gets identified as a CM3/CM3+ now, but that's unlikely.

Łukasz Zemczak (sil2100) wrote :

Sponsored for disco. Once that migrates I'll push this to bionic as well.

description: updated
Łukasz Zemczak (sil2100) wrote :

Sponsored uploads for both cosmic and bionic (waiting in unapproved).

Changed in flash-kernel (Ubuntu):
status: New → Fix Released
importance: Undecided → Medium
Changed in flash-kernel (Ubuntu Cosmic):
importance: Undecided → Low
Changed in flash-kernel (Ubuntu Bionic):
importance: Undecided → Critical
status: New → In Progress
Changed in flash-kernel (Ubuntu Cosmic):
status: New → In Progress

Hello Dave, or anyone else affected,

Accepted flash-kernel into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/flash-kernel/3.90ubuntu3.18.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in flash-kernel (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Changed in flash-kernel (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Dave, or anyone else affected,

Accepted flash-kernel into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/flash-kernel/3.90ubuntu3.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Łukasz Zemczak (sil2100) wrote :

Dave just tested the package next to me yesterday on a CM3 and it worked as intended. I mean, the fix revealed another problem - but a problem that will go away with the latest linux-raspi2 kernel release. flash-kernel now recognizes CM3 correctly but at the same time we're missing the CM3 .dtb on the filesystem (only having it in the boot partition as per the gadget hack). The new -raspi2 fixes that. Unrelated to the change here so we can release.

As for cosmic, well, the package builds so I guess that's all the testing we can do without using a very ancient image (or building a fresh one). Not worth the cycles as cosmic is not a supported series for the CM3.

tags: added: verification-done verification-done-bionic verification-done-cosmic
removed: verification-needed verification-needed-bionic verification-needed-cosmic
Łukasz Zemczak (sil2100) wrote :

SRU members: let's maybe wait for releasing this SRU until the linux-raspi2 update reached -updates (linux-raspi2 at least 4.15.0-1032.34 on bionic). This way we'll reduce the possibility of CM3 users triggering a flash-kernel run and encountering an error.

Brian Murray (brian-murray) wrote :

Setting to Incomplete so it doesn't appear on the report as ready to release.

Changed in flash-kernel (Ubuntu Bionic):
status: Fix Committed → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.90ubuntu3.18.10.2

---------------
flash-kernel (3.90ubuntu3.18.10.2) cosmic; urgency=medium

  * Add Raspberry Pi Compute Module 3 and 3+ to the db. (LP: #1816029)

 -- Dave Jones <email address hidden> Thu, 14 Feb 2019 11:12:13 +0000

Changed in flash-kernel (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for flash-kernel has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in flash-kernel (Ubuntu Bionic):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.90ubuntu3.18.04.2

---------------
flash-kernel (3.90ubuntu3.18.04.2) bionic; urgency=medium

  * Add Raspberry Pi Compute Module 3 and 3+ to the db. (LP: #1816029)

 -- Dave Jones <email address hidden> Thu, 14 Feb 2019 11:12:13 +0000

Changed in flash-kernel (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers