Missing RaspberryPi 3B+

Bug #1764491 reported by Adam Smith on 2018-04-16
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
flash-kernel (Ubuntu)
Undecided
Unassigned
Bionic
Critical
Unassigned
Cosmic
Low
Unassigned

Bug Description

[Impact]

The new Raspberry Pi 3B+ is missing from the flash-kernel database. Support has been added to the bionic raspi2 kernel, so it would be great if the other packages could support it too.
Without this fix, every trigger of update-initramfs (which triggers flash-kernel) will fail on 3B+ platforms.

[Test Case]

 * Boot up an Ubuntu raspi3 image on a Pi 3B+ and log into it
 * Run flash-kernel
 * Make sure no errors are reported (no "Unsupported platform.")
 * Reboot
 * Make sure the system still boots

[Regression Potential]

This is basically only adding support for a new board so should have no real regression potential. If the machine identification has some error making it identify normal Pi3's as B+ there's some risk of corrupting systems, but that should be quite visible whenever it happens.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1764491

tags: added: iso-testing
Adam Smith (adamsmith) on 2018-04-18
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in flash-kernel (Ubuntu):
status: New → Confirmed
Ryan Finnie (fo0bar) wrote :

Here's the appropriate entry for all.db:

# Raspberry Pi 3 B+
Machine: Raspberry Pi 3 Model B Plus Rev 1.3
DTB-Id: bcm2710-rpi-3-b-plus.dtb
U-Boot-Script-Name: bootscr.rpi3
Required-Packages: u-boot-tools
Boot-DTB-Path: /boot/firmware/bcm2710-rpi-3-b-plus.dtb
Boot-Kernel-Path: /boot/firmware/vmlinuz
Boot-Initrd-Path: /boot/firmware/initrd.img
Boot-Script-Path: /boot/firmware/boot.scr

"Machine: BCM2710" is not listed to not overlap with the 3 B entry; the B+ is also apparently considered a BCM2710, but /proc/device-tree/model shows "Raspberry Pi 3 Model B Plus Rev 1.3" on modern kernels/DTBs.

Changed in flash-kernel (Ubuntu):
milestone: none → ubuntu-18.04.1
satmandu (satadru-umich) wrote :

On multiple 4.17 kernels I'm seeing Machine show up as follows when I do this:

cat /proc/device-tree/model

Raspberry Pi 3 Model B+

Perhaps that should be in the Machine line in the flash-kernel database?

satmandu (satadru-umich) wrote :

Also, 4.18 looks like it has a bcm2837-rpi-3-b-plus.dtb file. Moving forward, is that the expected dtb file for use with the Raspberry Pi 3 B+?

Adam Smith (adamsmith) wrote :

@satmandu I'm guessing you are using an 'upstream' or a generic kernel. They seem to have different dtb file names to the raspi2 kernels.

Markus Birth (mbirth) wrote :

Can we omit this u-boot dependency, please? The Raspberry firmware can boot Linux kernels perfectly fine all on its own without the need of u-boot. There's absolutely no need to add this additional layer of potential problems, e.g. bug #1791466 .

Adam Smith (adamsmith) wrote :

Yep, the use of U-boot/flash-kernel makes no sense to me. I did create a bug to try and discuss options on how to remove U-boot - bug #1765628. U-boot makes sense without flash-kernel copying vmlinuz/initrd.img, or flash-kernel without U-boot, but using the two together as currently is silly.

Adam Smith (adamsmith) wrote :

Just an aside, Debian uses the raspi3-firmware package to copy the latest vmlinuz/initrd.img, but that has its problems too.

Changed in flash-kernel (Ubuntu):
status: Confirmed → Fix Released
Changed in flash-kernel (Ubuntu Bionic):
importance: Undecided → Critical
Changed in flash-kernel (Ubuntu Cosmic):
importance: Undecided → Low
description: updated
Changed in flash-kernel (Ubuntu Bionic):
status: New → In Progress
Changed in flash-kernel (Ubuntu Cosmic):
status: New → In Progress

Hello Adam, or anyone else affected,

Accepted flash-kernel into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/flash-kernel/3.90ubuntu3.18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in flash-kernel (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Brian Murray (brian-murray) wrote :

Hello Adam, or anyone else affected,

Accepted flash-kernel into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/flash-kernel/3.90ubuntu3.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in flash-kernel (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Dave verified that with the latest proposed built raspi3 bionic image [1] flash-kernel works and succeeds on a pi3 B+ (flash-kernel 3.90ubuntu3.18.04.1).

[1] http://cdimage.ubuntu.com/ubuntu-server/bionic/daily-preinstalled/20190123/bionic-preinstalled-server-arm64+raspi3.manifest

tags: added: verification-done-bionic
removed: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Since we will never have official cosmic pi3 images (as it is not a supported platform there), I consider the cosmic sanity-test from LP: #1811216 as a valid SRU bug validation.

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.90ubuntu3.18.10.1

---------------
flash-kernel (3.90ubuntu3.18.10.1) cosmic; urgency=medium

  * Add Raspberry Pi 3 Model B+ to the db. (LP: #1764491)
  * Modify the Pi 3 boot.scr addresses to fit a bigger kernel, prepare
    separate versions for armhf and arm64. (LP: #1811216)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 10 Jan 2019 09:56:08 +0100

Changed in flash-kernel (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for flash-kernel has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.90ubuntu3.18.04.1

---------------
flash-kernel (3.90ubuntu3.18.04.1) bionic; urgency=medium

  * Add Raspberry Pi 3 Model B+ to the db. (LP: #1764491)
  * Modify the Pi 3 boot.scr addresses to fit a bigger kernel, prepare
    separate versions for armhf and arm64. (LP: #1811216)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 10 Jan 2019 09:56:08 +0100

Changed in flash-kernel (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers