flameshot: The icon does not appear in the GNOME bar

Bug #1897754 reported by El jinete sin cabeza
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
flameshot (Ubuntu)
Low
Unassigned
gnome-shell-extension-appindicator (Ubuntu)
Low
Unassigned

Bug Description

https://github.com/flameshot-org/flameshot/issues/1009

---

When upgrading from gnome-shell-extension-appindicator_33-3_all.deb to gnome-shell-extension-appindicator_34-1_all.deb the icon does not appear in the GNOME toolbar.

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: flameshot 0.8.1-1
Uname: Linux 5.8.12-050812-generic x86_64
ApportVersion: 2.20.11-0ubuntu48
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Tue Sep 29 11:55:57 2020
InstallationDate: Installed on 2020-06-19 (102 days ago)
InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200609)
SourcePackage: flameshot
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
El jinete sin cabeza (ejsc) wrote :
description: updated
Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

Mh, so... I've just tried with the flameshot snap and the latest extension version, but it works correctly here.

Please, try to do as follow:
 - Start a session without flameshot started

In a terminal run:

  journalctl -b0 /usr/bin/gnome-shell -ef

Launch flameshot

Tell me what debug output do you get while running it.

If none, we may need to raise the debugging level, you can add it by editing /usr/lib/systemd/user/gnome-shell-x11.service (or wayland) so that it contains a line

 Environment=G_MESSAGES_DEBUG=all

In the [Service] stanza.

summary: - The icon does not appear in the GNOME bar
+ flameshot: The icon does not appear in the GNOME bar
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in flameshot (Ubuntu):
status: New → Confirmed
Changed in gnome-shell-extension-appindicator (Ubuntu):
status: New → Confirmed
Revision history for this message
Nicholas Guriev (mymedia) wrote :

I run into the issue when autostart feature of flameshot is activate. I daresay there is some sort of race condition while system startup, and the actual issue is in the gnome-shell-extension-appindicator package. There is something in diff between 33-1 and 34-1 versions that is breaking the app icon.

One possible workaround is to add a short delay before flameshort start into the ~/.config/autostart/Flameshot.desktop file and make Exec directive the following:

  Exec=sh -c 'sleep 1 && exec flameshot'

Revision history for this message
Nicholas Guriev (mymedia) wrote :

Marco Trevisan, as to your request, I am attaching logs that are appearing in system journal while flameshort start. Debug level was been raised as otherwise the journal was empty.

Revision history for this message
vodopad27 (family-gan) wrote :

Yes, i added
X-GNOME-Autostart-Delay=60
to ~/.config/autostart/Flameshot.desktop
and fixed an issue. Also i had issue with psensors and fixed with same approach.

Changed in flameshot (Ubuntu):
importance: Undecided → Low
Changed in gnome-shell-extension-appindicator (Ubuntu):
importance: Undecided → Low
Revision history for this message
Gerhard Beck (gerhardbeck-de) wrote :

I could fix it by downgrading to Version 33-1
I can also inform you, that also the nextcloud icon disappears and Nextcloud starts maximised instead of minimized

Revision history for this message
Kai Groner (kai-gronr) wrote :

I've also had this problem with the flameshot icon disappearing after upgrading to 20.04.

Reverting to gnome-shell-extension-appindicator 33-1 has fixed it for now, but having broken dependencies isn't good (even if things seem to be working).

Comments on https://github.com/flameshot-org/flameshot/issues/1206 also suggest this problem doesn't occur with the flameshot snap. Testing the deb package specifically may be a good idea.

Revision history for this message
Gerhard Beck (gerhardbeck-de) wrote :

But the problem is that it also affects e.g. the Nextcloud desktop client, so just using the snap package is not the solution

Revision history for this message
Vitali Müller (e-ma5l-u) wrote :

On my ubuntu 20.04, the bug affects nextcloud desktop client, the seafile desktop client and the Rocket.Chat desktop app. Downgrading to 33-1 fixes the issue.

Revision history for this message
Andrey Yermolayev (ayermolayev) wrote :

NextCloud client can be fixed by using the same approach — add
X-GNOME-Autostart-Delay=5
to the ~/.config/autostart/Nextcloud.desktop file.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.