Launching fish_config errors out on missing module

Bug #1867615 reported by Matthew Miller on 2020-03-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fish (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu Focal Fossa (development branch)
Release: 20.04

fish:
  Installed: 3.1.0-1
  Candidate: 3.1.0-1

Running fish_config within fish should launch a web page hosted locally that allows configuring the theme / prompt etc.

Instead of showing the web page, the command errors out with the following output:

Traceback (most recent call last):
  File "/usr/share/fish/tools/web_config/webconfig.py", line 11, in <module>
    from distutils.spawn import find_executable

Installing python3-distutils separately resolves the error above.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: fish 3.1.0-1
ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
Uname: Linux 5.4.0-14-generic x86_64
ApportVersion: 2.20.11-0ubuntu20
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Mar 16 07:33:12 2020
InstallationDate: Installed on 2020-03-14 (1 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200314)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/usr/bin/fish
SourcePackage: fish
UpgradeStatus: No upgrade log present (probably fresh install)

Matthew Miller (matt-dwg05) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fish (Ubuntu):
status: New → Confirmed
Matthew Miller (matt-dwg05) wrote :

This is fixed with the latest commit to fish in Debian (requires python3-distutils)

Logan Rosen (logan) wrote :

This is fixed in 3.1.0-1.2, which was synced into Fossa before it was released.

Changed in fish (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers