Please update the package to 2.1.10

Bug #590130 reported by Bhavani Shankar on 2010-06-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firmware-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firmware-tools

There is a new upstream version of the package available and it needs an update

Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Changed in firmware-tools (Ubuntu):
status: New → Confirmed
Charlie_Smotherman (cjsmo) wrote :

Please check your build logs:

/usr/bin/install -c -m 644 'firmwaretools/bootstrap_pci.py' '/tmp/buildd/firmware-tools-2.1.10/debian/firmware-tools//usr/lib/python2.6/site-packages/firmwaretools/bootstrap_pci.py'
 /usr/bin/install -c -m 644 'firmwaretools/dep_parser.py' '/tmp/buildd/firmware-tools-2.1.10/debian/firmware-tools//usr/lib/python2.6/site-packages/firmwaretools/dep_parser.py'
 /usr/bin/install -c -m 644 'firmwaretools/errors.py' '/tmp/buildd/firmware-tools-2.1.10/debian/firmware-tools//usr/lib/python2.6/site-packages/firmwaretools/errors.py'

it should install into /usr/lib/python2.6/dist-packages.... and not /usr/lib/python2.6/site-packages :)

It would also probably be a good idea to add python to Build-Depends-Indep.

Changed in firmware-tools (Ubuntu):
status: Confirmed → Incomplete
Bhavani Shankar (bhavi) wrote :

Ah Charlie

Overlooked :) sorry for that I ll take care of the python 2.6 transition

On it now

Regards

Changed in firmware-tools (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Bhavani Shankar (bhavi)
Bhavani Shankar (bhavi) wrote :

Hi Charlie,

Package is working fine according to this:

On 11 June 2010 07:19, Bhavani Shankar R <email address hidden> wrote:
>
> On Thu, Jun 10, 2010 at 9:23 PM, Dmitrijs Ledkovs
> <email address hidden> wrote:
>>
>> <snip>
>>
>> Control & pyversions would be better =) or the whole branch the best ;-)
>>
>> Depends wether it's just a python package or compiled extension.
>>
>> Generally just a rebuild with bumped up pyversions =)
>>
>

Why are you building Dell support package? Aren't they suppose to do it?

> Hello again!
>
> I followed your advice but it doesnt seem to work :(
>

I took current package firmware-tools_2.1.9-0ubuntu1 and it's
absolutely correct and python2.6 ready.

after you do "debuild", check debian/firmwaretools/

Notice that the python modules are in the correct pyshared dir & that
there are python-support private & public files.

On my machine I have python2.6 installed, so after I have compiled &
installed 2.1.9-0ubuntu1 everything was fine.

> Attached is the control file for your reference
>

Thanks now I know what package you are working on, and was able to
checkout latest available version from launchpad =)

> Thanks in advance for your help!
>

Your welcome. The 2.1.9-0ubuntu1 is absolutely fine.

And me too got confused with dist and site-packages

Regards

Changed in firmware-tools (Ubuntu):
status: In Progress → Confirmed
assignee: Bhavani Shankar (bhavi) → nobody
Charlie_Smotherman (cjsmo) wrote :

No it is not correct I refer you to Debian Python Policy section 1.5

http://www.debian.org/doc/packaging-manuals/python-policy/ch-python.html#s-paths

Have a nice day
Charlie

Changed in firmware-tools (Ubuntu):
status: Confirmed → Incomplete
Charlie_Smotherman (cjsmo) wrote :

After further research on my part I withdraw my previous statement.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firmware-tools - 2.1.10-0ubuntu1

---------------
firmware-tools (2.1.10-0ubuntu1) maverick; urgency=low

  * New upstream release LP: #590130
  * Bump standards-version to 3.8.4. No other changes
  * Switch to dpkg-source 3.0 (quilt) format
 -- Bhavani Shankar <email address hidden> Sat, 05 Jun 2010 21:09:13 +0530

Changed in firmware-tools (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches