upgrading 5.10 > 6.06 LTS fails on firestarter

Bug #48010 reported by wing on 2006-06-02
26
Affects Status Importance Assigned to Milestone
firestarter (Ubuntu)
Medium
Unassigned

Bug Description

started with gksudo "update-manager -d"
Accepted all default changes
It stopped when progressbar sayd "less than 1 minute" and reported:
Could not install 'firestarter'
The upgrade aborts now. Please report this bug.
subprocess post-installation script returned error exit status 2

terminal output of the installer:
root@erik-lap:/etc/ntlmaps# update-manager -d
/usr/lib/python2.4/site-packages/apt/__init__.py:17: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)
/usr/lib/python2.4/site-packages/UpdateManager/MetaRelease.py:171: DeprecationWarning: Class MetaRelease is already GObject-registered; Please note that classes containing any of the attributes __gtype_name__, __gproperties__, or __gsignals__ are now automatically registered.
  gobject.type_register(MetaRelease)
extracting '/tmp/tmpeTs0yM/dapper.tar.gz'
authenticate '/tmp/tmpeTs0yM/dapper.tar.gz' against '/tmp/tmpeTs0yM/dapper.tar.gz.gpg'
/usr/lib/python2.4/site-packages/apt/__init__.py:17: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)

after pressing ok, next screen shows:
Could not install the upgrades

The upgrade aborts now. Your system can be in an unusable state. A recovery was run (dpkg --configure -a).
installArchives() failed

after pressing Close, it exited. Before pressing I checked installers terminal window, but was unable to copy from there - it said something "starting firestarter [failed]".

if I then tried to start firestarter manually
( /etc/firestarter/firestarter.sh ) it reported:
External network device eth1 is not ready. Aborting..

hope this helps.

guessing package

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Can you please attach the files /var/log/dist-upgrade*.log to this bugreport?

Thanks,
 Michael

Changed in update-manager:
status: Unconfirmed → Needs Info

Sorry for the delay.

Changed in update-manager:
status: Needs Info → Unconfirmed
Jacob Godserv (fun2program8) wrote :

I also got this. I dist-upgraded from Feisty Herd 1 using GUI completely. It reported it couldn't Firestarter, but when I looked at the output (it was right at the end) I saw that it had merely failed in starting it using the init.d script.

I ran firestarter myself by running "sudo firestarter", and Firestarter gave me the following error:

A proper configuration for Firestarter was not
found. If you are running Firestarter from the directory you built it
in, run 'make install-data-local' to install a configuration, or simply
'make install' to install the whole program.

Firestarter will now close.

It appears to me whoever packaged this program didn't package the configurations as well. I'll attach the other logs as well.

Jacob Godserv (fun2program8) wrote :

OK, in that last post, I was a little "as well" happy. :P

Jacob Godserv (fun2program8) wrote :

Last log.

Prem Rara (fortran01) wrote :

System: upgrading from 6.06.1 LTS to Edgy Eft (6.10)

This is the error log in /var/log/dist-upgrade/apt.log:
ERROR: root: got an error from dpkg for pkg: 'firestarter': subprocess post-installation script returned error exit status 2.

To get more debugging message, I enabled the following flag and rerun dpkg:
export DEBCONF_DEBUG=developer; dpkg --configure -a

The error is related to firestarter failing to start its daemon. The error occurs when running the script /etc/init.d/firestarter start. To see more debugging message, remove the redirection of the following line in the init.d script /etc/init.d/firestarter start:
(commented:)
# $FS_CONTROL start > /dev/null
(new line:)
$FS_CONTROL start

The offending line is in the script /etc/firestarter/firestarter.sh. It aborts when any network interface called in /etc/firestarter/configuration is not yet initilized. In my case, it is eth1 (wlan). I just assigned an IP address to the offending interface.

The next offending line in /etc/firestarter/firestarter.sh is related to the DHCP not starting properly. Just disable DHCP for NATs when you enabled NAT in /etc/firestarter/configuration. In /etc/firestarter/configuration, set the following lines to off:

# Enable DHCP server for NAT clients
DHCP_SERVER="off"
# Forward server's DNS settings to clients in DHCP lease
DHCP_DYNAMIC_DNS="off"

Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. Furthermore, it affects firestarter not update-manager. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in update-manager:
status: New → Incomplete

Thanks,

Upgrade to Ibex went flawlessly, so I guess it's not a problem any
more and this can be closed.

best regards,
Erik

On Tue, Nov 18, 2008 at 3:18 PM, Jean-Baptiste Lallement
<email address hidden> wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. Furthermore, it affects firestarter not
> update-manager. We were wondering is this still an issue for you? Can
> you try with latest Ubuntu release? Thanks in advance.
>
> ** Changed in: firestarter (Ubuntu)
> Sourcepackagename: update-manager => firestarter
> Status: New => Incomplete
>
> --
> upgrading 5.10 > 6.06 LTS fails on firestarter
> https://bugs.launchpad.net/bugs/48010
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Thank you for following up. Im' closing this report due to your last comment. Don't hesitate to submit any new bug.

Changed in firestarter:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers