Firestarter fails to launch when run from Applications menu

Bug #34225 reported by Stuart Bishop
6
Affects Status Importance Assigned to Milestone
firestarter (Ubuntu)
Fix Released
Medium
MOTU

Bug Description

Firestarter refuses to start up, reporting that it is unable to open the display. I believe this is because the DISPLAY environment variable is being stripped by gksudo.

A workaround is to run gksudo env DISPLAY=:0 firestarter instead.

Changed in firestarter:
assignee: nobody → motu
Revision history for this message
Mantas Kriaučiūnas (mantas) wrote : Firestarter starts fine when run from Applications menu

Firestarter starts fine when run from Applications menu on my Ubuntu 5.10 (Breezy) system with backported gksu 1.3.6-1ubuntu7 package.

But one problem with desktop launcher is still not solved firestarter.desktop file still uses gksudo instead of gksu, in firestarter.desktop should be:

gksu /usr/sbin/firestarter

This is because gksu package is in sudo mode as default in ubuntu, look at bug #30057 for more info

Revision history for this message
Barry deFreese (bddebian) wrote :

Fixed .desktop file. Uploaded

Changed in firestarter:
status: Unconfirmed → Fix Committed
Revision history for this message
Loic Pefferkorn (loic) wrote :

built on all archs

Changed in firestarter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers