devanagari font rendering broken in firefox 2.0.0.3

Bug #99283 reported by Ajit Datar on 2007-03-31
2
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Mozilla Bugs

Bug Description

Binary package hint: firefox

Steps to reproduce
1. Install Kubuntu Feisty Fawn herd 5
2. Install firefox
3. Install libpango
4. In a shell do "export MOZ_ENABLE_PANGO=1 && firefox"
5. visit any devanagari site (eg http://hi.wikipedia.org/)
6. text like "हिन्दी विकिपीडिया" is not rendered properly, it used to render correctly on earlier versions of kubuntu and ubuntu when the MOZ_ENABLE_PANGO variable was set

---
Kubuntu version info
$ uname -a
Linux 2.6.20-12-generic #2 SMP Wed Mar 21 20:55:46 UTC 2007 i686 GNU/Linux

--
Firefox versionn info
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)

On Sat, Mar 31, 2007 at 04:01:02AM -0000, Ajit Datar wrote:
> Public bug reported:
>
> Binary package hint: firefox
>
> Steps to reproduce
> 1. Install Kubuntu Feisty Fawn herd 5
> 2. Install firefox
> 3. Install libpango
> 4. In a shell do "export MOZ_ENABLE_PANGO=1 && firefox"
> 5. visit any devanagari site (eg http://hi.wikipedia.org/)
> 6. text like "हिन्दी विकिपीडिया" is not rendered properly, it used to render correctly on earlier versions of kubuntu and ubuntu when the MOZ_ENABLE_PANGO variable was set
>

What language is this?

 - Alexander

Ajit Datar (ajitdatar) wrote :

The example provided in the bug is in Hindi. Devanagari script is used
in many Indic languages such as Hindi, Marathi, Sanskrit, Marwari,
Nepali ... (http://en.wikipedia.org/wiki/Devanagari)

Ajit

On 4/1/07, Alexander Sack <email address hidden> wrote:
> On Sat, Mar 31, 2007 at 04:01:02AM -0000, Ajit Datar wrote:
> > Public bug reported:
> >
> > Binary package hint: firefox
> >
> > Steps to reproduce
> > 1. Install Kubuntu Feisty Fawn herd 5
> > 2. Install firefox
> > 3. Install libpango
> > 4. In a shell do "export MOZ_ENABLE_PANGO=1 && firefox"
> > 5. visit any devanagari site (eg http://hi.wikipedia.org/)
> > 6. text like "हिन्दी विकिपीडिया" is not rendered properly, it used to render correctly on earlier versions of kubuntu and ubuntu when the MOZ_ENABLE_PANGO variable was set
> >
>
> What language is this?
>
> - Alexander
>
> --
> devanagari font rendering broken in firefox 2.0.0.3
> https://launchpad.net/bugs/99283
>

Ajit Datar (ajitdatar) wrote :

about:buildconfig shows that firefox was compiled with --enable-pango

--------------
about:buildconfig

Build platform
target
i486-pc-linux-gnu

Build tools
Compiler Version Compiler flags
gcc gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4) -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -pthread -pipe
c++ gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4) -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -fshort-wchar -pthread -pipe

Configure arguments
--host=i486-linux-gnu --build=i486-linux-gnu --prefix=/usr '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' --enable-default-toolkit=gtk2 --with-default-mozilla-five-home=/usr/lib/firefox --enable-pango --with-user-appdir=.mozilla --with-system-png=/usr --with-system-jpeg=/usr --disable-mailnews --disable-composer --disable-ldap --enable-postscript --disable-installer --disable-xprint --enable-crypto --disable-strip --disable-strip-libs --enable-canvas --enable-svg --enable-svg-renderer=cairo --enable-system-cairo --enable-mathml --disable-tests --disable-gtktest --disable-debug --enable-xft '--enable-optimize=-pipe\ -w\ -O2\ -g\ -fno-strict-aliasing' --with-system-zlib=/usr --without-system-nspr --enable-xinerama --enable-extensions=default --disable-pedantic --disable-long-long-warning --enable-single-profile --disable-profilesharing --enable-gnomevfs --enable-application=browser --disable-installer --disable-updater --enable-chrome-format=flat --disable-elf-dynstr-gc --enable-system-myspell --enable-libthai --with-distribution-id=com.ubuntu --enable-official-branding
--------------

Changed in firefox:
assignee: nobody → mozilla-bugs
status: Unconfirmed → Needs Info
Amit Tendulkar (amit-tendulkar) wrote :

This issue is also reproducible for me on Ubuntu 7.04 (Feisty Fawn)

Amit Tendulkar (amit-tendulkar) wrote :

This issue is not reproducible on Galeon web browser. So it is a firefox related issue.

Ajit Datar (ajitdatar) wrote :

Devanagari rendering is WORKING CORRECTLY for me after I did a clean install of Feisty Fawn and installed language support for Hindi and Marathi. :)

I don't have MOZ_ENABLE_PANGO=1 in my environment.

Although I am not able to figure out why it didn't work before, status of the bug is now 'Works for me'.

Changed in firefox:
status: Needs Info → Unconfirmed
Ajit Datar (ajitdatar) wrote :

Devanagari rendering is WORKING CORRECTLY for me after I did a clean install of Feisty Fawn and installed language support for Hindi and Marathi. :) I don't have MOZ_ENABLE_PANGO=1 in my environment. Although I am not able to figure out why it didn't work before, status of the bug is now 'Works for me'.

Ajit Datar (ajitdatar) on 2007-06-15
Changed in firefox:
status: Unconfirmed → Confirmed

Closed as seems that it has been fixed for the OP after last update.

Changed in firefox:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers